1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tivo series 3hd has no video

Discussion in 'TiVo Series3 HDTV DVRs' started by zena, Jul 20, 2013.

  1. zena

    zena New Member

    2
    0
    Jul 20, 2013

    We read the posts and went with suggestions. So we replaced the power supply ~ that wasn't the problem. The fan worked, so that wasn't the problem. We finally figured out it was the HDMI port. How can we replace that? Do we have to un-soder it from another motherboard and re-soder it to ours? Can that be done without damaging the m/board?
     
  2. atmuscarella

    atmuscarella Active Member

    5,726
    20
    Oct 11, 2005
    Rochester NY
    No idea if fixing a dead HDMI port is a do it your self project or not. You could contact Weaknees and see if they can help or you could just take the easy way out and use the component output which is HD, that is what I would do and then upgrade the next time TiVo gives you a good Offer.

    Good Luck
     
  3. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    It may not be the actual jack that can be accessed from outside the chassis, but the circuitry connected to it, and unfortunately a lack of available service information makes TiVo motherboard repair an unlikely prospect.
     
  4. wtkflhn

    wtkflhn Member

    190
    3
    May 12, 2006
    Metairie, La
    Since you are trying so hard to save the S3, I assume you have lifetime service on it. I think I would contact TIVO and see if they will swap it out for you. They used to do this for about $75. They would move the lifetime to the new box and you would return the old one. That's what I would try. If you try to change the mother board, you would lose the lifetime anyway.

    Good luck.
     

Share This Page