1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Roamio Plus Dead After 4 days

Discussion in 'TiVo Roamio DVRs' started by takeagabu, Sep 13, 2013.

  1. jmpage2

    jmpage2 New Member

    1,951
    0
    Jan 20, 2004
    That's actually pretty understandable under the circumstances but if it will be a long delay you should tell them you refuse package delivery and ask TiVo to send you another one. TiVo might offer to do this anyway since even if the package visibly looks okay it was knocked around like that.
     
  2. HarperVision

    HarperVision TiVo's Italian Cuz!

    5,275
    3
    May 14, 2007
    Paradise...
    Was there a kangaroo driving the other vehicle by chance?

    All kidding aside, I agree with jmpage2, you should have them send a new TiVo just in case.
     
  3. takeagabu

    takeagabu New Member

    119
    0
    Oct 7, 2007
    Finally got the Tivo. Cablecard won't pair! This is killing me.
     
  4. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,443
    164
    Apr 17, 2000
    Nevada
    CableCARDs are a PITA!!!!

    A few months ago I bought my Sister a used S3 to replace an old S2 she had. The first card she got didn't work at all. Just sat on the "acquiring channel info" screen. She took that back and got a second one. The second one worked but wouldn't pair so she didn't get any Premium channels. I called like a half dozen times trying to get it paired, but nothing worked so they sent a tech. The tech showed up, called someone on his walkie-talkie and had it paired in 2 minutes. She liked the HD unit so much I bought her another one to replace her other S3 unit. Same problem. The card worked OK but no one could get it paired. Since it only effected the premium channels and the other one was working she told me not to worry about it. Well a couple weeks ago they made a change and started encrypting almost every channel so now that TiVo was basically useless. So I called in for her to try and get it paired. Still no dice so they sent a tech. The tech didn't have any cards so he rewires everything hoping that'll help, calls into his guy a few times, still not working. Then he calls his guy one last time and they verify everything. Everything looks OK so the guy says... "let me start over and redo this card as if it's new". 2 minutes later it starts working.

    On the other hand when I got my Roamio I moved it from my Elite and called in, expecting it to be a hassle, and they had it up and running in 10 minutes. So it seems to be luck of the draw.
     
  5. ggieseke

    ggieseke Active Member

    4,020
    11
    May 30, 2008
    This morning UPS said delivery by the end of today. Now it says "An exception in the sorting process has occurred. UPS has taken corrective action." and it's rescheduled for tomorrow.

    Darn that forklift-driving kangaroo.
     
  6. JasonD

    JasonD New Member

    269
    0
    Mar 30, 2003
    San Diego
    On my Roamio cable card wouldn't pair, they sent a tech and he had it paired within twenty minutes. Overall pretty good service from Cox
     
  7. HarperVision

    HarperVision TiVo's Italian Cuz!

    5,275
    3
    May 14, 2007
    Paradise...
    Haha, Now you got the spirit ggieseke! :p
     

Share This Page