1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tivo remote access tool - pre BETA

Discussion in 'TiVo Underground' started by tivoupgrade, Aug 22, 2006.

I am testing the tool on the following platforms:

  1. Series1 Standalone Unit

    13.1%
  2. Series1 DirecTV Unit

    3.4%
  3. Series2 DirecTV SD Unit

    48.0%
  4. Series2 DirecTV HD Unit

    20.4%
  5. Series2 Standalone Unit

    25.6%
Multiple votes are allowed.
  1. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    Francesco - I'm not certain on the 2.5 issue because I don't have access to a modded unit. The error suggests that one of the configuration files may be missing, but beyond that, I really can't say.

    If someone would be willing to donate a modded 2.5 system for a period of time, or even give me telnet/ftp access to it, I could mess with it a bit; but not until next week at the earliest. I'm in meeting in CA right now and then off for the labor day weekend. (I can't tell you what the meetings are about, but they are all good ones and very much related to this project) :)

    Lou
     
  2. puffdaddy

    puffdaddy Member

    295
    0
    Mar 1, 2006
    You're in Alviso, CA you say? ;)
     
  3. Francesco

    Francesco Summum Pontificem

    18,365
    0
    Oct 4, 1999
    Maricopa...
    If you tell me how next week, I will gladly let you remote in and see what's inside my TCD540 (and what mundane stuff it's used for right now off local cable). :)
     
  4. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    no, actually not, sorry to say; i have some friends there, but no time this week for a visit such as that...

    ... i'm actually in palo alto... see next post for an update...
     
  5. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    I'll be in touch... basically - it'll be "old school" access -- map ports 21 and 23 on your router to the ip address of your TiVo, then provide your external ip address - you should be able to test this from a dos prompt and going to your external ip address using telnet and ftp...
     
  6. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    ... I've just spoken with one of the developers who confirmed that he too made a change on the server that may very much have affected things. I won't go into the details, but after discussing, I can see why you may have noticed a difference.

    If you all would, please... especially those of you who might be getting disconnects, please BEAT ON THE SYSTEM, and do some crazy things like resetting your routers, unplugging your cable modems, etc.

    One thing to keep in mind is that if you get a disconnect message, the tivo should be periodically trying to reestablish a connection - so give it a minute or two and try reloading the page before giving up and rebooting your system (which will almost certainly work, but is not a recommended solution).

    Lastly, if you still consistently get a "tivo disconnected" message, please do a PS on your unit and verify that the client is running (or not running). I am still wondering about whether there are multiple issues here, and whether we need to do some things on the client side to ensure the process isn't completely bombing out...

    Lou
     
  7. mgmrick

    mgmrick Haven't broke yet

    399
    0
    Aug 28, 2002
    Port Byron...
    Are we onto something here? All 4 of my units where disconnected yesterday....all 4 work today. This is without me rebooting them. There uptime is 2days 10 hours

    4 units hacked using zipper and rbautch's scripts

    Thanks
    Rick
     
  8. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    Very good to know. Will try to contain myself and wait for more feedback, but I'm liking the sound of these initial comments.
     
  9. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    mgmrick - how did you register four units, with two accounts?

    [edit] - I've increased the number of units which can be registered to FIVE, for now.
     
  10. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Thanks for increasing the number of Tivos! My DSR7000 and HR10-250 have been running fine for about a day now. No disconnects. Another DSR7000 refuses to connect and throws an error that looks like this:
    Code:
    *** No response from connection server ***
    I reinstalled the client, to no avail If nobody else is getting this, the problem is probably on my end.
     
  11. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    That sounds like your TiVo cannot find our server. Did you install the client directly from the server using the standard instructions? If so, then its odd that you would get this message. See if you can ping the ip address and/or try reinstalling the client again and that may do the trick. More importantly, if you get any errors when attempting to re-install the client, take a closer look - check to be sure there is a route through your gateway, etc...
     
  12. mgmrick

    mgmrick Haven't broke yet

    399
    0
    Aug 28, 2002
    Port Byron...
    Ptvupgrade,

    I created 2 accounts...but I can now go back and add the 4th unit won't need 2 accounts. As you can probally tell us hackers have quite a few hacked tivo's and 3 was not enough

    Thanks
    Rick
     
  13. jasch

    jasch New Member

    310
    0
    Jun 8, 2001
    Hear Hear. I have 6 tivos at home.
     
  14. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    ok - i've increased the limit, temporarily, to SIX.

    to those of you who have registered more than one account - can you please do the following:

    1) remove each tivo you've registered from your secondary account
    2) recreate each tivo into your primary account
    3) pm me with the email address of your secondary account so i can remove it

    this will be a good test of some of the administrative functionality

    Later, I am going to reduce the number of registerable units for a brief period, to see how this affects folks, so please be prepared...
     
  15. mgmrick

    mgmrick Haven't broke yet

    399
    0
    Aug 28, 2002
    Port Byron...
    Pm sent removed and added

    Back to disconects with out any input on my side.

    Thanks
    Rick
     
  16. tbeckner

    tbeckner TiVo Fan

    1,352
    0
    Oct 26, 2001
    Bend, OR, USA
    3COM 3CR870, which allows me to specify outgoing access. Most business level routers allow you to control access in both directions.

    In addition, Surf Control Content Filtering, Block/Allow Lists, IPSEC/L2TP-IPSEC/PPTP and Passthrough VPN support, SPI Firewall tuning, Traffic Shaping, etc. :)
     
  17. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    So far I have had ZERO disconnects over the past two days (approx 10 logins) on five different machines. Whatever you did fixed things for me, at least so far. Thanks again for this great tool! :up:
     
  18. Draven X. Byrne

    Draven X. Byrne Pope to the TiVos

    316
    0
    Jun 2, 2003
    Hailing...
    As well as I. I also purposely messed with stuff like just unplugging the NIC, leaving it unplugged for an hour, etc.

    Once I plugged it back, it would reconnect under 10 -15 minutes.

    Looks like it's rockin' now!

    DXB
     
  19. mgmrick

    mgmrick Haven't broke yet

    399
    0
    Aug 28, 2002
    Port Byron...
    Mine are all working (4) tonite. However they did reboot last nite as as scheduled

    Rick
     
  20. kewashi

    kewashi New Member

    38
    0
    Mar 11, 2006
    Lou -- I've had no disconnects for the past several days. Although I still can't view my programs from TWP through the gotomydvr service. I think my vserver isn't working quite right. Anyway I thought you'd like to know that I reset my router and also logged in from a hotel and everything worked very smoothly. I even got to my tivo from the airport network before I got on the plane on my flight home. By the way -- I was just in Palo Alto and Sunnyvale earlier this week --- gee... maybe I should have waved at you when I was driving on S Hwy 101...
     

Share This Page