1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Refresh not working with kmttg Windows 7

Discussion in 'TiVo Roamio DVRs' started by deac33, Jul 9, 2014.

  1. deac33

    deac33 Member

    42
    0
    Sep 28, 2013
    I have two Mac computers running Parallels with Windows 7 Ultimate and kmttg v1.1a and tools v1.1a and both fail to respond to the Refresh button.

    Mac 1, Macbook Air:
    I have installed kmttg both on the MacOS side (Refresh works fine there) and in Windows 7 Parallels where Refresh does not work.

    The Win 7 kmttg is a new install and has never worked. It issues curl error 35. I'm checked MAK & IP settings as suggested, same MAK as the MAC kmttg and same network. Windows can ping the Tivo IP address.
    Did I miss something in the install procedure?



    Mac 2, Mac Mini:
    This is an old install of Win 7 kmttg that has worked very well until yesterday. I've been happily running kmttg v1.1a_beta for weeks and Refresh worked until yesterday on it. I did nothing before the breakage. After Refresh quit working I noticed the full release version of v1.1a so I just updated to it with no change (also tools v1.1a now). Using the same MAK as when it worked and I can ping the Tivo inside Win 7 command tool.

    No error message here, it just cranks on "playlist", over 15 minutes on the current iteration with no output while the Mac kmttg on Mac 1 has responded in the usual 45 seconds or so.

    I don't know if it matters, but the healthy Mac kmttg shows "running" under STATUS, but the Mac 2's bad program shows an incrementing timer. Oh, wait, it did finally time out with curl error 28 SSL connection timeout. Did I break the SSL settings somehow?
    What should I do next?
     
  2. moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Try other methods of obtaining listings besides curl:
    Config-Program Options-Use Java for downloads instead of curl

    If you have series 4 or later units you can also try:
    Config-Program Options-Use RPC to get NPL when possible

    If those work and curl doesn't then it's likely an Antivirus and/or firewall related problem.
     
  3. deac33

    deac33 Member

    42
    0
    Sep 28, 2013
    It turned out to be my Tivo connected via switch instead of direct to the router, that after it had been working on the switch.

    So despite being able to see the Tivo via ping, etc., it was Tivo network problem and not kmttg at all and corrected by connecting Tivo to the router.

    Thanks so much for the suggestions, I'll keep them in case I ever have this problem again.

    -deac
    ;-)
     

Share This Page