1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TiVo Net Controller for PC - Windows 7/Vista

Discussion in 'VirginMedia TV with TiVo - UK' started by apwheeler, Nov 20, 2011.

  1. Big Al

    Big Al New Member

    4
    0
    Dec 3, 2002
    London
    Fired this up and it worked 1st time (Windows 7) Nice little app, agree that there's lots of development potential. Have already been winding SWIMBO and the Kids up with it. ;o)

    THANKS !!!!!
     
  2. Paul Webster

    Paul Webster Member

    51
    0
    Nov 16, 2003
    UK
    Does the Ethernet address (not the cable modem one) look similar to the IP address of your desktop machine?
    Typically (but not necessarily) something like 192.168.1.xxx
     
  3. Tony Hoyle

    Tony Hoyle Geek

    646
    0
    Apr 1, 2002
    Manchester
    The port configuration test always fails.. ignore it.

    Tivo will only talk to something within its own network* - and it also appears to be hardcoded to reject an IP not starting 192.168 (which caused *major* ballache on my network) - however you'll know if this is your problem as it'll keep messaging you about disabling the network every 5 minutes..!

    If you go into settings/network the IP you want is under 'Ethernet connection details'.

    * To simplify, in the common case the first 3 numbers need to be identical.
     
  4. stevelup

    stevelup New Member

    64
    0
    Jun 4, 2002
    It's currently showing 169 because it isn't connected. Once you have it successfully connected, the TiVo will change to show a 192 address.
     
  5. cwaring

    cwaring VM Tivo User

    9,015
    0
    Feb 11, 2002
    Knaresboroug...
    Ahh. Right. Yes. Of course :) Now all I have to do is find my Netgear bridge. It's here somewhere!
     
  6. dawn_mcgowan

    dawn_mcgowan New Member

    6
    0
    Nov 24, 2011
    my ethernet ip on the tivo begins 169. the ip on my laptop begins 192. whenever i enter the tivo ip into the remote control app it says 'not responding' for ages, and then says it cannot connect. p***ing me off now!
     
  7. dawn_mcgowan

    dawn_mcgowan New Member

    6
    0
    Nov 24, 2011
    also in the settings on tivo it mentions having to put in the media access key into each device for it to work. ive found the MAK on the tivo settings, but where do i enter that on my laptop / in the app??
     
  8. dawn_mcgowan

    dawn_mcgowan New Member

    6
    0
    Nov 24, 2011
    hold on.....is tivo wifi enabled, or do i need to physically plug a cable between my laptop and the tivo box?
     
  9. cwaring

    cwaring VM Tivo User

    9,015
    0
    Feb 11, 2002
    Knaresboroug...
    No it isn't.
     
  10. Paul Webster

    Paul Webster Member

    51
    0
    Nov 16, 2003
    UK
    169... implies that the device timed out on getting an address via DHCP.
    As you guessed ... no WIFi on a TiVo. You need Ethernet connection to something.
     
  11. brightonjohn

    brightonjohn New Member

    79
    0
    Mar 3, 2011
    I'm a bit confused as to why my KLG-575 KCORP Router doesn't show my TiVo In the IP Address Table and yet all otherwise works perfectly. :confused:
     
  12. dawn_mcgowan

    dawn_mcgowan New Member

    6
    0
    Nov 24, 2011
    thanks for your help guys. i'm a bit embarrassed now. how stupid of me. xx
     
  13. apwheeler

    apwheeler New Member

    23
    0
    Feb 3, 2011
    I have created version 0.03

    However I am currently in India for work so have not been able to check it against my own TiVo. So if someone could check it works ok and let me know, that would be great.

    Should work on XP/Vista/Windows 7 as long as you have .NET 4 installed.

    * The app now remembers the IP address of your TiVo
    * Shortcut keys added to each Remote Command
    * Can show or hide the Virgin Online TV guide within the app.
    * Added TiVo icon (Thanks to Stiggles Digitalspy Forum)
    * Added full channel list (Thanks to Stiggles)
    * Place the mouse over the Remote Button and it will show you the corresponding shortcut key.

    Following Shortcut keys provide the following functions
    CTRL+H - Home
    CTRL+T - TV
    CTRL+G - TV Guide
    CTRL+P - Play
    CTRL+S - Stop
    CTRL+M - My Shows
    CTRL+V - Pause
    CTRL+R - Record
    CTRL+L - Last Channel
    CTRL+I - Info
    CTRL+U - Thumbs Up
    CTRL+D - Thumbs Down
    CTRL+F - Skip
    CTRL+B - Skip Back
    CTRL+X - Slow
    CTRL+LEFT - Rewind
    CTRL+RIGHT - Fast Forward
    ENTER - OK
    DELETE - Clear
    + - Channel Up
    - - Channel Down
    1 to 9 - Send corresponding Number
    A to Z - Send corresponding Key when in a text search (Search TV, YouTube search etc.)

    The latest version can be found on my website
    Http://www.andypwheeler.pwp.blueyonder.co.uk/tivoremote
     
  14. brightonjohn

    brightonjohn New Member

    79
    0
    Mar 3, 2011
    Thanks for continued development Andy.
    The remote control side of the app works as intended and remembers IP address now.
    But I get

    "The website declined to show this webpage
    HTTP 403
    Most likely causes:
    This website requires you to log in.

    What you can try:
    Go back to the previous page.

    More information "

    Once clicking on 'Go back to the previous page' seemed to work and then the next time I got a page forbidden message and the time after that just a blank page. I wonder what others are finding?
     
  15. brightonjohn

    brightonjohn New Member

    79
    0
    Mar 3, 2011
    A ReBoot of the router seems to have sorted this out - I don't see any other way of refreshing its IP Address List at the moment - so research needed there!:eek:
     
  16. apwheeler

    apwheeler New Member

    23
    0
    Feb 3, 2011
    Hmmm... didn't realise you have to log in to access the Virgin TV Guide. The app is set to navigate to www.virginmedia.com/tvguide.

    Not had feedback from anyone else yet, you are the first.
     
  17. brightonjohn

    brightonjohn New Member

    79
    0
    Mar 3, 2011
    That's right - so this time I clicked on the previous page link and then managed to login and it worked correctly. But as things stand I guess I will have to carry on doing that. Still a nice app though!:)
     
  18. apwheeler

    apwheeler New Member

    23
    0
    Feb 3, 2011
    I think once you sign in once it remembers you in the future.
    Thanks for confirming the remote side is all working, as I was unable to test it.
     
  19. brightonjohn

    brightonjohn New Member

    79
    0
    Mar 3, 2011
    The remote side certainly works but the logging in and connection to the VM site actually doesn't as this time, having exited and then restarted the app all I got to the right was a blank screen. HOWEVER I suspect that this has more to do with flaky work at the VM end as this site has been a pain from the outset!!
     
  20. cwaring

    cwaring VM Tivo User

    9,015
    0
    Feb 11, 2002
    Knaresboroug...
    You only need to login to use the Guide to set recordings on your Tivo.
     

Share This Page