1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Mini "Can't Watch Now" Message

Discussion in 'TiVo Help Center' started by NotAlreadyInUse, Jun 15, 2013.

  1. NotAlreadyInUse

    NotAlreadyInUse New Member

    1
    0
    Jun 15, 2013
    Just thought I'd post that I'd been receiving a Can't Watch Now (V125) message on my Tivo Mini when I would try to watch a recorded show (Live TV worked fine). The message indicated that there was a problem with my Premiere connecting to the network, so I spent a long time messing with that box (connecting to Tivo Service, Restarting, network diagnostics...).

    Then I connected the Mini to the Tivo Service (hoping it would resolve some incompatibility between software versions) but that didn't help either.

    Finally, I restarted the Mini itself, and then I was able to view recorded shows as I could before.

    I'm not positive that this would have resolved the issue immediately, but I guess that it would.

    Hopefully this could save somebody else some time.
     
  2. Oct 2, 2013 #2 of 10
    sozler

    sozler New Member

    13
    0
    Jan 15, 2009
    Thanks for the suggestion. It also resolves my issue, so I don't need to do anything on the Roamio. However, I have to do this once every night.

    My Mini is connected through Ethernet.

    If anyone has any other solutions, please let me know.
     
  3. Oct 4, 2013 #3 of 10
    kherr

    kherr Member

    137
    0
    Aug 1, 2006
    .... "Green" switch issue ????????? .....
     
  4. Oct 5, 2013 #4 of 10
    sozler

    sozler New Member

    13
    0
    Jan 15, 2009
    Actually, mine turned out to be a DHCP issue. After posting my issue above, I left Wireshark capturing anything that my TiVos broadcast for a day. Roamio has two IP addresses assigned to two consecutive MACs. One of them changed its IP during the day, but I have no idea why the DHCP server did not re-assign the same IP. After that change, Mini could see My Shows, but could not play any of them. Live TV was also not working.

    This happened with a Netgear router, so maybe other routers would have been smarter about assigning the same IP to the same MAC even without static allocation.

    Also, I do not know why Mini could not play after Roamio's one of the IPs changed, it should've caught the new TiVoConnect beacon in my opinion (sounds ignorant?).

    In short, I went to my router settings, assigned a static IP to all TiVo MACs including even the Mini. It has been working just fine since then (it's been 2 days). Yay!
     
  5. russellg99

    russellg99 New Member

    7
    0
    Apr 5, 2012
    Giving both the Mini and the Roamio Plus a static IP fixed this problem for me. I had already assigned a static IP on the Roamio -- which may have been part of the problem, I don't know. But after assigning one on the Mini as well, it immediately fixed the problem of not being able to play recorded shows on the Roamio.

    Thanks,
    Russell
     
  6. Caseman171

    Caseman171 New Member

    4
    0
    Mar 8, 2014
    Had issues with my TiVo (v112) error. Seems like the static IP fix worked
     
  7. stevepowell

    stevepowell New Member

    1
    0
    Dec 28, 2014
    To temporarily fix the issue. ...instead of getting out of bed and unplugging the mini and waiting several minutes for it to reboot :) .... go into settings, network, change network settings and then just specify your connection info again without changing anything. This will allow you to watch shows again. ..until the roamio changes its ip again the next night.
     
  8. jojomorales

    jojomorales New Member

    7
    0
    Dec 21, 2014
    I had the same issue yesterday. I restarted the mini and all was well. Are you saying that this could happen daily?
     
  9. solomita

    solomita New Member

    35
    0
    Oct 12, 2002
    Somehow this bug is still persisting 2.5 years later... Not a good sign for TiVo support.

    We're having this problem now every day. I'm very confused about something an earlier poster said:

    "Roamio has two IP addresses assigned to two consecutive MAC"

    Did one Roamio use 2 different MAC addresses? That's very broken. How did you determine the 2 MAC addresses and that they're related?
     
  10. ej42137

    ej42137 Active Member

    2,170
    3
    Feb 15, 2014
    Los Angeles
    The builtin Stream in a Roamio has its own address; I understand that Bolts have consolidated the Stream function more so that a Bolt only has one address.

    If for some reason you need to know which is which, turn the box over and the MAC addresses will be listed for you. Another way to identify the Stream address is that it is not the address that you configured under Network Settings, if you used a static address there. (This is something stevepowel upstairs should to to circumvent his problem.)

    I myself like to keep track of things in my network, so before I hookup a new piece of gear I aways give it a name and enter the MAC in my router's DHCP table.
     

Share This Page