1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TiVo HDs, no sub, working, but bad HDMI ports, GOOD PARTS SOURCE, GOOD POWER SUPPLIES

Discussion in 'Buyer/Seller Area' started by nooneuknow, Dec 3, 2013.

  1. nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    Save on shipping by buying only the parts you need.

    PM me if interested, or post here if you don't have the required posts to PM.

    Link to the "Good buying experience with nooneuknow thread": http://www.tivocommunity.com/tivo-vb/showthread.php?t=517648
     
  2. Tobashadow

    Tobashadow Read over there --->

    2,339
    0
    Nov 11, 2006
    Do the component connections still work?
     
  3. nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
  4. Tobashadow

    Tobashadow Read over there --->

    2,339
    0
    Nov 11, 2006
    If they are functional what do you want for them as whole units for me to use?
     
  5. dslunceford

    dslunceford Active Member

    5,703
    15
    Oct 19, 2000
    No. VA/D.C.
    Just a note that given you've upgraded to a Roamio, you may be able to get $99 lifetime on the HD if you ask TiVo for it.

    I sold my unit in same condition, stock drive but w/Lifetime, for $234 shipped on eBay last month. Got $240 shipped for another THD where the HDMI still worked...
     
  6. nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
  7. nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    Pictures now available:
     

Share This Page