1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Desktop refuses to use network drive

Discussion in 'TiVo Home Media Features & TiVoToGo' started by lpoulsen, May 22, 2006.

  1. CuriousMark

    CuriousMark Forum Denizen

    Jan 13, 2005
    I have added a note to my NAS hacking page to warn people that it will no longer help them if they are using current versions of TiVo Desktop.
  2. Injuhneer

    Injuhneer New Member

    Apr 27, 2008
    Indeed. I upgraded to 2.6.1 from a 2.3 rev and suddenly all UNCs don't work. That sux.
  3. Injuhneer

    Injuhneer New Member

    Apr 27, 2008
    Not for me. I have XP Pro and Win2k3 Server. The desktop.ini is visible and cn be opened for edited. The file is fine. The TD prefs simply won't allow me to select any network resource for MTR.

    I am testing a solution now:

    Shut down TD.

    I have gone into the registry in XP and modified the HKCU/Software/Tivo/Desktop/Modules/TivoNowPlaying/config/LocalRootPath value to reflect the mapped drive path.

    When I launched TD it said the drive was missing or moved and the slection dialog appeared. I selected the mapped network drive and the OK buttong un-greyed.

    I clicked OK and waited a few moments. The contents of the network drive now appear in the Now Playing List.

    Next is to set up some transfers and see what happens.
  4. mitchc

    mitchc New Member

    Mar 31, 2008
    on my buffalo terrastation pro I am able to store my music and photos and tivo desktop works fine...I can access thru any of 4 tivos in the house over the network. the videos though i cannot store on the nas as is discussed in the forums.

    if your edit of the registry works, would you please post the details.
  5. gvegastiger

    gvegastiger New Member

    Apr 30, 2008
    This may be a dumb quesiton, but has anyone gotten their Tivo's to read movie files off a NAS drive using TD on a Mac?

    I tried just changing the location but my S2 doesn't see any files. I haven't tried the shortcut option yet but will this evening. Has anyone done this yet? I have a Simpleshare NAS 500 GB and want to use it to store my DVD collection on.
  6. acheslow

    acheslow New Member

    Dec 14, 2000
    Bothell, WA
    This worked for me on Vista with a ReadyNAS. Thanks!!
  7. wlk

    wlk New Member

    Apr 3, 2008
    Unfortunately, it didn't work for me (XP) with unRAID. The dialog box popped up (after modifying the registry) and the new mapped network drive was highlighted. After clicking the "OK" button, however, the dialog box popped right back up again. If I highlighted another drive letter, the OK box grayed out and I could no longer select my mapped network drive.
  8. wlk

    wlk New Member

    Apr 3, 2008
    FYI. I just upgraded to unRAID v4.3.3 (Samba 3.0.28a), but no joy.
  9. fatavatar

    fatavatar New Member

    Oct 9, 2008
    I was able to get this to work with unRaid by creating symbolic link in Vista to the unRaid mapped drive. (It seemed to take a few tries however). I'm not sure if you can do the same thing with an NTFS junction in XP or not. I'm not sure XP supports symbolic links.
  10. kmackenz

    kmackenz KMACK

    Aug 22, 2003
    Worked for me on a LinkStation Live with Vista! Thanks!!!!:up::up:

  11. kmackenz

    kmackenz KMACK

    Aug 22, 2003

    Never mind... Now it keeps asking to pick the folder after saying OK! I was replied too quick! Was excited to see the non-grayed out OK.
  12. MikeAndrews

    MikeAndrews Registered abuser

    Ummmm. curl in kmttg works writing to a network drive.

    The only problem I had was curl complaining about mismatched file sizes on shows > 4GB but I was going from a Windows XP PC to a drive mounted from an Apple Time Capsule. A lot of tempting fate there but it worked fine for a long while.

    I think curl writes 4GB after buffering and it was not fast enough. .... Now that I think about it, I had the problem when I moved the PC to a 100mb switch from a 1000mb link right on the Time Capsule. Idea! :p
  13. Gregor

    Gregor Active Member

    Feb 18, 2002
    Trying to do this now with a DLINK DNS-321. Tried the registry hack, no go. Ideas?
  14. mkinnuca

    mkinnuca New Member

    Apr 3, 2009
    I have the same problem. I use an HP mediasmart server. As a workaround I use Smart Sync Pro software to move the tivo files from my laptop to the server.
  15. Matt J.

    Matt J. New Member

    Feb 18, 2010
    This fixed it for me. I'm running TiVo Desktop 2.8 on Windows 7 and using an Intel SS4200-E for the NAS.

    Here's what worked.
    1. Copy the "My Tivo Recordings" from the default location to its new home on the NAS. Make sure you include the desktop.ini in the copy. (As mentioned this is hidden by default)
    2. Regedit and modify "LocalRootPath" under "HKEY_CURRENT_USER\Software\TiVo\Desktop\Modules\TivoNowPlaying\Config". This should be set to point to the location of the "My Tivo Recordings" folder on the NAS.
    3. start TiVo Desktop and transfer a program.
    4. (optional for Desktop Plus) regedit and modify "OutputPath" under "HKEY_CURRENT_USER\Software\TiVo\Desktop\Converter" Change this to point to whatever location you want to use on the NAS.
  16. kmbarr

    kmbarr New Member

    Feb 28, 2010
    :up:Thanks! I worked through just about all the solutions here without success [excluding alternate software or scripts to indirectly transfer recordings] and this finally worked perfectly for me!
  17. Imladrian

    Imladrian I brake for Ewoks.

    Oct 17, 2010
    I'm running Windows XP, TiVo HD, TiVo Desktop 2.8, and trying to use a 1TB My Book Live connected to my router. I was able to get THD to transfer to my My Book Live drive by cut/pasting the My TiVo Recordings folder to it and then editing the registry as directed above. I noticed a few differences from the results that were described.

    1. The desktop.ini file does not require me to change my Folder Options > View settings to deselect "Hide protected operating system files" in order view it (i.e. it's always visible).

    2. Something is screwy with the TiVo desktop window. If I manually select a file and initiate a transfer, I'm unable to close, minimize, or select anything as an hour glass appears anytime I try to click on anything. The window remains open until the transfer is done and my inputs are accepted. During the transfer other windows/programs still respond.

    3. My overall system performance seems to bog down during a file transfer and is much slower than I experienced with a USB connected storage drive. This degradation affects all applications running.

    I'm not too worried about the system file being visible, but I would love to have control over the program window and not suffer a hit to performance. Any suggestions.
  18. pilott

    pilott New Member

    Jan 17, 2004
    San Jose
    I recently ran into this problem as well. As a last attempt before going into the registry I tried using a symbolic link to my network share and that did work. This is only an option with vista and later (I think, never used vista and I am using win 7).

    mklink /D C:\video \\NAS\video

    A bit of strangeness: I had to ALSO have a mapped share with saved credentials to get it to work (I have \\NAS\video mapped to V: with username and password saved). There might be a better way to handle the credentials, but that worked.
  19. turbo327

    turbo327 Ret Network Janitor

    Dec 16, 2002
    Norfolk, VA
    Just got Mattj's reg edit above working fine on the Dlink DNS-321 NAS. Tivo works both ways.

    The only thing I've noticed is on reboot just 1 time the Tivo server did not want to correct reboot. I am using the Tivo Beacon, not MS/Apple's Bonjour.

  20. kwiebe

    kwiebe New Member

    Feb 17, 2004
    This worked great for me (Win 7). Thanks for the tip. :up:

Share This Page