1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Desktop refuses to use network drive

Discussion in 'TiVo Home Media Features & TiVoToGo' started by lpoulsen, May 22, 2006.

  1. ciscokidinsf

    ciscokidinsf New Member

    60
    0
    Jan 26, 2007
    Hey all. Same here. I just got my new Terastation and cannot connect it to TivoDesktop. I also tried obelisk's method but it didn't work. I've tried 2.4 preview and 2.3. I'll try WebDrive next.

    Where exactly is the 'smb.conf' file and how can we open it/edit it (notepad?) I can't find it. Thanks.
     
  2. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    You will need to hack your Terastation. The smb.conf file is on it, not the PC. You access the Terastation and edit the file with vi, nano, or your favorite Linux text editor if it isn't one of those. Check out linkstationwiki.net for more than you ever wanted to know on the subject, plus a few hundred other Buffalo device hacking subjects.

    CuriousMark
     
  3. ciscokidinsf

    ciscokidinsf New Member

    60
    0
    Jan 26, 2007
    Uhhh... no can do. I wish there was a homebrew firmware with those changes. I'm ok doing firmware updates, I'm no newbie, but I don't do Linux yet, (I have no Linux editor and not familiar with the data/file structure) I don't want to damage the thing.

    Sigh... I ****ing knew I should've gotten the ReadyNAS, and I almost did, but the price difference was beaucoup bucks and I got a semi-decent deal on Ebay with the Terastation. Oh well, I'll do manual transfers or perhaps a daily backup.

    I couldn't make Webdrive work. if anyone has, I might need better instructions. (FTP is setup in the Terastation, but I can't get the thing to show up correctly in windows)
     
  4. ciscokidinsf

    ciscokidinsf New Member

    60
    0
    Jan 26, 2007
    Me again Apparently TD and my Terastation are NOT working via webdrive. Despite Webdrive being able to MAP to Windows explorer as a drive letter, when I try to drive TD to that drive it seems to work, but the job fails b/c of some unexplained permissions. Bummer. I know it has to do with the Tivo app, because Webdrive and File explorer works fine, I can move files back and forth.
     
  5. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    I still think you should ask at the linkstationwiki forums. If Freelink is available for Terrastation it may have samba installed properly, and if not, one of the uber hackers there my be able to help you out and make it so. They have done a lot of work over there, and created a lot of great stuff, but you have to be willing to read to dig it out. They will help those who demonstrate they are willing to work a bit and help themselves.

    Mark
     
  6. jches55

    jches55 New Member

    4
    0
    Jul 25, 2005
    I purchased a Linksys NSLU2 Storage Link in order to store TiVo files on the network instead of USB connected drive [using Windows XP] --- and, I also cannot connect to the NAS drive from TiVo Desktop. Is there a workaround for this situation out there ..... [somewhere]?
     
  7. ciscokidinsf

    ciscokidinsf New Member

    60
    0
    Jan 26, 2007
    Sorry, apparently only the ReadyNAS works nice with Tivo. Other NAS devices seem to fail with Tivo Desktop..
     
  8. bud8man

    bud8man Tivo Evangelist

    706
    0
    Feb 12, 2004
    Oakland, NJ
    So the issue is...TiVo will not allow you to use a NAS drive as the location to download your files and store them...
    How about this...or do shortcuts from the NAS placed in a TiVoToGo folder on a PC fail as well....
    1. use a folder on the PC to download the files
    2. Use SyncToy to transfer them to the network drive
    http://www.microsoft.com/windowsxp/using/digitalphotography/prophoto/synctoy.mspx
    3. Create Shortcuts of the files on the NAS drive and place them in the folder on the PC
    4. Delete the copied files from the PC
    I am sure some guru could figure a simple batch program to accomplish most of this...
     
  9. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    Like was hashed out in this thread?

    TiVo Desktop and Network drives
     
  10. davesanti

    davesanti New Member

    21
    0
    Oct 7, 2004
    Hey all pulling a slightly old thread here..

    I too am using a Linksys NSLU2 (unlung) to serve music out of the attached HDD. I am interested in being able to use the Tivo to pull videos and picks out of the NAS. I dont need to pull the recorded shows off the Tivo to the NAS (yet anyway) Are there are any further thoughts on this issue.

    Thanks

    Dave
     
  11. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    Some have gotten a headless Galleon to run on the linkstation. It may be possible to do that on the NSLU2 if it has the horsepower to run Java. Check out the linkstationwiki for details.

    CuriousMark
     
  12. murmur

    murmur New Member

    23
    0
    Jul 6, 2005
    Same story here with a D-Link DNS-323 NAS.
     
  13. murmur

    murmur New Member

    23
    0
    Jul 6, 2005
    I just installed TD2.5 and the problem still exists. Now I feel dumb for not reporting it back when I first noticed it.
     
  14. luper89

    luper89 New Member

    3
    0
    Jun 10, 2006
    I just tried this and it worked! Admittedly slightly more cumbersome than directly mapping to the network drive but I wasn't comfortable with Linux or hacking into anything, so for me this is the best way to go. I'm using Windows XP and a Buffalo Linkstation if anyone is wondering. (I haven't bothered with SyncToy yet, just dragged and dropped onto the network drive using Windows Explorer.)
    Thanks for the suggestion!

    Now if only there was a way to get Tivo to access a network drive directly without keeping a computer running in the background...
     
  15. murmur

    murmur New Member

    23
    0
    Jul 6, 2005
    Damn, that solution is so simple that I'm kicking myself for not trying it before. Nice.
     
  16. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    I have seen posts about people putting Galleon on the Linkstation, specifically a Kurobox HG. There is a Howto on the Linkstation Wiki.
     
  17. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    I am ressurecting this old thread because it seems the best place for my input.

    This is a recurring question that pops up from time to time as people try to have TiVo Desktop save directly to their NAS. I see no reason why it should not work and consider it a bug of TiVo Desktop, however TiVo may consider it a feature.

    I recently took my old NAS and upgraded it and thought I would investigate this while I was at it. I was able to duplicate the problem and then implement the fix provided by cmetcalf above. Sure enough, it works. I also posted "Make Your NAS Compatible With TiVo Desktop" at NAS-Central for others wishing to do the same and needing a little more detailed guidance. I hope anyone with this problem finds the article useful.

    CuriousMark
     
  18. mikelenner

    mikelenner New Member

    1
    0
    Apr 11, 2008
    i'm having trouble getting this solution to work with tivo desktop 2.6 - it exhibits different behavior then 2.5. Instead of allowing you to click the folder on your network mapped drive, tivo desktop simply grey's out the OK button.

    I'm made the changes on my NAS's samba config and fstab - still, the OK button is grayed out. Anyone got this solution working on tivo desktop 2.6?
     
  19. weaverdrew

    weaverdrew New Member

    25
    0
    Dec 23, 2003
    I also see what you've reported: TD's "OK" button is grayed out now in 2.6 for my NAS MyBook drive. I presume that's because TD's developers (who are not Tivo employees, it's a third party, I was told) know the "drive has moved or changed" error message was erroneous, but they didn't fix the root issue.

    I'm going to try the CuriousMark solution this week and will report back.
     
  20. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    I haven't been using my NAS with TD 2.6, as I am running PyTiVo on it now. I will have to check it out too. If your samba is good and it still doesn't work, then I am not sure there is a good fix, other than dumping TiVo Desktop and switching to PyTiVo.

    I am not ready to speculate on the why of it yet.
     

Share This Page