1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Desktop on Windows 7

Discussion in 'TiVo Help Center' started by coreybryant, Aug 24, 2013.

  1. coreybryant

    coreybryant Texan at Heart

    Mar 1, 2003
    Castle Rock, CO
    I recently cleaned out my computer and did a complete reinstall. I bought the TiVo Desktop and it will not download. I have contacted support several times but they have not been of any help

    When I first did this, I did not even have a firewall - I did not want them to have that as an excuse. I do have eSet - the same one I used before.

    But the shows are in the queue, saying failed. It sees the two TiVos (2 & 3) and it see the shows. I can choose to download a show but it fails.

    I am using Windows 7 32 bit on this one.

    Any advice would be appreciated.

    (BTW, there is a Google ad on the home page about an updgrade - and it does not work, I was wondering if there is something for people who have the lifetime on two TiVos)

    Thank you
  2. jhilla

    jhilla Guest

    May 13, 2011
    Now the other possible reason for the failures depends on the firewall in use. The Windows Firewall automatically opens the ports needed if you are using other 3rd party products you will need to open the ports manually. Here are the list needed to be active.


    as per the rest of us, we have swapped sides to use Pytivo which is beautiful since it uses (1) port to do all the work. By default it used 9032 but you can change it based on your options and choices.

  3. coreybryant

    coreybryant Texan at Heart

    Mar 1, 2003
    Castle Rock, CO
    Well I did not have the firewall on when I started, but I noticed this. The system is named CRBRYANT-PC, but when I go into TiVo Desktop Plus - Services - TiVo Server Properties, under the network identification name, it has COREYBRYANT-PC.

    Now, the system has always been CRBRYANT-PC so I don't know when it picked this up. Would this have something to so with it?
  4. SNJpage1

    SNJpage1 New Member

    May 25, 2006
    Atlantic City, NJ
    If you don't do the patch it will never work.
  5. wmcbrine

    wmcbrine Ziphead

    Aug 2, 2003
    That list is very misleading. In reality, TiVo Desktop only uses a handful of ports: one for http (8080), one for https (I forget which -- 4430?), a listener for TiVo Connect Discovery beacons (2190), and a non-exclusive listener for Zeroconf beacons (5353 UDP), which in TD's case is delegated to Bonjour. I think that's all the incoming ports. The rest of the ports on that list are the ports on remote systems that a TiVo might connect to -- not things that would normally be blocked by a home router or firewall.

    pyTivo uses 9032 (adjustable) for http, doesn't support https, can optionally listen on 2190 (off by default), and like TD, also listens non-exclusively on 5353 UDP, although it can still function if that port is blocked. I'd open it, though.

    I think the list is written the way that it is just so that support can point you to it, get you to open all those ports, and then definitively rule out a blocked port issue when your problem (whatever it might be) persists.
  6. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    Have you ever had a PC that you named COREYBRYANT-PC or that named itself that before you could change it?
  7. coreybryant

    coreybryant Texan at Heart

    Mar 1, 2003
    Castle Rock, CO
    No, never had COREYBRYANT-PC which was odd. So I backed up my registry and changed COREYBRYANT-PC to CRBRYANT-PC. I know, drastic, but sort of getting there.
    I can download shows from TiVo 2 to TiVo 3
    Here are the permissions:
    Bonjour service is started:
    I noticed that when I highlighted a show I could not choose download as it was greyed out
    I went and chose use TiVo Beacon and then this happened:
    One interesting thing, once I went thru and changed COREYBRYANT-PC to CBRYANT-PC, I can use that (like I use to) to Remote Desktop into there.

    I rebooted after I changed from Bonjour to TiVo Beacon. The one show that I did transfer from TiVo2 to the computer, I can transfer it to TiVo 3.
  8. ggieseke

    ggieseke Active Member

    May 30, 2008
    In Desktop, relink your account to TiVo to make sure they know the new name. In effect, you renamed your computer and your TiVos will have to download new certificates for your PC.

    Then go to tivo.com and disable transfers & downloads. Wait a few hours for their server farm to sync up, then force a daily call. In the System Information screen the TiVoToGo status should change from "a,a,a" to "i,i,i".

    Once it does, reverse the process until it shows "a,a,a" again.

    BTW: When you set up Windows 7 one of the first questions it asks you is for a user name. It takes that and adds -PC for the computer name unless you change it at that screen. You can rename the PC later but traces of the original name may still be there depending on how much software you installed before renaming it.
  9. Gadfly

    Gadfly New Member

    Oct 27, 2007
    I have TiVo desktop 8.2.2. and I have paid for it. I am trying to upgrade it to 2.8.3 and I can't. I tried to send an email to their support and ask them what to do. so I click email and they ask me to log in to my account which I do. but then none of the options I see includes sending them an email.

    if this is not the most incompetent company in term of getting a simple support system to work, I don't know who is. they were horrible in software development but I didn't think they are this bad.

    and now I have to go back to my mini and tell it not to shut down, I am still watching...

    unfortunately there isn't much competition to force them to come to 21st century.
  10. Hi8

    Hi8 TiVoPro - wanabe!

    Mar 6, 2002
    Have you applied the "Patch" ???

    I had S3 OLED TiVos, an until I downloaded and applied the patch my transfers always failed as well.

    There is a new upgrade (11.m) rolling out that corrects this problem for the S3, I'm not sure what models TiVo(s) you have but ...

    I bet the patch will fix your problem.

Share This Page