1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo Decoder GUI and Tivo Premiere Elite Problem

Discussion in 'TiVo Premiere DVRs' started by DennisTheMenace7, Jul 3, 2012.

  1. Jul 3, 2012 #1 of 20
    DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    When using Tivo Decoder GUI and Tivo Premiere Elite unit and Tivo Desktop Software my problem is when I click ‘Decode’… Instantly I receive an error from windows stating “this program is not responding” then it says “tivodecode.exe” has stopped working, Close Program.

    Have I set something up wrong?! There is a file in the output folder with 0 bytes so its at least working for a second!


    THIS DID NOT HELP:
    Are you using a TiVo Premiere and TiVo Desktop to transfer the video to your PC? I recently purchased a TiVo Premiere and have discovered an incompatibility with TiVo Decoder. If you are using a TiVo Premiere, then you have to uncheck the “Use the fastest method available” for file transfer speed in TiVo Desktop when transferring video from your TiVo Premiere to your PC.

    If you have it checked then TiVo Decoder will abort with an error when attempting to convert the TiVo file to a standard MPEG2 file. If you have it unchecked then TiVo Decoder will be able to process the TiVo file.
     
  2. Jul 3, 2012 #2 of 20
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,724
    8
    Apr 6, 2000
    SF Bay Area
    Did you input your Media Access Key into TivoDecode or any other program involved with .tivo files.
     
  3. Jul 4, 2012 #3 of 20
    DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    Yes, I did. I also own a Tivo Pioneer 810H which doesn't have this problem with its files crashing when using the decoder.
     
  4. Jul 4, 2012 #4 of 20
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,724
    8
    Apr 6, 2000
    SF Bay Area
    CPU may be a bit slow with Tivodecode running and decoding. It may say 'its not responding', but it may be too busy processing and closing the Tivodecode would interrupt it. It can take a while depending on the size.

    "fastest method" will transfer in .ts (transport stream) format which Tivodecode does not like, only .ps (program stream) will work.
     
  5. Jul 4, 2012 #5 of 20
    DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    Is anyone successfully using Tivo Decoder GUI and Tivo Premiere Elite? If so, what version of TDG are you using?
     
  6. Jul 4, 2012 #6 of 20
    lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    In your initial post, you said "THIS DID NOT HELP". Does that mean you have examined the settings of TiVo Desktop and unchecked "use fastest method" if it was checked? And downloaded again any files you downloaded while that option was set?
     
  7. Jul 5, 2012 #7 of 20
    DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    Yes lpwcomp, I did just that. I thought that was obvious. I showed that "THIS DID NOT HELP" because it was a post by another which sounds like a fix but it's not.
     
  8. Jul 5, 2012 #8 of 20
    lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    It's usually best not to assume anything. In this case, your snippy attitude has forced me to assume you "obviously" know what you are doing, and don't really need anyone's assistance, and so I will leave you to it.:rolleyes:
     
  9. Jul 5, 2012 #9 of 20
    DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    Sorry lpwcomp that your feelings got hurt. I had no idea you were so sensitive. Don't read so deep into what others write. I only meant that it would be understood that I tired what I posted so please don't bother going down that road.
     
  10. scandia101

    scandia101 Just the facts ma'am

    10,519
    0
    Oct 20, 2007
    MN, greater...
    thank you
     
  11. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    You're welcome?
     
  12. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,446
    166
    Apr 17, 2000
    Nevada
    You have to download programs as Program Streams to get TiVo Decode GUI to work. By default TiVo desktop uses the newer Transport Stream format for .tivo files downloaded from a Premiere. However tivodecode does not work properly with TS files. (there is a patch that adds support, but it's not 100% so it's not included in the default build)

    If you download files via TiVo Desktop you need to go to File->Preferences and uncheck the "Use fastest method when transferring" option. If you use the web interface then you need to select the PS link.

    However this will only work for files you still have on your TiVo that you can redownload.

    Alternatively you can use something like DirectShow Dump and simply rename the files that come out of it to .ts instead of .mpg. Or you could use VideoReDo to save to whatever format you want, it support both PS and TS TiVo files just fine. :)

    Dan
     
  13. DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    Thanks Dan203 it worked! I unchecked "Use fastest method when transferring" option" and redownloaded a file. TIVO Decode GUI did not crash. Thanks for your help!
     
  14. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    Amazing! So why did you sarcastically respond "Yes lpwcomp, I did just that. I thought that was obvious." when I asked if you had done the very same thing?
     
  15. philw1776

    philw1776 Active Member

    2,288
    0
    Jan 19, 2002
    Seacoast NH
    What a wise ass comment
     
  16. MC Hammer

    MC Hammer New Member

    177
    0
    Jul 28, 2011
    Yet an extremely valid one.
     
  17. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,446
    166
    Apr 17, 2000
    Nevada
    I think the reason it didn't work is because he didn't realize he had to redownload the files. He thought simply changing the option would have an effect on the files he already had. The original instructions don't make that 100% clear.

    Dan
     
  18. DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    Dan203 is correct I had no idea I had to download the files again. Simply changing the option would have no effect on the files I already had. The original instructions don't make that 100% clear. I hope this help others. Please people don't get your shorts soiled. Clarity is the key. Dan203 is the man!
     
  19. DennisTheMenace7

    DennisTheMenace7 New Member

    86
    0
    Dec 10, 2003
    lpwcomp I owe you an apology. You were correct and I was wrong. Sorry about that.

    You did say "And downloaded again any files you downloaded while that option was set?"

    Hats off to lpwcomp. He was correct on all counts. I need to slow down. THANK YOU lpwcomp!
     
  20. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    No problem. Water. Bridge. Just glad everything is working for you now.
     

Share This Page