1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The clock is wrong because it's right!

Discussion in 'TiVo Home Media Features & TiVoToGo' started by unitron, Feb 16, 2013.

  1. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    In another post* notting came up with the reason TiVo to PC transfers are failing, no matter which software you're using, Desktop or otherwise.

    The TiVos are handing out expired session id cookies.

    I reset a PC to think it's only the 13th, and now I've got a transfer going successfully and about as quickly as I've ever seen one happen.


    *http://www.tivocommunity.com/tivo-vb/showthread.php?p=9526322#post9526322
     
  2. LKMcMillen

    LKMcMillen New Member

    28
    0
    Nov 17, 2004
    Setting my computer's calendar date back to February 13, 2013 worked for me too. :)

    Thank you!

    A sharing of information.

    TiVo Premiere
    TiVo Premiere Software Version: 20.2.2.1-01-2-746
    TiVo Desktop Plus Software Version 2.8.3

    This morning I discovered a problem with the transfer of recordings from my TiVo Premeire DVR to my personal computer over my home's wired network using my licensed copy of the TiVo Desktop Plus software.

    After I'd picked recordings to transfer from the list of recordings displayed in the TiVo Desktop Plus, and selected the "Start Transfer" button, it appeared at first that all was working as normal. But after a few seconds the TiVo Desktop Plus software displayed the message "Some transfers have been interrupted". When I then selected the "Transfer Status" tab I saw that each recording title is preceded with a red "X", and that there is a notation of "X The system cannot find the file specified" for each of the selected files.

    All of the recordings were made within the last 72 hours. I restarted my TiVo box using the it's settings menu system, and then by disconnecting/reconnecting the power cord several times. I've shut down and restarted my computer several times. I've disconnected/reconnected the power from my network's router, as well as reset it to factory settings and set it up again to fit my network. And I've uninstalled/reinstalled the TiVo Desktop software. None of those actions have resolved the issue.

    TiVo (Online chat) support just informed me a few minutes ago that it appears that recent updates from Microsoft installed to my personal computer (Windows 7 Ultimate 64-bit) yesterday are apparently the source of the same, or similar problem which I'm experiencing, and asked that I wait 24-48 hours to see if additional updates are released to fix the problem.

    At TiVo Support's request I reviewed the list of updates to my Windows Operating System and found that "security" updates identified as KB2792100, KB2310138, KB2790655, KB2790113, KB2797052, KB2789642, KB2778344, and KB2799494 had been installed during the last 24 hours.
     
  3. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    As with the the last two problems that affected everyone, TiVo support is full of it.
     
  4. sw10025

    sw10025 New Member

    1,386
    1
    May 16, 2000
    Los...
    I suspect lpwcomp is right, and Tivo may be confused - or not telling the truth - about the source of the problem. I experienced the exact same problem, and the exact same fix worked, HOWEVER, I hadn't turned my computer off for a number of days before the downloads started failing (therefore no operating system changes could have been made, even if they were automatically downloaded) and Tivo Desktop Plus had been working fine hours before it started failing, and the computer definitely hadn't been off, or had an interruption of power since the time the downloading was working and the time it stopped working. And the computer also never flashed the usual message about their being updates waiting to be implemented.

    Just "chatted" with Tivo support to see what they would say re the issue, and was given the same line about it being a Microsoft update. Told them what I just said above, which he didn't comment on. Also told him about changing the clock solving the problem, which he didn't seem to know about. Asked him if he knew of any other workarounds (since changing the clock could conceivably mess up other things on my computer, and it confuses me when I look at the date until I remember) and he said he'd heard that doing a system restore from a few days before would also resolve the problem. Neither is a great resolution, but I'd rather change the clock than do a system restore and lose the last couple of days worth of work.

    He said they're working on a software update that will resolve the problem, and just to be sure I made him clarify we should expect one from Tivo, not from Microsoft, that will resolve the problem, but he didn't have an estimate for how long it would be before it was available.
     
  5. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Since I experienced the problem and am still running Win2K, which hasn't been updated in years....
     
  6. tluxon

    tluxon Member

    250
    0
    Feb 28, 2002
    Kirkland, WA
    It's nearly impossible for this to be a Windows issue, as I've had the same symptoms of an expiry date issue on 3 different PCs with separate OS's (Win7 x32, Win7 x64, and WinXP). The WinXP PC hasn't had updates applied for at least 4 months.

    I can't set my clock back because I'm recording multiple shows at any one time with WMC on this PC, so my only band-aid so far has been to download with kmttg with it set to "use Java to download instead of curl". This is a step back for me because kmttg downloads are about 50% slower than pyTivo downloads on my setup.
     
  7. aaronwt

    aaronwt UHD Addict

    19,192
    25
    Jan 31, 2002
    Northern...
    I just turned on my Windows 8 TiVo Desktop machine. It has not been turned on recently. There were no updates and I have the issue.

    I have kmttg but have not used it in a while. I'll need to try and remember how to use it.
     
  8. LKMcMillen

    LKMcMillen New Member

    28
    0
    Nov 17, 2004
    After restoring my computer's system partition from an image backup made January 28, 2013, without installing any updates issued since that date, or the installation of the TiVo Desktop Plus software, and attempting to transfer recordings directly from my TiVo Premiere over my wired network using Microsoft's Internet Explorer with the URL of https://192.168.1.102 (The IP address assigned by my network) without success, I fully believe that the problem is certainly with the TiVo DVR software.

    Thanks to all!
     
  9. pbiersac

    pbiersac New Member

    2
    0
    Sep 13, 2008
    Just chiming in to agree about changing the time on my PC to correct the file transfer problems I've been having. I successfully transferred files off my TiVoHD yesterday (2/15/2013) but today (2/16/2013)? Nothing but TiVo Desktop showing "the system cannot find the file specified" after failed transfer. This has been irritating me all day long! I've had a similar problem before and cleaning up some old temp files and rebooting usually worked. Not this time though. Among other things, I:
    * Checked network settings on my routers and both TiVos (a series 2 and a TiVo HD).
    * Unplugged both TiVos and left them unplugged for nearly an hour each before restarting.
    * Completed guided setup again (without clearing thumbs, recommendations, schedules, etc)
    * Performed fresh installs of TiVo Desktop on my PC
    * Cleaned out various cache and temp file directories on my PC
    * Poked through (but ultimately did not change) anything in PCs registry
    * Rolled back to previous good system restore point (2/13/2013) on my PC to get away from Microsoft security updates that *did* install during the last few days. I don't normally accept automatic Windows updates but they snuck in (somehow) while I was sleeping. Really thought this could be a legit cause of my problems since it turned my Windows Firewall back on (I disabled it previously). No dice.

    Been scouring forums all afternoon and no fixes seemed to work. Noticed that the hard drive in my TiVoHD was slightly louder than normal and expected that maybe it was finally dying. Nearly jumped the gun to purchase a new TiVo (Premiere 4XL) but couldn't get over the fact that my series 2 was also suffering the same problem and *only* since today. Fortunately, found this thread and gave it a shot. NO JOKE...immediately after killing all TiVo processes, setting my PCs clock back to 2/13/2013 and restarting TiVo Desktop...and I mean immediately...no more problems. I am currently mid-transfer but will put the clock back to todays date to see if the problem returns. Assuming it does, the questions are now: 1) what doesn't TiVo like about today's date, 2) what is TiVo going to do about fixing the problem, and 3) how quickly is TiVo going to fix it?

    I don't want to keep setting my PC back to pre-2/16/2013 just to transfer shows...
     
  10. javabird

    javabird Active Member

    1,023
    0
    Oct 12, 2006
    Seattle
    Thanks for the info. Same problem on a Mac here. I don't want to reset my clock because it will affect my other apps, but I noticed the web downloads are still working.
     
  11. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    It has nothing to do with any of that. Apparently TiVos can't hand out session id cookies dated any more recently than Feb. 15, 2013, so the PC has to be lied to about the current date.

    Go to the bottom right hand corner of your screen, right-click the time display, click adjust date/time, click the calender to make it think it's the 13th or 14th of February instead of the 16th, and watch Desktop start working like normal.

    Or, if TiVo is as slow to fix this as they've been on getting the Premiere's OS out of beta, maybe leave it on February 16th and set to last year or the year before.

    Of course if making your computer misinformed about what the date really is screws up something else, well, that's the way the out of date cookie crumbles you.
     
  12. msmart

    msmart New Member

    228
    0
    Jan 2, 2007
  13. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    You can experience the problem under Mac OS X or Linux, too.

    The problem has been well characterized over in the kmttg thread. It's entirely due to the TiVo.
     
  14. dakk

    dakk New Member

    20
    0
    Nov 8, 2005
    I have been turning my clock back to transfer recordings all was working fine til just now.
    I went back even further to Feb.9 no joy. Now it just will not transfer, period
     
  15. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    I don't like the sound of that.

    You really shouldn't need to set it any farther back than necessary to keep from rolling over to February 16th, 2013 before the transfers finish.
     
  16. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    I have a workaround for pyTivo in my repos now.
     
  17. rpetruzz

    rpetruzz New Member

    1
    0
    Oct 14, 2005
    Hi,

    Just to add confirmations to this. I run Windows 8 Pro and did just recently download and install updates.

    But no matter how many times I rebooted the PC, rebooted the Tivos nothing worked. I still got the "The system cannot find the file specified" for all my Tivo downloads. And I have 5 different Tivos. Four of them Premier units. Even the Tivo that is not Premier was failing.

    I changed my clock back to Feb 13, 2013 and everything is working just the way that it should.

    Thank you for posting the workaround to the problem. I can't leave my date changed backwards, but this is at least a work around until Tivo gets their act together.

    Bob
     
  18. morac

    morac Cat God

    8,956
    22
    Mar 14, 2003
    NJ
    I found a set and forget work around for TiVo Desktop that doesn't involve changing the clock. See this post for details.
     
  19. ggieseke

    ggieseke Active Member

    4,031
    12
    May 30, 2008
    Brilliant!
     
  20. mdjwintergreen

    mdjwintergreen New Member

    1
    0
    Feb 17, 2013
    Was having the same problem with the "tivo system cannot find the file specified" and I did just what you all said by turning my PC clock back to Feb 1st and it worked! I'm totally shocked! I have three different tivos and all was working just fine last weekend transferring shows from my tivos to my pc (I travel a lot for work) and NOTHING had changed on all fronts from last weekend (except time apparently). I really didn't think that would be the solution but it was! I sure hope they come up with an update to fix that cuz I'm pretty sure that luck is going to run out soon and I won't know what to do then as you all are saying going back again (or further) doesn't work. Come on TIVO!
    MJ
    P.S. Whoever figured that out...You're a god! Thank you!!!!!
     

Share This Page