1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TCD24008X and TCD5400XX power supply compatability

Discussion in 'TiVo Coffee House - TiVo Discussion' started by steve40503a, May 22, 2013.

  1. steve40503a

    steve40503a New Member

    5
    0
    Aug 18, 2011
    Hey everyone. I have two Tivo Series 2 model numbers TCD24008A and TCD240080. The power supply finally went bad on the TCD24008A a couple of weeks ago and I bought a replacement power supply on e-bay. The replacement power supply worked just fine bringing renewed life to my TCD24008A Tivo. For future replacement of the power supply I ordered another used power supply through e-bay to keep in moth balls until needed. The only problem is that the “spare” I received while advertised on e-bay as a replacment power supply for Tivo Series 2 models TCD240080 and TCD24008A looks different than the bad one that I replaced in the TCD24008A one that was replaced. By different I mean some of the components are the same but others are different on the power supply circuit board. The spare one also had been written on with a sharpie pen“TCD540040”. The specifics are the first replacement power supply had a printed label with the following “SPWR-00004-000 REV A1”. The spare new(er) replacment power supply had a printed label with the following “SPWR-00004-001 REV A3”. I have read several posts on either the Tivo community forum or the weaknees forum from a couple of years or so ago that said that the TCD540040 power supplies can be used in the TCD24008X Series 2 Tivos. I’m just a little scared as I want to install the TCD540040 power supply SPWR-00004-001 REV A3 into my TCD24008A unit to make sure that the power supply is good and moth ball the SPWR-00004-000 REV A1 as my “I know it works” spare. Weaknees shows two different power supplies one for TCD24008X and another for TCD5400XX. Just want more reassurance from some of you more experienced folks (my experts) that I won’t blow the mother board or hard drive on my TCD24008A by installing my new(er) spare power supply. Thanks in advance for your time both reading this rather lengthy post as well as your time to reply. You folks are my Tivo heroes!
     
  2. scandia101

    scandia101 Just the facts ma'am

    10,520
    0
    Oct 20, 2007
    MN, greater...
    I only read about half of that, but the power supplies between the two models are interchangeable. One reason they look different is that the parts are not available or economical to use forever. An early 240 ps is likely different in appearance than a ps in a later 240. I put a ps from a 540 into a 240 and had no problems with it and other people here have used a ps from one model in the other w/o issues. I started a thread on the subject years ago and the question comes up again every now and then.

    Here is the old discussion:
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=385566
     
  3. lillevig

    lillevig Hot in West Texas

    1,769
    0
    Dec 6, 2010
    San Angelo, TX
    You might take a look at the capacitors on the bad supply. That is often the cause of the problem. There have been several discussions in this community regarding "capacitor plague". I recently had a TCD240 supply go out on me and it turned out to be one capacitor tucked under the edge of a heatsink. Took a little bit of work to get it replaced because of the tight quarters but now the supply works great again.
     

Share This Page