1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

super slow pulls..how to remedy?

Discussion in 'TiVo Home Media Features & TiVoToGo' started by newsposter, Jan 4, 2017.

  1. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    am doing another show now and i think i said it before but the lines scroll up very slowly. not super fast like i remember
     

    Attached Files:

  2. JoeKustra

    JoeKustra Cable only TCF Club

    7,274
    312
    Dec 7, 2012
    Ashland, PA...
    With "nothing" going on (no active tasks except Taskmgr) it should be almost zero, especially for an I7. Go to Details, then click on the CPU tab. The most time (like 99%) should be the Idle Process. Anything else above 1 or 2% is bad and might be killing your decoding. So, reboot, then check Taskmgr, Details, and see what's happening. Give it a few minutes to settle down.

    Sorry, I don't use pytivo. I do use Desktop and TiVoDeCode.
     
  3. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    i'm more than willing to learn something new to transfer to tivo. i thought tivo desktop didnt work anymore. or is it a paid thing? ill have to look at the other one as well.
     
  4. JoeKustra

    JoeKustra Cable only TCF Club

    7,274
    312
    Dec 7, 2012
    Ashland, PA...
    You are better with pytivo and kmttg. Much better support. I seldom use Desktop since I save things to a 500GB Premiere on my network that I only plug in on weekends. Also, one of my Roamio boxes has a 3TB drive. My primary Roamio has 1TB, and it's used when I'm awake and runs 24/7/365.

    If you find that there is a task (it may not display a name) that is using 25% of your CPU, we may have a common problem: Windows Update.
     
  5. HerronScott

    HerronScott Well-Known Member

    3,555
    156
    Jan 1, 2002
    Staunton, VA
    TiVo Desktop still works except for pushes for the paid version. I've always used the free version (along with pyTiVo on the WHS server and kmttg on my PC).

    Scott
     
  6. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    i have tivo desktop 2.8.3 and went thru all options. cannot find where to push from laptop to tivo. File/video to publish is greyed out

    i clearly can see how id put something from tivo to laptop. i know nothing about kmttg so gotta start reading.
     
  7. HerronScott

    HerronScott Well-Known Member

    3,555
    156
    Jan 1, 2002
    Staunton, VA
    Well push is a TiVo Desktop Plus option only which you can't purchase any more and it's broken. You can only pull now on the TiVo from the PC (same for pyTivo).

    Scott
     
  8. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    kmttg

    i've read through that page and it doesnt appear there's anything regarding going from PC to tivo?


    also just curious if anything in comodo firewall could be holding me back. or if it's working at all, it's working as well as it can be?
     
    Last edited: Jan 7, 2017
  9. HerronScott

    HerronScott Well-Known Member

    3,555
    156
    Jan 1, 2002
    Staunton, VA
    You need pyTivo to transfer back to the TiVo. kmttg and Archivo can transfer from TiVo to PC but not back to the TiVo.

    Scott
     
  10. JoeKustra

    JoeKustra Cable only TCF Club

    7,274
    312
    Dec 7, 2012
    Ashland, PA...
    In the olden days before Plus, you had an entry at the end of My Shows labeled "Now Playing on <PC>". You could use the SD looking display on the TiVo to tell that the PC transfer the program back to the TiVo. There was no conversion of .TiVo to .mpg or anything like that. The hardest part was getting the TiVo to see the PC. Usually it required a restart of the PC's Bonjour file server. After that it wasn't any harder than a TiVo to TiVo transfer. There was music and picture transfer too, but that is really broken. Those were the old days when TiVo supported Desktop.
     
  11. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    i've had consistent issues with nvidia drivers but that doesnt have anything to do with this i assume? also today updated ffmpeg to newer version

    downloaded kmttg and it appeared that something was encoding but then said cannot find account ID for TSN tivo in the pytivo window.
     
  12. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    i'm poking around. under control panel /network/wifi wifi status it says speed 54.0 mbps. i'm in the same room as the router so is that the top speed of the router?

    router specs are here
    Linksys E1200 N300 Wireless Router

    but somehow i dont think its a wifi issue. gut is telling me something else

    doubt this means antyhing but the dhcp client table lists everything as wireless G except tivo and my WD cloud drive are LAN
     
    Last edited: Jan 7, 2017
  13. ThAbtO

    ThAbtO TiVoholic by the bay

    7,168
    50
    Apr 6, 2000
    SF Bay Area
    That is the top speed of wireless G networks. Wireless N is 130Mb/s.
     
  14. HerronScott

    HerronScott Well-Known Member

    3,555
    156
    Jan 1, 2002
    Staunton, VA
    Now Joe, stop being so cynical. :)

    TiVo Desktop (free version) still works to transfer shows from the bottom of your HD menu My Shows and it works to view pictures. I do hope they fix the music issue though. :(

    Scott
     
  15. orangeboy

    orangeboy yes, I AM orangeboy!

    4,087
    0
    Apr 19, 2004
    East Moline, IL
    I pull compatible h264 mp4 files in very short times (sub minute duration) after they've been remuxed to a transport stream container using ffmpeg. My recipe:
    Code:
    SET ffmpeg_cpu_parm=-threads 2 -sample_fmt flt -ss 0.0
    SET ffmpeg_input_parm=-i "%usrtmp%\%Source_Filename%" 
    SET ffmpeg_remux_parm=-map_metadata -1 -c:v copy -bsf:v h264_mp4toannexb -c:a copy 
    SET ffmpeg_output_parm=-shortest -strict experimental -copyts -map 0:0 -map 0:1 -y -f mpegts  "%usrtmp%\%Output_Filename%"
    ffmpeg.exe %ffmpeg_cpu_parm% %ffmpeg_input_parm% !ffmpeg_remux_parm! %ffmpeg_output_parm%
    
    The code is part of a bigger Windows batch file where:
    "%usrtmp%\%Source_Filename%" is the source .mp4 file.
    "%usrtmp%\%Output_Filename%" is the resulting .ts file.

    Credit should go to Mr. W. McBrine. I basically used the same recipe he uses to transcode on the fly to stdout in pyTivo, but changed the output to go to a file, eventually replacing the original .mp4. Remuxing takes a couple/few minutes on the ancient hardware I continue to run.

    If you have TiVo "compatible" mp4 files, maybe the same remuxing process could help?
     
  16. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    speaking of mp4, if i'm uploading them, it should be super fast shouldnt it?

    i have a 20 minute SD mp4 and it took 3 min 32 sec at 18mb according to tivo. task manager never gets above 22 mb wifi sent and pytivo says 17.2 mb/s for the file. i have no idea if this is good or bad time wise

    disconnected my my cloud and plugged laptop into ethernet and killed wifi..same file above was 2 min 2 sec and 31.5 mb..i saw spurts up to over 40..but still is this a good time?
     
    Last edited: Jan 8, 2017
  17. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    so in theory, i should have 54 transfer speed when i'm uploading?
     
  18. ThAbtO

    ThAbtO TiVoholic by the bay

    7,168
    50
    Apr 6, 2000
    SF Bay Area
    It goes both ways, barring any interference, and only on your internal network. the internet is limited by the speed set for your internet plan.
     
  19. newsposter

    newsposter Poster of News

    34,894
    30
    Aug 18, 2002
    SE PA
    did 1.5 hour avi on ethernet..took 11 min 4 sc and 28 mb according to tivo. on wifi same file was 16 min 2 sec and 19.3 mb.

    edit: i cannot report back. ive been having weird thing lately where folders on my laptop show no shows under them or the folders dont appear at all. in this case i went to the same folder where the movie was that i just did and it shows empty on tivo. i also have an issue where when i'm listing the shows on tivo that are on the laoptop. there's like half page of blank space and no matter what you cannot see the files. i put the same movie in another directory 'higher up' and i can upload it now. very weird. i also have an issue where the movie directory disappears from my shows on tivo right after its done downloading. i have to restart pytivo. its like the entire thing is falling apart
     
    Last edited: Jan 8, 2017
  20. HerronScott

    HerronScott Well-Known Member

    3,555
    156
    Jan 1, 2002
    Staunton, VA
    Any of the rates they give you for 802.11g/802.11n are going to be the raw rate. For 802.11g, the raw rate is 54Mbps but due to overhead you won't get more than ~31Mbps throughput on transfers and since there are numerous other factors in play, you probably won't achieve that maximum either.

    Scott
     

Share This Page