1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby not in Menu...

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kaylus, Feb 12, 2011.

  1. kaylus

    kaylus New Member

    11
    0
    Feb 12, 2011
    I apologize if this is a daft question, but is there some extra trick on the Premiere to get Streambaby to show up? I've searched these forums and found nothing.

    I've disabled Windows Firewall and started StreamBaby with debug logging on and notice that it doesn't even seem to see the Tivo, nor does the Tivo menu have anything related to StreamBaby.

    What should I look at next?
     
  2. kaylus

    kaylus New Member

    11
    0
    Feb 12, 2011
    Just, for additional information:

     
  3. kaylus

    kaylus New Member

    11
    0
    Feb 12, 2011
    More testing: I can also see this from other computers on the local network, both wired and wireless. Both the Tivo and the Desktop are Wired directly.
     
  4. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Where are you looking? On the Premiere, streambaby should show up under the Showcases menu.
     
  5. kaylus

    kaylus New Member

    11
    0
    Feb 12, 2011
    Every time I modify a setting somewhere or restart something I check in the following 3 locations:

    The "Showcases" submenu under "Showcases and Extra" only has 5 advertisement bits in it.

    The "Showcases and Extras" has a handful of things, but no Streambaby.

    The "Music & Photos" has it neither.

    ---

    If you look at my log above compared to other logs you'll see that it doesn't ever seem to pick up the Tivo. Other logs I've seen say "jmDNS: TIVOONE found" or something similar.

    I am able to do the folder.png test from every device on my network though, so I know it's bound and operating properly on Streambaby side.
     
  6. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Have you enabled "home network applications" at the bottom of the Showcases & Extras menu? If so, have you tried the "add an application" menu, putting in the IP address of your machine running streambaby?

    Could your router be blocking multicast?
     
  7. kaylus

    kaylus New Member

    11
    0
    Feb 12, 2011
    Yes, the "home network applications" were enabled. Though I doubted it could be the multicast, I checked through the menus of my router (Dual Channel BELKIN N600 Play) and saw nothing that could modify the multicast settings.

    To be very sure I pulled out an older linksys with DD-WRT on it and as soon as I connected it found the TiVO. Looks like you were correct; now I need to find out how to get my newer router supporting Multicast.
     
  8. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Cool, glad you're getting closer! I did a quick search here and it seems everyone who's had a problem with multicast on a Belkin router can't seem to find the setting. :eek: I'm sure someone has done it, though ...
     
  9. Allanon

    Allanon Member

    580
    0
    Nov 2, 2005
    According to THIS Belkin hides the settings.

    Try:

    http://{your router ip}/enblservice.html
     
  10. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    StreamBaby not in menu (Music, Photos & Showcases) on TIVO HD

    my streambaby.ini is as follows:
    #
    # ./streambaby --help for more configuration file options
    #

    dir.1=C:Videos
    dir.1.name=Videos
    #dir.2=/media/disk
    #dir.2.name=External Drive
    # Ip address to bind to
    # most people don't need to change this.
    #ip=one nine two.one six eight.one.three seven
    # port to use
    #port=7290
     
  11. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    StreamBaby not in menu (Music, Photos & Showcases) on TIVO HD

    The setup instructions seemed simple enough, any suggestions?
     
  12. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    StreamBaby not in menu (Music, Photos & Showcases) on TIVO HD

    I am currently runing a Netgear FVS114 Prosafe VPN Firewall router without any options for multicast. There is nothing mentioned in the setup instructions regarding multicast, so I'm not sure if this matters.
     
  13. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    StreamBaby not in menu (Music, Photos & Showcases) on TIVO HD

    I have the latest version of Java installed and did the following:
    ◦To edit environment variables in Windows go to Control Panel-System-Advanced-Environment Variables and then look for Path entry under System Variables. Then add a semicolon followed by full path to java.exe on your system as in the example given above (will vary depending on your particular OS).
     
  14. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    StreamBaby not in menu (Music, Photos & Showcases) on TIVO HD

    I have home networking enabled on my TIVO along with Netflix which works fine.
     
  15. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    StreamBaby not in menu (Music, Photos & Showcases) on TIVO HD

    The initial run of the streambaby.bat looks like this:
    Initializing StreamBaby v0.29...
    02/18/11 14:18:51 StreamBabyMain$BshLogger: Download ffmpeg for first-run...
    02/18/11 14:18:51 StreamBabyMain$BshLogger: Connecting: http://streambaby.googlecode.com/files//
    ffmpeg-r15986-gpl-shared-win32.tar.bz2
    02/18/11 14:18:52 StreamBabyMain$BshLogger: Downloading...
    02/18/11 14:18:53 StreamBabyMain$BshLogger: Finished downloading, begin extract.
    02/18/11 14:18:54 StreamBabyMain$BshLogger: extracting: avcodec-52.dll (bin/avcodec-52.dll)
    02/18/11 14:18:58 StreamBabyMain$BshLogger: extracting: avdevice-52.dll (bin/avdevice-52.dll)
    02/18/11 14:18:58 StreamBabyMain$BshLogger: extracting: avformat-52.dll (bin/avformat-52.dll)
    02/18/11 14:18:58 StreamBabyMain$BshLogger: extracting: avutil-49.dll (bin/avutil-49.dll)
    02/18/11 14:18:58 StreamBabyMain$BshLogger: extracting: ffmpeg.exe (bin/ffmpeg.exe)
    02/18/11 14:18:58 StreamBabyMain$BshLogger: extracting: ffplay.exe (bin/ffplay.exe)
    02/18/11 14:18:58 StreamBabyMain$BshLogger: extracting: SDL.dll (bin/SDL.dll)
    02/18/11 14:18:59 StreamBabyMain$BshLogger: extracting: swscale-0.dll (bin/swscale-0.dll)
    02/18/11 14:18:59 StreamBabyMain$BshLogger: Retrieval of ffmpeg complete
    02/18/11 14:19:04 Listener: added factory
    02/18/11 14:19:04 Main: streambaby ready & listening.

    The subsequent run of the streambaby.bat looks like this:
    Initializing StreamBaby v0.29...
    02/18/11 14:21:27 Listener: added factory
    02/18/11 14:21:27 Main: streambaby ready & listening.

    I am not able to see any of the information that Kaylus posted?

    Any idea what I am missing?
     
  16. orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    That's quite obnoxious.
     
  17. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Wow ... trying to pad your post count or what?

    My guess is that, like kaylus, your router is blocking the multicast packets. You'll need to configure that firewall to allow the traffic on your network.
     
  18. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    It was not my intention to pad my post count as it would have been preferable to submit all available documentation in a single and initial post. My reason for six consecutive posts was simply to circumvent the limitations as it pertains to 5 posts or less which have been put in place by this site and to hopefully receive a legitimate response within a timely manner.

    With that said and moving forward, can someone explain the purpose of multicast as it pertains to “StreamBaby”?

    By definition (correct me if I am incorrect), Multicast is the delivery of a message or information to a group of destination computers simultaneously in a single transmission from the source creating copies automatically in other network elements, such as routers, only when the topology of the network requires it.

    I am only looking to stream to one TivoHD unit, so is this really necessary?

    And if so, what do you do if your router does not have a configuration for the multicast setting?

    The instructions for the installation and usage of “StreamBaby” are quite simple, however it is not working for me.

    Any thoughts?
     
  19. orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    I found this tiny bit of info concerning multicast and the FVS114:

    Is RIP2 being used?
     
  20. ScottM562

    ScottM562 New Member

    8
    0
    Feb 18, 2011
    Thanks for the insight into my router settings.

    The current settings are:
    RIP Direction: Both
    RIP Version: RIP_2M

    Still no StreamBaby in the menu, any other suggestions?
    Thanks
     

Share This Page