1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. gmoney88

    gmoney88 New Member

    Nov 14, 2009
    is it possible to customize the look of the file browser ? I'd like to have the ability to browse cover images (like media center)
  2. rfryar

    rfryar My Media, My Way

    Feb 15, 2008
    Thank you! It works like a charm now. Well at least with Thumbnail generation disabled. I will have to troubleshoot why that feature does not work for me, but since I never really jump around in my videos I have never missed it.

    Thanks again!

  3. PWF

    PWF New Member

    Mar 17, 2008
    I tracked down the error. It was a combination of things, but the main issue was that Cox is upgrading their service again and my cable modem could not "keep up" with their network. So it would drop its connection every minute or two and give out a new IP address to my router. That would tie up my router and it would stop transmitting over wireless for a bit while it reconnected to the cable modem.

    I ran cat5e to my living room and I now have gigabit ethernet, bypassing the router. I also replaced my cable modem.

    The last issue I have been seeing is that when rebuffering my audio signal sometimes flips front to back. If I go back to the menu and then continue playing where I left off it fixes itself, but it's a bit annoying.
  4. BrianVeg

    BrianVeg New Member

    Dec 3, 2007
    I've got Stream Baby to run on my windows 7 64 bit machine but when I go to my Tivo I can only see the top level directory. I can't see any folders or any files in that directory.

    Any ideas?
  5. Pepito

    Pepito New Member

    Jan 7, 2009
    Just a quick note :)

    Australia misses StreamBaby


    Greetings from Melbourne, AUSTRALIA
  6. rhoelzer

    rhoelzer New Member

    Jan 3, 2004
    I use Hamachi and StreamBaby tries to use my Hamachi IP. If I set it manually to in the ini file it uses If I disable Hamachi and set it back to automatic it works.

    Anybody seen this and/or have a solution?
  7. lesliew

    lesliew New Member

    Oct 11, 2003
    UK / USA
    Today I installed streambaby on my QNAP NAS and have had mixed success with it. JRE_6_X86 for Linux also installed.

    I just wanted to know if you could help clear up a few questions. BTW I have been running pyTivo on the same NAS almost flawlessly for months now. I have 2 S3 Tivo's

    When I startup the streambaby application I get the following error
    "FFmpegJavaVideoModule: Unable to load FFmpeg native libraries", is this significant ?

    When trying to run some video formats I sometimes get "ERROR: resource unavailable", is this a result of the above ?

    Occasionally I get the message rebuffering whilst streaming a movie, Viewing the same movie via pyTivo, the movie plays fine, no pauses. Does streambaby need more bandwidth or is it just more processor intensive.

    Any help to clear up the above errors or tips on how to make it work better would be appreciated.

    To be quite honest I'm surprised I got this working at all especially after I saw the JAVA requirement. I'm sure I will have more questions in time, back to seeing what else I can do with it.

  8. dm_

    dm_ New Member

    Nov 4, 2009
    Sigh. No news on the .au lack of streaming capability I guess?
  9. superflysocal

    superflysocal New Member

    Nov 26, 2009
    I love this application!! Thanks so much.

    I am in a bit of a bind. In one room I use Popcorn Hour and stream my movie libraries. I hold my movies in a central server. many are mp4 format with aac multichannel audio. However, to be able to get multichannel audio to work with my receiver (and most receivers out there), i had to convert the aac to ac3 and then change the container to mkv (no mp4 with ac3). It works fine and i get native 5.1 output. If i didn't do this, then the Popcorn will only PCM 2 channel audio to my receiver.

    Now that i just discovered tivo and streambaby, I'm hoping I won't have to have a separate library of mp4's. But when I try use streambaby on a mkv, I get very stutttery video, like it is running at 1/2 the normal framerate or something. The video otherwise looks fine. Is there no way around this except changing it back to mp4? btw, the few mp4 movies i haven't converted works fine, smooth motion and everything.
  10. rfryar

    rfryar My Media, My Way

    Feb 15, 2008
    Streambaby must convert the MKV into Mpeg since the TiVo does not support MKV natively. The best bet is to remux the MKV into MP$ with AC3 audio which Streambaby can just stream instead of convert.

    Does the popcorn hour work with MP4 with AC3 audio? If not you may be in a bit of a bind and have to have two copes of all your movies, one in MKV format and the other in MP4/AC3 format for the TiVos.

  11. superflysocal

    superflysocal New Member

    Nov 26, 2009

    From reading Popcorn hour forum, i was lead to believe MP4 container is not compatible with ac3, but perhaps popcorn hour just cannot handle it. You are saying it is compatible?
  12. westside_guy

    westside_guy Annoyingly ephemeral

    Mar 13, 2005
    The soggy...
    Tivo handles an a h.264 MP4 file with AC3 audio just fine, if that's what you're asking.

    See the streambaby video compatibility page for more info.
  13. phnord

    phnord New Member

    Sep 11, 2009
    Hey guys,

    I love what you've done for us Tivo users. My parent's have FiOS, and they're in a similar situation - the Mac version of the FiOS Media Manager only allows audio and photos to be streamed.

    Do you guys know of any similar programs to Streambaby that would allow us to stream video from Mac's to FiOS DVR's?
  14. Frankoz2

    Frankoz2 New Member

    May 31, 2009
    Any news for Aussie Streambaby devotees? we're missing the you
  15. easily_confused

    easily_confused New Member

    Sep 1, 2009
    I'm wild about streambaby --- thanks for this app

    For the most part streambaby seems to work fine. But, When I play this I get "failed to open stream" with ffmpeg running. I have a stock ini file except for disable_preview. Once this fails, nothing works and I have to restart streambaby.

    Oh, and I have a TIVO series 3 HD

    Attached Files:

  16. easily_confused

    easily_confused New Member

    Sep 1, 2009
    Using 0.27

    I consistently get 0xffff errors after a split VOB file terminates. By split VOB I mean, for example, an episode on a multi-episode dvd that is split across 2 vob files.

    A few times I was able to continue after the first VOB ended. A few times when I navigated back to the streambaby top level I saw a full screen image from the video appear momentarily and then go away. I could then go back and play the 2nd part (no log of this though). A few times I tried playing an mpeg2 and then went back and played the second part. But, sometimes those methods don't work, and I just have to "wait it out", I guess.

    When the tivo is in the 0xffff mood (mode?) youtube does not work either. In fact, now that's how I determine I can go back to streambaby. If youtube works, streambaby will too.

    It seems like anytime I exit a vob early I leave the tivo in some weird mode that causes 0xffff.

    I expect there is something you can do (or not do) at the server end to allow it to clean up when a video abrubtly ends, but figuring it out may be tricky.

    I'll be happy to send logs or whatever you need to get this fixed.

    Here are the log entries at the point of the ending of the first vob - VTS_07_1.VOB. Note the point at which the timestamp jumps and the socket error occurrs. Afterwards is just me pressing buttons.

    11/28/09 01:42:43 MpegStreamingModule$1: MpegEndTS:Timestamp: 2334.04, filePos: 1073651726
    11/28/09 01:42:43 NamedStream: Registering named stream: 65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream
    11/28/09 01:42:44 Listener: http=HttpRequest /streambaby/65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream
    111/28/09 01:42:43 ViewScreen: Desc: VTS_07_1.VOB
    1/28/09 01:42:44 Listener: path=/streambaby/65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream uri=/streambaby/
    11/28/09 01:42:44 Listener: 
    11/28/09 01:42:44 Listener: 65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream HTTP GET - to factory /streambaby/
    11/28/09 01:42:44 StreamBabyStream$StreamBabyStreamFactory: uri=65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream
    11/28/09 01:42:44 NamedStream: Getting mapped stream for named stream: 65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream
    11/28/09 01:42:44 NamedStream: Getting mapped stream for named stream: 65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream
    11/28/09 01:42:56 NewStatusBar: state=true
    11/28/09 01:43:01 NewStatusBar: state=false
    11/28/09 01:43:14 ViewScreen: code=20 rawcode=16789780
    11/28/09 01:43:18 ViewScreen: code=17 rawcode=16789521
    11/28/09 01:43:51 ViewScreen: code=16 rawcode=16789264
    11/28/09 01:46:12 ViewScreen: code=16 rawcode=16789264
    11/28/09 02:11:05 InfoCache$PruneTask: Pruning cache...
    11/28/09 02:11:05 InfoCache$PruneTask: Pruning complete.
    11/28/09 02:21:21 ViewScreen: END: 
    11/28/09 02:21:21 ViewScreen: goto position: 2303441, vidlen: 2333760
    11/28/09 02:21:21 ViewScreen: Position not in buffer, starting new stream
    11/28/09 02:21:21 NewStatusBar: state=false
    11/28/09 02:21:21 ViewScreen: Openening stream at position: 2303000(2303 secs)
    11/28/09 02:21:21 VideoModuleHelper: quality setting is above quality of video, streaming normally
    11/28/09 02:21:21 MpegStreamingModule$1: MpegStartTS:Timestamp: 0.28, filePos: 2062
    11/28/09 02:21:21 MpegStreamingModule$1: MpegEndTS:Timestamp: 2334.04, filePos: 1073651726
    11/28/09 02:21:21 MpegStreamingModule$1: Seeking for ts 2303.280000001192 to timestamp: 2303.24, filePos: 1054967822
    11/28/09 02:21:21 NamedStream: Registering named stream: 87f74c1f-94a3-4211-8611-43077d4b0a15.stream
    11/28/09 02:21:21 NamedStream: DeRegistering named stream: 65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream
    11/28/09 02:21:21 Listener: 
    11/28/09 02:21:21 Listener: I/O Exception handling  HTTP GET 65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream: Connection reset by peer: socket write error
    11/28/09 02:21:21 Listener: ctx=HttpRequest /streambaby/65ac8c7c-8325-4a6d-a5fb-9b1925e82791.stream t=java.net.SocketException: Connection reset
    11/28/09 02:21:23 ViewScreen: error=ERROR: 0xffff
    11/28/09 02:21:23 ViewScreen: error=ERROR: 0xffff
    11/28/09 02:21:23 ViewScreen: error=ERROR: 0xffff
    11/28/09 02:21:23 ViewScreen: error=ERROR: 0xffff
    11/28/09 02:21:23 ViewScreen: error=ERROR: 0xffff
    11/28/09 02:21:23 ViewScreen: error=ERROR: 0xffff
    11/28/09 02:21:29 ViewScreen: code=4 rawcode=16777732
  17. Len McRiddles

    Len McRiddles New Member

    Dec 21, 2002
    Are you using a Linksys BEFSR41, If you are, do you have WAN multicast filtering enabled? The reason I ask is I ran across this today.

  18. rustyshackelford

    rustyshackelford rusty shackelford

    Apr 9, 2009
    success!!!! that was what was wrong with mine. i struggled for months trying to get that to work. worth every bit of a beer for the steer. thanks len. you are one fine fellow. good karma to you.
  19. superflysocal

    superflysocal New Member

    Nov 26, 2009
    So what is the best app or script for windows that converts mp4 with multichannel aac to mp4 with multichannel ac3?
  20. whozat

    whozat New Member

    Jan 30, 2009
    hey, folks. Long-time user of streambaby with a quick question about subtitles.

    Looking through the thread, I've seen mention of using .srt files for subs, and using t2sami to generate the srt files. I've just used t2sami GUI, and it generated .smi files from my DVDs. These look like a richer format than .srt files, but just putting "My Movie.smi" next to "My Movie.mp4" didn't seem to work...doing the same with an .srt file worked fine, though.

    Does streambaby not support .smi files? Is there something else I have to do first?


Share This Page