1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. net114

    net114 Tivolitic Guru

    860
    0
    Dec 29, 2000
    florida
    Yes, but I found it easier to just change the .bat file. :)
     
  2. Len McRiddles

    Len McRiddles New Member

    1,262
    0
    Dec 21, 2002
    U.S.S.A
    Thank you very much sir. That did the trick.
     
  3. sfalvey

    sfalvey Long time lurker

    75
    0
    Feb 26, 2004
    Sydney,...
    I have been using streambaby for about 6 months without any problems up until a couple of days ago. Suddenly it stopped working and I have been scratching my head since then.

    When I select any video to watch, even ones I have watched before I get red text saying Error 0xffff and the filename.

    I have switched on debug logging and there does not appear to be anything reported.

    I have tried removing the title cache and the .txt metadata files with no luck. I have also tried the usual rebooting the server and the tivo. I have tried moving all the videos out of the way and just used one file in a single directory. I have also tried running ffmpeg by hand against the file and everything seems to be working there.

    The obvious question is what has changed. Nothing on my end that I am aware but TiVo service sent out an update this week for Aussie TiVos that among other things changed "Watch Live TV" to "Watch Freeview" on TiVo Central. I dont know what else may have changed at the backend.

    The last time I had problems with Streambaby it was because of a problem with the TiVo service where my TiVo (and a number of other customer's TiVo) stopped being able to run apps. That was fixed by TiVo because it also effected the Blockbuster downloads. This time only Streambaby seems to be effected.

    Are there any other Aussie users out there using Streambaby without a problem?

    Any ideas of where else I could look would be appreciated.

    Cheers
     
  4. Pepito

    Pepito New Member

    16
    0
    Jan 7, 2009
    Australia
    11.1b-01-2-663


    Greetings from Australia
     
  5. net114

    net114 Tivolitic Guru

    860
    0
    Dec 29, 2000
    florida
    Pepito did you reboot your Tivo?

    I know, dumb question, but with our 2nd Tivo it uses a wireless connection, and it does that sometimes, the only thing to fix it is to wait 20 minutes or reboot the tivo.
     
  6. Pepito

    Pepito New Member

    16
    0
    Jan 7, 2009
    Australia
    Yes I did, but rebooting again now :)

    edit: You're not going to believe it, Streambaby now works again. I swear I rebooted it when it first stopped working!

    Interestingly I just spoke to a mate who tells me his TiVo is running 11.3a-01-2-663 firmware. His "Watch Live TV" option now says "Freeview".


    Greetings from Australia
     
  7. Len McRiddles

    Len McRiddles New Member

    1,262
    0
    Dec 21, 2002
    U.S.S.A
    I have heard that not all versions of XP are compatible with streambaby. Bonjour will work with other apps, but not streambaby from what I remember.
     
  8. AussieMark

    AussieMark New Member

    8
    0
    Oct 27, 2009
    Hot off the press from TiVo staff in Australia. The newest firmware upgrade has disabled Streambaby in Australia and New Zealand .....

    "Hi Everyone

    With the latest release of Software the .tivo files that are moved from the TiVo to the PC and back now use transport streams instead of program streams. This was necessary for us to support H.264 in NZ for both MRV and TiVo Desktop.

    This new format does break Streambaby – however this has occurred in the past when we have released new SW, and the Open Source community simply sniffs the new protocol and updates StreamBaby to make it work again. I can't give you a target date but it has been updated relatively quickly in the past.

    Thanks

    Craig"
     
  9. Pepito

    Pepito New Member

    16
    0
    Jan 7, 2009
    Australia
    Does this mean Australian Tivo's are running a later version firmware than the rest of the world now? :)
     
  10. AussieMark

    AussieMark New Member

    8
    0
    Oct 27, 2009

    Not sure, but it's definitely a different version of firmware, because the newest version replaces "watch live TV" on the main Tivo menu with "watch Freeview".

    Hopefully the Streambaby crowd will be able to rectify this issue soon. I've logged the bug over at the Streambaby open source site.
     
  11. sharmos

    sharmos New Member

    2
    0
    May 8, 2009
    Yep I've got the exact same problem and it's frustrating the hell out've me !!!
     
  12. Pepito

    Pepito New Member

    16
    0
    Jan 7, 2009
    Australia
    Good work AussieMark :up:
     
  13. petestrash

    petestrash New Member

    210
    0
    Mar 7, 2004
    Perth,...
    Confirmed streambaby is killed by 11.3a here.

    If one of the devs would like some info on 11.3a feel free to pm.

    Peter.
     
  14. sfalvey

    sfalvey Long time lurker

    75
    0
    Feb 26, 2004
    Sydney,...
    Ditto. If anyone needs packets grabbing etc, please let me know.

    Simon
     
  15. kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    I've uploaded a new SVN release (been a while..) that includes a delete from hard-drive modification submitted by t14cl (I hope thats right, I have trouble remembering names with numbers, and for that matter any name I can't pronounce ;-)

    http://streambaby.googlecode.com/files/streambaby-svn-r253.zip

    It's a bit hackish at the moment (may be forever...) in that on the PlayScreen the "Go back" button line now has a dual-purpose. Pressing left-arrow or select goes back to the previous screen as usual. However, pressing right-arrow selects the "More" screen.

    The only option on the "More" screen is currently "Delete from Hard Drive"

    -- As a shortcut you can also press "clear" from the PlayScreen to delete the movie from the hard drive.
    (The play screen is the screen after you select the video and it shows the details of the video)
     
  16. kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    What I'd be most interested in at this point is what wmcbrine asked about in another streambaby thread about this issue:

    -- Do MP4 files streamed natively still work.

    Streambaby currently streams files to the TiVo using either MPEG-2 program stream (which everything except MP4 eventually ends up transcoded to) or H.264/MP4.

    From the quote from TiVo that was posted it made it sound like it was the MPEG-2 PS (program stream) that has changed to a TS (transport stream).

    Having said that, I think it may be up to someone in Australia with the TiVo knowledge to fix the issue or at least tell me pretty explicitly what needs to be changed. It may be a bridge-to-far to try and fix this without having a TiVo with the issue to test with in front of me. I'd be more and willing to give my input about things that may need to be changed.
     
  17. AussieDielo

    AussieDielo New Member

    2
    0
    Oct 28, 2009
    Perth,...
    I've got an Aussie TiVo Series 3 connected to my network at home via wire. I've installed Streambaby on a Windows XP PC and setup the ini file to point to a directory where I have *.avi, *.wmv files. When I start streambaby.bat it runs and my TiVo can see all the video files on my XP PC but when I go to play any of them, the TiVo displays an x2e006a error message.

    Question. I know that the Home Network option is bundled in the USA version and it's an additional cost for people in Oz. Do I need to purchase this? Is that my problem?
     
  18. Erasmus

    Erasmus New Member

    2
    0
    Apr 3, 2009
    Yes you need a Media Access Key (MAK) to use any networking functions, and the only way to get one in Australia is to purchase the Home Network Package. This retails for $199 but if you look on the whirlpool forums you can get a special offer of $99. The problem is that Streambaby won't work with the latest update of the Tivo firmware which will hit your box soon if it hasn't already. The Tivo supplied desktop software is pretty flakey at the moment so I would hold off if I were you.
     
  19. t1c4l

    t1c4l New Member

    15
    0
    Apr 13, 2009
    Thanks for polishing it up a bit :up: I like that you added the CLEAR button feature too, I didn't think of that.
     
  20. t1c4l

    t1c4l New Member

    15
    0
    Apr 13, 2009
    If that is what the issue is (Transport Stream change) I might give it a shot at changing it as I've also got an Aussie TiVo and it just started giving 0xfffff for me too :mad:
     

Share This Page