1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. BJezz

    BJezz New Member

    68
    0
    Jan 11, 2009
    Netflix are not mentioned in the copyright information on the TiVo, whereas pretty much everybody that can be mentioned has been. This suggests to me that there is no Netflix component running on the TiVo itself and that they are streaming data over HME.

    I'm just guessing though. But if it is using HME, I would be surprised if the network traffic to control the streaming was encrypted. I would only expect the video itself to be encrypted.

    I don't have a Netflix account, so I cannot volunteer with a packet sniffer.
     
  2. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    TiVo routinely uses HME over SSL, even for stuff that seems pointless to hide, much less stuff that they actively want to hide; so yes, it's encrypted.

    HME per se doesn't stream anything. We send a command to the TiVo, with a URL, and it fetches the material "behind the scenes". As it does so, it sends back status reports every so often -- where it is in the stream, what rate it's playing at. At the same time, we can send commands -- pause, speed up, etc.

    Now, in Streambaby, the TiVo ends up making its http request right back to the same server that's running the HME front-end. But handling that request is technically outside the scope of HME. (It's just a standard http request, like you'd make to download a file.)
     
  3. BJezz

    BJezz New Member

    68
    0
    Jan 11, 2009
    Well that sucks, but is very interesting. I had this vision of the HME commands being intertwined with the encrypted video, making it difficult (but eventually possible) to decipher the command set. But if the HME calls are encrypted on a separate connection, I see rebuffering being a workaround in Streambaby for a long time to come.
     
  4. jcthorne

    jcthorne Active Member

    2,726
    3
    Jan 28, 2002
    Houston
    For vids longer than 1 hr, why not just have them pushed and start watching a few minutes later when the buffer has built up? Seems to work for most .mp4s I have tried.
     
  5. blastoff

    blastoff New Member

    17
    0
    Nov 29, 2006
    Have given streambaby a try. No problems installing, messages indicate it is running, but it does not show up on my Tivo (under music, photos ...). Have tried changing video directory, ports, and IP, but no joy.
     
  6. wbm

    wbm New Member

    1
    0
    Jun 10, 2009
    I'm having problems getting it to work too. Dled and configured it, got the latest version of Java. Mine shows its ready on the PC, and appears in the tivo menu, but when I click the option I usually just get a please wait screen for a couple of minutes, then the 50005 connection error. A couple of times it has pulled up my videos folder, but when I press play I get about a second of video, then it crashes and the PC shows the connection has been reset. I'm not real literate with this stuff, so if anyone has ideas for me to try I would very much appreciate them. Also, if there's a resource where there's troubleshooting info I would love to know about it.

    I liked the idea of SB because I've read the TIVO desktop is a bit of a resource hog on a PC, and I just want to occasionally be able to stream a movie or TV show from my computer.

    Thx in advance for any help.
     
  7. rfryar

    rfryar My Media, My Way

    222
    0
    Feb 15, 2008
    Cottage...
    For the HD videos I am using in MP4 format, 8K bitrates, they will stream fine, just a bit faster than live. But when pushed they transfer a LOT slower than real time. Not sure why that is the case but it is for me at least.

    Also one of my Tivo's is on the test servers so I can not push content to it at the moment. :)

    Rick
     
  8. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    First rule of fight club ...
     
  9. moyekj

    moyekj Well-Known Member

    11,151
    35
    Jan 23, 2006
    Mission...
    Actually you can. In streambaby config just change the mind server to the following (instead of mind.tivo.com):
    stagingmind.tivo.com
     
  10. Sheldon469

    Sheldon469 New Member

    39
    0
    Mar 21, 2004
    MD, USA
  11. cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    What does this error mean?

    Initializing StreamBaby svn-r238...
    java.net.BindException: Cannot assign requested address: JVM_Bind
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(Unknown Source)
    at java.net.ServerSocket.bind(Unknown Source)
    at java.net.ServerSocket.<init>(Unknown Source)
    at com.tivo.hme.host.http.server.HttpServer$PortInterface.<init>(HttpSer
    ver.java:204)
    at com.tivo.hme.host.http.server.HttpServer$Port.<init>(HttpServer.java:
    169)
    at com.tivo.hme.host.http.server.HttpServer.start(HttpServer.java:79)
    at com.unwiredappeal.tivo.streambaby.host.Listener.<init>(Listener.java:
    103)
    at com.unwiredappeal.tivo.streambaby.host.Main.<init>(Main.java:137)
    at com.unwiredappeal.tivo.streambaby.StreamBabyMain.main(StreamBabyMain.
    java:152)
    error: Cannot assign requested address: JVM_Bind
    usage: Main [--port <port>] [--ip <ip>] class

    Exited.
    Press any key to continue . . .
     
  12. solutionsetc

    solutionsetc Member

    762
    0
    Apr 2, 2009
    Northern...
    Just a guess but do you have a firewall that might be blocking incoming connections to Java?
     
  13. cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    It worked the other day on an older version of streambaby. I just upgraded recently.
     
  14. cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    SVRN-232 runs fine I just tested it.....I always just copy my ini file over to the new version. I can't run any of the 2 new versions 238 and 239.
     
  15. solutionsetc

    solutionsetc Member

    762
    0
    Apr 2, 2009
    Northern...
    Does the version that used to work still work?
     
  16. kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    Somewhere between those version (I think) I "fixed" a problem with binding to wrong IP addresses... Either I fixed it incorrectly, or it was only working on your system before due to a bug.

    Do you have an ip= line in your streambaby.ini? If so make sure it is the correct IP address that you want to bind to. (And you can try commenting it out if it is there also).
     
  17. cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    Yep - I just copy the ini file from each version to the next. I also commented it out and then it just sits there and doesn't do anything.
    R237 works but I can't get 238 or 239 to go.
     
  18. westside_guy

    westside_guy Annoyingly ephemeral

    464
    1
    Mar 13, 2005
    The soggy...
    I've run into a problem with the latest subversion code (r239), running on Mac OS X 10.5.7. Happens whether I use the default java or force use of 1.6.

    Code:
    $ ./streambaby
    Initializing StreamBaby svn-r239...
    06/21/09 16:56:55 FFmpegJavaVideoModule: Unable to load FFmpeg native libraries
    java.net.BindException: Can't assign requested address
            at java.net.PlainSocketImpl.socketBind(Native Method)
            at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
            at java.net.ServerSocket.bind(ServerSocket.java:319)
            at java.net.ServerSocket.<init>(ServerSocket.java:185)
            at com.tivo.hme.host.http.server.HttpServer$PortInterface.<init>(HttpServer.java:204)
            at com.tivo.hme.host.http.server.HttpServer$Port.<init>(HttpServer.java:169)
            at com.tivo.hme.host.http.server.HttpServer.start(HttpServer.java:79)
            at com.unwiredappeal.tivo.streambaby.host.Listener.<init>(Listener.java:103)
            at com.unwiredappeal.tivo.streambaby.host.Main.<init>(Main.java:137)
            at com.unwiredappeal.tivo.streambaby.StreamBabyMain.main(StreamBabyMain.java:152)
    error: Can't assign requested address
    usage: Main [--port <port>] [--ip <ip>] class
    
    $
    
    With an identical streambaby.ini file, 0.27 works just fine. I just decided to try the subversion code today to see if some mp4 audio synch issues got cleared up.

    Here's the .ini file (in case someone asks):

    Code:
    #
    # ./streambaby --help for more configuration file options
    #
    
    # Video share(s)
    
    title=Our Video Collection (Streambaby svn-r239)
    dir.1=/Volumes/foobar/moveez
    dir.1.name=Our Video Collection
    
    toplevel.skip=true
    
    # Ip address to bind to
    
    ip=192.168.1.7
    
    # port to use
    
    port=7290
    
    # ffmpeg info
    
    ffmpeg.path=/sw/bin/ffmpeg
    
    # Tivo.com account information (needed for optional video push)
    
    tivo.username=foo@foo.bar
    tivo.password=fubar42
    
    tivo.1=This is the important tivo
    tivo.1.tsn=1234567890ABCD
    tivo.2=This is the less important tivo
    tivo.2.tsn=DCBA0987654321
    
    # Miscellaneous settings
    
    ##mp4module.interleave=false
    preview.big=true
    
    use.title=true
    sort.filename=true
    meta.vidinfo.disable=false
    use.title.cachedonly=false
    
    Any ideas? Thanks!
     
  19. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    Obvious question: is your machine's IP address 192.168.1.7? is port 7290 already taken by another program?


    The ffmpeg warning is because you don't have the shared libs set up right (although I'm assuming you don't care).
     
  20. westside_guy

    westside_guy Annoyingly ephemeral

    464
    1
    Mar 13, 2005
    The soggy...
    Yes, and no. Everything works fine with streambaby 0.27. When I stop it, and then try to start svn-r239, the errors occur. If I then turn around and start 0.27 again, everything is fine.

    Yeah, I've never cared enough about those warnings to bother solving them. :D I almost exclusively use streambaby in push mode; so the thumbnailing etc. isn't important to me.
     

Share This Page