1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. Jan 30, 2009 #281 of 3415
    kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    That all looks fine (well, the fps and channels are wrong, but that should be fixed in the next version and doesn't get used in the current version).

    So my current guess is this:
    1) You can't delete FFmpeg. If you delete ffmpeg then streambaby won't be able to use it to get the length, type, etc of the videos, so this is why the video won't play at all when you delete it.
    2) The reason ffmpeg was running in the background when you tried to play the video, was not because it was transcoding it, but because it was generating the thumbnails for preview mode. You can disable the autogeneration of thumbnails by setting in streambaby.ini:
    preview.autogenerate=false
     
  2. Jan 30, 2009 #282 of 3415
    Sicklybutsexy

    Sicklybutsexy New Member

    179
    0
    May 5, 2007

    Ah. That would explain the fact that ffmpeg wasn't working very hard. thanks again.
     
  3. Jan 30, 2009 #283 of 3415
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Here's what ldd gives me:
    Code:
    windracer@zhaan:~$ ldd /usr/bin/ffmpeg
            linux-gate.so.1 =>  (0xb7f08000)
            libz.so.1 => /usr/lib/libz.so.1 (0xb7ecc000)
            libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7ea6000)
            libfaac.so.0 => /usr/lib/libfaac.so.0 (0xb7e93000)
            libfaad.so.0 => /usr/lib/libfaad.so.0 (0xb7e53000)
            libmp3lame.so.0 => /usr/lib/libmp3lame.so.0 (0xb7dbe000)
            libtheora.so.0 => /usr/lib/libtheora.so.0 (0xb7d73000)
            libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb7c79000)
            libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb7c4f000)
            libxvidcore.so.4 => /usr/lib/libxvidcore.so.4 (0xb7b36000)
            libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7b32000)
            libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7b19000)
            libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb79bb000)
            /lib/ld-linux.so.2 (0xb7eee000)
            libogg.so.0 => /usr/lib/libogg.so.0 (0xb79b5000)
    
    I'll try the LD_LIBRARY_PATH=/usr/lib again tonight along with the debug logging.
     
  4. Jan 30, 2009 #284 of 3415
    kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    Streambaby V0.20beta
    has been released. I'm calling it beta, as there are some core changes and I consider it more of a beta than usual.

    You can check out the complete change list here:
    ChangeLog

    As I alluded to in an earlier message, the icon's have changed by default, as I was nervous about a couple of licensing issues. (The icons license gives permission to use in open source, but I am unsure of compatibility with GPL/google code/etc)
    The icons are stored now in the assets directory of streambaby, and can be changed using the following ini settings:
    icon.icon=, icon.folder=, and icon.movie=. FIlenames are relative to the assets dir

    The main feautre that has been added is actually disabled by default (I may enable it in the next/future version, but I wanted to get reaction first).
    This feature is the ability to select a quality from the "play" screen. When enabled, it allows you to select a quality/bitrate to stream at. Only bitrates that are less than the bitrate of the movie are shown.
    Same=Stream at same quality as original (i.e. stream straight to tivo or use -sameq)
    (Note: There are settings in the INI to enable Auto quality, but it is non-functional yet. Auto=determine bandwidth automatically)

    Note: People who have changed their default ffmpegexe.transcode line should remove any reference to bitrate/quality (i.e. -bitrate or -sameq) from the line, even if they do not enable the new quality features.
    The quality is now set by changing ffmpegexe.transcode.sameqargs= and ffmpegexe.transcode.qualityargs. sameqargs is used for "same" quality (default), quality is used for diffrent bitrates.

    See a more complete description here:
    QualitySettings

    Other features that people asked for in no particular order (and not complete) that are in this version:
    INI settings for: not caching password, not ignoring files beginning with a dot, jumping straight to the first folder (dir.1) if it is the only one.
    minimal .tivo file support (although I don't think it will be useful)
    alpha cutlist support (EDL files)-- Let me know how it goes, if it doesn't work well I may have to remove it. Accuracy may be off by too much to be useful.

    Make sure to check out the new INI settings for some of the new features:
    New for 0.020

    Still to do, in no particular order (and no guarantees that I dont go in a completely different direction...)
    1. metadata support/better "info"
    2. auto-quality support
    3. easier/better galleon integration? Probably won't do complete config at this point.
    Note: I'm a little worried I made galleon support worse in this version, if so, sorry.

    Also note, I've stopped uploading the -src distribution, as the latest source should always be available in SVN.
     
  5. Jan 30, 2009 #285 of 3415
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    Ok nothing will help there
    your ffmpeg is linked statically to the ffmpeg libraries ( libavutil, libavcodec, etc are not listed as
    shared libraries to find -- ergo they are statically linked into the ffmpeg binary)

    you will need to get those shared libs from somewhere to make it work.
    Did you get ffmpeg from a package? did you build it?
     
  6. Jan 30, 2009 #286 of 3415
    Emillion

    Emillion New Member

    24
    0
    Oct 19, 2007
    # An unexpected error has been detected by Java Runtime Environment:
    #
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x78010aa8, pid=1100, tid=2784
    #
    # Java VM: Java HotSpot(TM) Client VM (10.0-b23 mixed mode, sharing windows-x86)
    # Problematic frame:
    # C [msvcrt.dll+0x10aa8]
    ...............................................
    VM Arguments:
    jvm_args: -Xmx256m
    java_command: C:\Program Files\StreamBaby\/jbin/streambaby.jar
    Launcher Type: SUN_STANDARD
    ..............................................
    --------------- S Y S T E M ---------------
    OS: Windows 2000 Build 2195 Service Pack 4


    0.18 did not have this error, any ideas? Firewall, JRE?

    Great app - loved tivostream, love this,
    Thank you
     
  7. Jan 30, 2009 #287 of 3415
    kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    At what point did you receive this error? As soon as streambaby was started, or at some point later on (like when attempting to play a particular video, etc..)

    Thanks
     
  8. Jan 30, 2009 #288 of 3415
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    (bug report removed)
    edit Ok it looks more complicated than my post.
    It seems some inputs can be resampled 5.1 -> 2, others can't.. let me see if I can figure out what's going on.

    Ok:
    5.1 AAC -> 2 AC3 is not doable
    5.1 AC3 -> 2 AC3 works

    So, <grumble> it *shouldn't* matter, but I guess input encoding does. I guess 'screw it' for now. Easier to keep things as h.264/ac3 than worry about this crap.. :). I'm going to set my 2channel default to 0 to avoid worrying about this.
     
  9. Jan 30, 2009 #289 of 3415
    kearygriffin

    kearygriffin New Member

    346
    0
    Jan 31, 2008
    <grumble> is right. I just tested with my newer version of ffmpeg (SVN from mid-december) and have the same issue with resampling. The older ffmpeg that ships with my Ubuntu 8.10 happily resamples 5.1 aac -> 2 ac3.

    I'll either drop the 2-channel option completely, or more than likely just make the default 0 like you in the next rev, just in case this gets changed/fixed in ffmpeg at some point.
     
  10. Jan 30, 2009 #290 of 3415
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Built it myself, yah.

    I'm going to try the new version, see what happens.
     
  11. Jan 30, 2009 #291 of 3415
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    Just make sure to use the --enable-shared flag when you run configure.
    That will build the binary using shared libs.. then run 'make install' to put the shared libs into /usr/local/lib and the app into /usr/local/bin

    (or whatever.. just if you use --prefix, make sure wherever you put it is a location ld.so knows to look for libs in)
     
  12. Jan 30, 2009 #292 of 3415
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    I meant I was going to try the new version of streambaby, not ffmpeg. ;)

    I might try recompiling ffmpeg at some point, but right now I've got it just the way I like it. I can live without thumbnails while FF'ing.
     
  13. Jan 30, 2009 #293 of 3415
    jasa

    jasa New Member

    23
    0
    Nov 5, 2008
    Earth
    I just tested new version and it looks that it is more developed than older version version and overall tivo recognition is better plus time out has been fixed, all of this are good, but flv video sound sucks((( I just hear some funny voices probably a audio codec issue.

    I think only problem as of now is support for file types, and since this is based on ffmpeg you should not have much trouble adding full list of file types such as 3gp and so on )))

    In general I just wanted to say that program rocks and thanks again


    I do not get why people want to integrate this with galleon??? whats the big deal???

    I think it works better on its own, or at least from my experience galleon and streambaby do not run as smoothly together.
     
  14. Jan 30, 2009 #294 of 3415
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    a) because we can ;)
    b) because I don't need multiple java services running on my server listening on multiple ports requiring multiple startup scripts when I can do it all in one "container"
     
  15. Jan 30, 2009 #295 of 3415
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    Ok Keary. commentary?:

    Toying around with some videos, I've noticed that if I supply -s 1920x1080, videos are always 'fitted to the screen correctly'. 1.85 movies have bars above/below. 1.33 movies have bars to left/right. 1.66 fit just right.

    If I let streambaby select the resolution, 'stretching' occurs. And it's 'weird'. some 1.33 films are stretched to fit. Some 1.66 films are letterboxed. etc..

    So, I thought maybe supplying an -aspect flag would help.. While it helps some (16:9 films, when I use -aspect 1, work) it's not a fixer. I was thinking that maybe for particular resolutions, tivo just does its own thing with aspect ratios and ignores the PAR/DAR values? I figure someone must have come across this issue with pyTivo?

    Anyways, here's an example 4:3 encode:
    Code:
    Input #0, matroska, from '/Volumes/External Disk/movies/Cartoons/Shrek_2.mkv':
      Duration: 01:32:24.68, start: 0.000000, bitrate: N/A
        Stream #0.0(eng): Video: h264, yuv420p, 720x478, PAR 8:9 DAR 320:239, 23.98 tb(r)
        Stream #0.1(eng): Audio: ac3, 48000 Hz, 5.1, s16
    
    and from the log:
    Code:
    uri: file:/Volumes/External%20Disk/movies/Cartoons/Shrek_2.mkv, Container: mkv, Duration: 5544.689 seconds
    Video: h264 720x478 23.976023976023978 fps
      PixAspect: 1.0, Aspect: 1.5062761
    
    (note that the the computed PixAspect and Aspect values are wrong).

    Ideas?
     
  16. Jan 30, 2009 #296 of 3415
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Actually, I think you made it better/easier! I've updated my post with the steps in it.

    Somehow, I'm getting thumbnails when FF'ing now as well! Maybe due to the improved/streamlined setup (thanks to the streambaby.dir setting).

    I can also confirm that ignore.dotfiles and toplevel.skip work beautifully. Thanks! :up:
     
  17. Jan 30, 2009 #297 of 3415
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    re:thumbnails:
    If you have the shared libs, they are always 'working'. If you don't, then it will generate (quietly, in the background) thumbnail icons. If you wait long enough before fast forwarding, it will have them all ready and you won't know a thing has changed. However, if you try early enough -- before the relevant ones have been generated, you will get a gray thumbnail.
     
  18. Jan 30, 2009 #298 of 3415
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Ok, that explains what I'm seeing then.

    I found this in my logs, so it would seem you're right (not that I doubted you ;)):

    Code:
    INFO   | jvm 1    | 2009/01/30 23:11:16 | 01/31/09 04:11:16 FFmpegJavaVideoModule: Unable to load FFmpeg native libraries
    
    I guess a rebuild of ffmpeg is next on my to do list ... maybe this weekend.
     
  19. Jan 30, 2009 #299 of 3415
    westside_guy

    westside_guy Annoyingly ephemeral

    464
    1
    Mar 13, 2005
    The soggy...
    Hmm, streaming w/ 0.20beta on my Mac (using Java 1.6), video in the one animated show I watched would start and stop - animation wasn't smooth, in other words, like it was dropping a a bunch of frames every so often. Audio seemed fine (smooth). I then tried watching the same show with 0.19a and didn't see any problems with audio or video.
     
  20. Jan 30, 2009 #300 of 3415
    bluehz

    bluehz New Member

    36
    0
    Dec 19, 2008
    Upgraded to 0.20 on Ubuntu 8.10 server running through galleon and no go. As soon as I hit the StreamBaby, Stream menu item I get this in the logs:

    23:46:08,674 INFO [Acceptor] AppHost - Current resolution is: com.tivo.hme.sdk.Resolution[640x480-PAR=1/1]
    23:46:08,687 INFO [Acceptor] AppHost - HME receiver disconnected
    23:46:08,705 INFO [Acceptor] AppHost - connection to receiver closed
    23:46:08,706 INFO [Acceptor] AppHost - Unexpected error: java.lang.NullPointerException

    FWIW - streambaby standalone 0.20 runs just fine. Any suggestions windracer?
     

Share This Page