1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streambaby - new streaming application

Discussion in 'TiVo Home Media Features & TiVoToGo' started by kearygriffin, Jan 20, 2009.

  1. Nov 6, 2013 #2721 of 3415
    TheWGP

    TheWGP Hmmm...

    299
    0
    Oct 26, 2007
    Just thought I'd report back. I just installed OS X Mavericks and, like everyone else, needed to reinstall a Java SDK.

    I installed the Java SE Development Kit 7u45 from the link that OS X sent me to (http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html), the one for Mac OS X x64.

    My streambaby is working just fine. Please note, though, that I have the fix / edit applied in my streambaby.bat as follows:

    java -Djava.net.preferIPv4Stack=true -Xmx256m -jar "$DIRNAME/jbin/streambaby.jar

    All of that may or may not be needed (per recent posts) but that's what I'm using and it works for me, so until someone fixes streambaby itself... :up:

    Happy Mavericks-streambabying!
     
  2. thewebgal

    thewebgal MacAphile AV geek

    375
    1
    Aug 10, 2007
    DC 'burbs
    So - I am thinking about upping my system and replacing my TIVOHD with the basic Roamio - can anyone comment if Stream Baby will still work with the Roamio?
     
  3. moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    It does and with the same 1.1GB buffer size limitation.
     
  4. thewebgal

    thewebgal MacAphile AV geek

    375
    1
    Aug 10, 2007
    DC 'burbs
    I don't mind that limit - its works out to about 45 mins per buffer-full on our current TIVOHD system ... Sounds like a good plan to get the price match on a Tivo Roamio at BestBuy today, order a 3TB WD drive and get it online for Christmas!
     
  5. Dec 1, 2013 #2725 of 3415
    meBigGuy

    meBigGuy New Member

    13
    0
    Feb 23, 2007
    I'm running Windows 7 x64, wired network connection to my TIVO Series 3 HD. quad core I7 @ 2.6GHz.

    Stock streambaby v.29 with vanilla ini (no tweaks)

    When streaming a 720p video (Video=3.764Kbps) the Tivo does not keep up if I let it stream at SAME. If I change to Highest - 5000 Kb/s then it streams without buffering issues, but the quality is way down.

    The file is a 43 min show and 1.4GB, but it rebuffers at 21min for some reason so maybe it is actually higher than 3.765Kbps when sent to the TIVO.

    Here are the video properties:
    Code:
    General
    Unique ID                      : 178439231546728339973762144169366149392 (0x863E255B992A49C6842DDF3CEFA85910)
    Complete name                  : B:\video\xyz.720p.WEB-DL.DD5.1.H.264-ECI.mkv
    Format                         : Matroska
    Format version                 : Version 4 / Version 2
    File size                      : 1.28 GiB
    Duration                       : 43mn 18s
    Overall bit rate               : 4 232 Kbps
    Encoded date                   : UTC 2013-09-27 11:13:15
    Writing application            : mkvmerge v6.3.0 ('You can't stop me!') built on Jun 28 2013 20:09:41
    Writing library                : libebml v1.3.0 + libmatroska v1.4.0
    
    Video
    ID                             : 1
    Format                         : AVC
    Format/Info                    : Advanced Video Codec
    Format profile                 : High@L3.1
    Format settings, CABAC         : No
    Format settings, ReFrames      : 2 frames
    Codec ID                       : V_MPEG4/ISO/AVC
    Duration                       : 43mn 18s
    Bit rate                       : 3 764 Kbps
    Width                          : 1 280 pixels
    Height                         : 720 pixels
    Display aspect ratio           : 16:9
    Frame rate mode                : Constant
    Frame rate                     : 23.976 fps
    Color space                    : YUV
    Chroma subsampling             : 4:2:0
    Bit depth                      : 8 bits
    Scan type                      : Progressive
    Bits/(Pixel*Frame)             : 0.170
    Stream size                    : 1.14 GiB (89%)
    Language                       : English
    Default                        : Yes
    Forced                         : No
    Color primaries                : BT.709
    Transfer characteristics       : BT.709
    Matrix coefficients            : BT.709
    
    Audio
    ID                             : 2
    Format                         : AC-3
    Format/Info                    : Audio Coding 3
    Mode extension                 : CM (complete main)
    Format settings, Endianness    : Big
    Codec ID                       : A_AC3
    Duration                       : 43mn 18s
    Bit rate mode                  : Constant
    Bit rate                       : 384 Kbps
    Channel(s)                     : 6 channels
    Channel positions              : Front: L C R, Side: L R, LFE
    Sampling rate                  : 48.0 KHz
    Bit depth                      : 16 bits
    Compression mode               : Lossy
    Stream size                    : 119 MiB (9%)
    Language                       : English
    Default                        : Yes
    Forced                         : No
    
    Text
    ID                             : 3
    Format                         : UTF-8
    Codec ID                       : S_TEXT/UTF8
    Codec ID/Info                  : UTF-8 Plain Text
    Language                       : English
    Default                        : No
    Forced                         : No

    Is the audio messing me up? Is it just too much video bandwidth? I tried setting the tuners to blank channels and it made no difference.

    It may be it messes up most when there is highest detail, so possibly there is higher datarate at that time.

    Any idea of what network data transfer rate the TIVO starts falling behind?
     
  6. Dec 1, 2013 #2726 of 3415
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Since it's MKV container streambaby is probably re-encoding the video to mpeg2 on the fly which is why it's slow. You should remux to mp4 container or use pyTivo instead with ts=on setting for best possible quality transfer. (Actually I'm not sure if pyTivo ts=on works for series 3 units or not since mine are all sitting in closets).
     
  7. Dec 1, 2013 #2727 of 3415
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Unless you are in Aus/NZ, you need an S4 or later for "ts=on" to do anything.
     
  8. Dec 1, 2013 #2728 of 3415
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
  9. Dec 1, 2013 #2729 of 3415
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Since I did not edit the quote, you must haves added after I quoted it but possibly before I posted.
     
  10. Dec 1, 2013 #2730 of 3415
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Gotcha. I added a minute after my 1st post after realizing series 3 unit was in the picture.
     
  11. Dec 1, 2013 #2731 of 3415
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Yeah, I started to post immediatly but decided I needed to make sure it was accurate so went off to find the post to which I linked.

    I used to try and avoid mkv files as I was running Win2k so couldn't run the ffmpeg needed for "ts=on", so xfers took forever. New machine running 8.1 thus new ffmpeg. Holy ****! I can actually see the progress bar moving. Takes < 3.5 minutes to xfer a 44 min 720p recording.
     
  12. Dec 6, 2013 #2732 of 3415
    meBigGuy

    meBigGuy New Member

    13
    0
    Feb 23, 2007
    I thought that if "SAME" appeared in the menu it was not being transcoded. But, no matter since I understand what is happening.

    I finally figured out the issue is that the encoding is variable data rate and was approaching 16Mb/s in peak bursts (during high detail scenes) (16000Kb/s). When I selected Highest-5000Kb/s it transcoded to that data rate and the quality suffered as a result.

    The TIVO just can't keep up with the higher average data rate that corresponds to scenes with high details (lots of trees with leaves in the breeze, in my case). It can do better than 5000 I think, but I don't know how much. Maybe I will eventually translate stuff to different fixed data rates and see where it breaks.

    I guess if you want really high quality you need to load the file in its entirety and then play it.
     
  13. berkinet

    berkinet New Member

    34
    0
    Dec 20, 2013
    I am running Streambaby in pyTivoX on MacOS 10.9.1 (Mavericks) and trying to receive the stream on a Roamio+. So far no joy. Maybe I am looking in the wrong places, but I can't find my stream anywhere on the Roamio+'s TiVo Central. Any ideas? (FWIW, pyTivo is working and I can download videos in My Shows.
     
  14. moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    TiVo Central->Apps & Games
    Look towards the bottom. If you don't see it then reset the HDUI using following remote sequence:
    Thumbs down, Thumbs up, play, play

    Then look under Apps & Games again towards the bottom. If you still don't see it that means it's not running properly perhaps because of firewall or A/V software.
     
  15. berkinet

    berkinet New Member

    34
    0
    Dec 20, 2013
    Thanks moyekj
    Well, some progress. I tried the regular streambaby distribution and it worked. Then I went into the pyTivoX bundle and started streambaby there from the command line. That worked. However, it seems pyTivoX cannot properly start streambaby.

    Has anyone else experienced this issue?

    OTOH, when I got stream baby to work (manual start from the command line) it displays with "\032" in place of the spaces: stream\032baby I guess this is a known issue... but, is there a workaround?
     
  16. moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    It's a TiVo bug. Workaround is use a title without spaces in streambaby.ini. I have following entry for title which shows up fine:
    title=streambaby
     
  17. berkinet

    berkinet New Member

    34
    0
    Dec 20, 2013
  18. Thomaseo1

    Thomaseo1 New Member

    7
    0
    Apr 25, 2012
    Is there a way to make Streambaby, by default, not show subtitles, by using either the .ini file or by modifying another file without disabling it.

    Also is it possible to have Streambaby show mpaa rating (G PG PG-13 R etc)from .txt files like PyTivo does?

    These 2 things have been bugging me forever and I can't seem to figure them out.

    Any help would be appreciated
    Thanks....
     
  19. thewebgal

    thewebgal MacAphile AV geek

    375
    1
    Aug 10, 2007
    DC 'burbs

    Some of the shows I've grabbed have .avi and .srt files in the folder. I have found if I get rid of the .srt files, I no longer see the subtitles.
    Does this help?

    FWIW, Steambaby is still working great for me on my Roamio connected to a mac pro running Mavericks.
     
  20. Thomaseo1

    Thomaseo1 New Member

    7
    0
    Apr 25, 2012
    Unfortunately not, the reason why it doesn't help is because it disables subtitles for the movies, even though I may want to use it later on. At current I need to hit the Zoom/aspect ratio button on every movie to turn off subs where I would like to only hit that button to turn them on only when I want them.

    Edit*
    Two more Questions
    What is the best version of Java to use?
    How can you completly disable ffmpeg.exe and only use the one built with Java, unless there is a way to use a 64 bit ffmpeg.exe.
     

Share This Page