1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange Tivo Mini & Roamio Pro issue

Discussion in 'TiVo Mini' started by preilly44, Jan 2, 2014.

  1. Jan 2, 2014 #1 of 18
    preilly44

    preilly44 Member

    41
    1
    May 31, 2011
    Hello all,

    I have a strange issue. My Mini is saying it can't find the Roamio Pro (error c421) and it won't let me view any recorded shows. Here is the strange part, I can view live TV with no problems (so it has to have a connection to the Pro).

    I've tried power cycling the mini and the Pro with no luck. I can connect to the Tivo service from the mini (and the pro) and I have another Mini that works off the same Pro with no problems.

    Any ideas?

    Patrick
     
  2. Jan 2, 2014 #2 of 18
    lessd

    lessd Active Member

    7,699
    5
    Jan 23, 2005
    CT
    If this is a new Mini it takes a few days to find your pro, try a call homes with both units.
     
  3. Jan 2, 2014 #3 of 18
    preilly44

    preilly44 Member

    41
    1
    May 31, 2011
    Looks like I fixed it by power cycling the Pro, Mini, Wireless bridge, router and cable modem at the same time.

    It is very strange that I was able to view live TV from the Mini (via the Pro) but nothing else.

    Thanks for your help!
     
  4. Jan 9, 2014 #4 of 18
    Videodrome

    Videodrome tivo - please wait..

    912
    0
    Jun 20, 2008
    Tivo networking is trash, i mean if 2 pcs can communicate on a lan. There is no reason the tivo shouldn't be able to. I have a mini ,and it says my other primere is not compatible. I wouldnt recommend the mini to anyone considering how many attempts i have taken to get it working .
     
  5. lessd

    lessd Active Member

    7,699
    5
    Jan 23, 2005
    CT
    TiVo has a copyright problem so the network on the Mini is a pain as TiVo make sure that the TiVo you are trying to connect to is in your account, we have all had this problem and after a few days it works just great, been using the Mini from when it came out and when it started working it has been very reliable.
     
  6. abeln2672

    abeln2672 Member

    33
    0
    Nov 24, 2007
    Sorry to bump an old thread, but I'm having this EXACT same problem with a Mini and Roamio Basic. I can watch Live TV and also use the "small guide" (by clicking select), but hitting the actual Guide button or trying to access the Now Playing List gives me the error message. I see that the OP solved it by power cycling everything, but I've been having this problem intermittently for a few days now and would hate to do that every time -- especially with the slow reboot time on Tivos. Anyone else seen this issue?
     
  7. tarheelblue32

    tarheelblue32 Active Member

    3,649
    5
    Jan 12, 2014
    Raleigh, NC
    I would try doing a complete reset on the Mini and see if that resolves the issue.
     
  8. lew-wolfgang

    lew-wolfgang New Member

    26
    0
    Sep 23, 2013
    San Diego
    I had this happen twice, starting about a week ago. I've got the Roamio Pro with three Mini's. The c421 error appears on all three! last night I rebooted only the Pro and the three Mini's started to work without touching them. So the problem is definitely in the Pro.

    The Mini's were able to check in to the mother ship by themselves and the network diagnostics looked okay. Netflix didn't work.
     
  9. CiXel

    CiXel New Member

    24
    0
    Aug 29, 2003
    I had the same thing and rebooting the Roamio did the trick. Fortunately nothing was recording at the time, but this could be nastty
     
  10. HazelW

    HazelW Member

    284
    0
    Dec 6, 2007
    No. Va
    I have the exact same problem as the thread starter--mini reports it can't find the Roamio, but it plays live TV and can connect to the internet.

    The mini was on MOCA in the bedroom for over a year without a problem. I decided to move it to an enclosed porch that had no coax connection. I used powerline.

    So here is the solution I found. Just disconnect the powerline adapter for a few seconds and when you plug it back in the mini reconnects to the DVR. But it will lose it again randomly. There are reports of the same thing happening with wired network.

    The actual video is fine with no dropouts or stuttering. I am guessing there is something strange in the network protocol that the mini uses.

    I'm going to try wi-fi to see if the same thing happens.

    When TiVo says it does not support wi-fi or poweline for the mini, I believe it means "there is a bug in our network protocol that we can't find or fix".
     
  11. JoeKustra

    JoeKustra Cable only

    5,825
    54
    Dec 7, 2012
    Ashland, PA...
    My experience has shown that the Mini, when used with a good router, works fine with WiFi. My Mini is using an old AN0100 adapter I had from my Premiere. The Roamio, however, must be wired or at least think it is. When using the internal WiFi my Roamio would not allow live TV on the Mini. I had to add an external adapter to make the Roamio "think" it was wired. This may not be universal, but only my experience. What's missing is any diagnostics to show the link speed or quality of the connection with the Roamio or Mini diagnostics. Such numbers would be quite valuable.
     
  12. Diacritical

    Diacritical Member

    129
    0
    Jan 10, 2003
    Brooklyn...
    Just got mine yesterday. It's connected by a media bridge (D-Link AC1650 in media bridge mode connected by 802.11ac to a D-Link AC3200) and the Roamio is connected by hardwire to a switch in the other room. The Mini needed a software update out of the box, but once that was done, it downloaded the programming info in about 20 minutes and was ready for use. So far, it works brilliantly. Tuning a new channel in live takes a little less than 2.1-2.3 seconds, watching recorded programming works perfectly, even when rewinding or fast forwarding. The video itself is free from any artifacts or pixilation... It's really the closest thing I can imagine to another full TiVo in a place I cannot get wires to.

    Stats would be nice! There should be an option to hit a key and see what the current transfer rate is, time left in the recording and video and video format (like Netflix offers on the Roku).
     
    Last edited: Apr 4, 2015
  13. JoeKustra

    JoeKustra Cable only

    5,825
    54
    Dec 7, 2012
    Ashland, PA...
    Glad things worked out for you. I found the Standby (power saver) mode to be useless with my setup since the HDMI-Mini-TV connection required the TV to be powered up twice. It's a cheap 15" TV though. The lack of diagnostic information can be expected since TiVo doesn't really like people to go wireless. I can't blame them since it's not easy to find problems. Maybe if there were better tools? Chicken & Egg problem?
     
  14. thczv

    thczv New Member

    47
    0
    Dec 20, 2001
    Sacramento, CA
    This thread is a bit old, but I thought I should post here in case my experience helps anyone else. I just bought a Tivo Mini that I tried to connect to my Roamio over a hard wired network. Both my Tivo Mini and my Roamio were connected through a Netgear GS116Ev2 switch. But I couldn't make the Mini talk to the Roamio. Like the original poster in this thread, I could use the Mini to watch live TV through the Roamio. But I couldn't watch any saved TV using the Mini. Strangely, it was an Amazon review of a different network switch that gave me the clue I needed. Once I changed the settings on my GS116Ev2 switch to disable IGMP Snooping, my Mini connected immediately and I have had no further trouble. The Amazon comment also suggested disabling multicast forwarding. But I didn't see that setting on my switch, so of course I didn't change it. I don't know what IGMP snooping is. But turning it off solved my problem. Good luck!
     
  15. unitedstan

    unitedstan TivoNewbie

    1
    0
    Feb 14, 2016
    I have been trouble shooting intermittent issues with my Tivo Roamio Pro and Tivo Mini's for months. Had the same issues that my Roamio Pro always worked, network working great for other issues, Netflix would always work perfectly on my Tivo Minis, but intermittently (and mainly not) I could not stream shows from the Roamio Pro to certain minis, or all minis, and sometimes when this would happen I could watch live TV, and sometimes I couldn't.

    I will note that Tivo Customer Service was not helpful at all. Despite the fact that I purchased a new Roamio Pro with lifetime service and 5 Tivo Minis, there 'official' stance was they would not provide support if there is a switch in the network. I escalated to supervisors and same thing. They would do a little song and dance, have me reboot everything and then again reboot everything (really...keep rebooting...I'm not a network guy but rebooting the same things again and again...??). They kept blaming my network and switch, despite the fact that I could watch Netflix in HD perfectly on everything Tivo Mini simultaneously.

    So I went on my own mission to try to find this stuff and found it here! So thank you.

    Some other frustrating notes of things I learned from the supervisor at Tivo:

    - Tivo doesn't actually 'support' Ethernet connections to mini's. Really? I pushed hard on this one since it's on the box and in the website. I also don't see where they say anywhere besides when you call them that you can't use a switch, and think about that per below: no switch and not Ethernet means that many things they advertise can't be true.

    - The supervisor kept pushing me to connect everything to the router directly to take the switch out of the mix:up:. But most routers only have four ports, so how could I connect everything without a switch (I have a Roamio and 5 mini's)? He said, well we don't really 'support' Ethernet...just MOCA. I don't have Moca. it's a new house with all CAt 6e

    - You can only connect 4 Tivo mini's to a Roamio Pro because the other two tuners have to be used by the Roamio Pro. Really? No one every told me that when I bought 5 Tivo Mini's. I'd really like to know the story here. How many can you connect AND how many can you use simultaneously when you aren't recording other things? I did note to him, btw, that even if you can only connect 4, the Router would still need a switch to work as it only has four ports out. Oh...

    Thanks again for the posts. Thought I would share the above to see if others have thoughts on this. I think Tivo might be better off just combing these blogs and helping people solve the issues than just not supporting any switches or Ethernet.
     
  16. jogo

    jogo New Member

    15
    0
    Dec 27, 2015
    I installed my own cat 6e and use a switch. The issues like you are talking about didn't show up for me until the last update. Mainly in the last week or two. Its weird.
     
  17. avonnieda

    avonnieda New Member

    4
    0
    Dec 14, 2014
    And we appreciate it! It's only been half a day since I disabled IGMP snooping on my switches, but the difference is already night and day!

    I never would have figured this out myself, and as someone who always posts the solution to a problem when I find it, I appreciate others that do the same.

    For others having this problem, if you have a switch in your network that is unmanaged, consider upgrading to a somewhat managed switch so that you can disable IGMP snooping. I have 3 switches in my network, and I disabled on all three. They're all NETGEAR ProSAFE Plus switches with web management.

    Best regards,

    -Adam vonNieda
     

Share This Page