1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SO3 Error caused by Defective N adaptor!

Discussion in 'TiVo Coffee House - TiVo Discussion' started by NiTE, Nov 15, 2012.

  1. NiTE

    NiTE New Member

    Apr 26, 2010
    There is no "maybe" or doubt. After along nightmare, It is finally over.

    I had one TCD648250B (now 3) and a series 4

    One "Classic" TCD 648250B developed Error So3 (the greatest tivo ever made!)

    I tried everything... the nightmare began. You all know the steps...

    Months went on...

    Kickstarts etc...

    Bought new drives which I cloned in case it was the drive itself.

    Only a temporary solution, it started again.

    I even bought a new 2TB pre formatted drive on ebay, same problem.

    I bought a new series 4 with lifetime , which I hate, added ethernet cable 100ft and a WD external drive to try to save my recordings at one point. Most recordings were copy protected so that was a waste. a spent over a thousand for the first series 4 with lifetime. I use it in classic menu now due to bugs.

    Nothing worked, Bought two more series 3, same model, on ebay, because I love it. Best tivo ever. OLED and THX, extra controls on unit!

    The errors started on the new units!!!
    Every tivo "in that room"

    after many years, it turns out it was the new Wireless N network adapter! every tivo it was connected to had the same problem, it seemed to obtain data, but it was corrupt!

    I switched out the new Wireless N network adapter the ailing tivos immediately downloaded fresh data and started working normally with nothing else needing to be done.

    I had spent almost 2 thousand dollars and bought three tivos, and several drives, I really didn't need.

    I have some nice new tivos and spares, and all have larger drives, but tivo didnt know what it was... they didn't really help much.

    They tried to make up for it... with discounted lifetime memberships.

    I am very upset all my problems were caused by the defective Wireless N network adapter, wish I figured it out sooner.

    Kickstarts seemed to fix the probs temporarily sometimes, but then stopped helping. That adapter was a nightmare.

    Tivo exchanged the defective new adapter for a refurb, problem finally solved.

    They didnt seem to realize this is a cause of SO3s, I have not seen my valuable info believed or repeated ever.

    Spread the word, I think many of you have a similar problem, especially if your problems started after upgrading to wireless N

    I bet there was a bad batch with bad Firmware and/or hardware.

    I know this will help many of you.

    there is no doubt here.This is real. To actually know the cause is refreshing.

    Now I have 5 tivos (4 HD) and all are 2TB huge but it was not worth losing all my recordings, season passes, all that aggravation and money.

    I'm mad but happy it is over now.

    Tivo why dont you tell people this is the cause of MANY So3?

    Symptoms persisted so long and was repeated many times. On new tivos, different units, and new drives, new images. Then the new adapter solved all the problems on all the units that had malfunctioned and been taken out of service. I thought it was maybe my internet connection etc, "something in that room". The solution was definitive and leaves NO ROOM for error.

    The N adapter was bad... But behaved perfectly when, programmed, reset to defaults, or updated, or when connected to a computer. It even functioned as a wireless Ethernet connection on other devices, but when connected to a TiVo, DISASTER after a few weeks or Months.

    It Murdered, by slow painful death, so many tivo's, images, and drives its sad.
    This was reposted here as suggested by unitron.
  2. tootal2

    tootal2 Active Member

    Oct 14, 2005
    You might be right. 1 TiVo had the s03 error 2 times and it was using wireless adaptor. and the other TiVo has been wired and has never had a problem.

    Im going 100% ceton in 15 days when I get a ceton echo
  3. NiTE

    NiTE New Member

    Apr 26, 2010
    I'm not saying all so3 errors are caused by Wireless N adapters, they happened before the wireless N was invented, but its a new cause.

Share This Page