1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Simultaneous Composite A/V and HDMI, on a Roamio PRO?

Discussion in 'TiVo Roamio DVRs' started by Pete_L_P, Nov 28, 2013.

  1. Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008
    Anyone tested composite video and audio on a Roamio PRO, while simultaneously using HDMI ?

    Mine doesn't seem to be doing that, but debugging is very difficult in my setup. I have a huge rat's nest of wires and very, very poor access. (A rack with rear access would be SO much nicer)

    Pete
     
  2. Dec 4, 2013 #2 of 30
    Devx

    Devx New Member

    274
    0
    Jun 1, 2006
    Atlanta, GA
    The Roamio Plus/Pro continue the Tivo trend of having all outputs active simultaneously.
     
  3. Dec 4, 2013 #3 of 30
    Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008
    Thanks very much for the reply. Have you tested this yourself? Or if not, can you point me to your source for this info?
     
  4. Dec 4, 2013 #4 of 30
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    I have tested it, works fine.

    The Basic model also has a composite output, which is always active, but it requires a breakout cable because it's a mini 3.5mm port.
     
  5. Dec 4, 2013 #5 of 30
    Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008
    Thanks Dan

    Which model or models did you test it on?
     
  6. Dec 4, 2013 #6 of 30
    moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
    Pete_L_P, yes it does work. I have Roamio Pro with HDMI going to TV and component going to Slingbox 350.

    The 1 catch to be aware of is *some* TVs don't keep HDCP handshake alive when in "standby" mode, and hence when TV is off the TiVo output will have an overlay indicating as such which can be cleared for a few seconds but then comes back.
    My TV falls in that category and obviously having that annoying overlay on the component output is not desired. To fix that problem I ended up getting an *active* HDMI splitter which sits between TiVo and TV. This works because as far as the TiVo is concerned the HDMI/HDCP connection is always on and so won't throw up the stupid overlay.
     
  7. Dec 4, 2013 #7 of 30
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    I tried it on a Pro and my Mini which has the same 3.5mm port as the Basic.
     
  8. Dec 4, 2013 #8 of 30
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    I don't think this applies to composite though, only component. But it's been a few years since I ran into this problem so maybe they've added the overlay to composite as well?
     
  9. Dec 4, 2013 #9 of 30
    moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
    Not sure either. But OP stated his interest is in Roamio Pro, so component would be what he cares about.
     
  10. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    He said composite. But people get those mixed up all the time, so who knows.
     
  11. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    Yeah it does. The Red/White/Yellow composite ports are right next to the Red/Blue/Green component ports. See...

    [​IMG]

    Edit: Doh! Ninja delete
     
  12. moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
    I forgot Roamio Pro has both component & composite outputs.
     
  13. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    The Basic does not have component. Only HDMI and the 3.5mm composite breakout port. (not sure why they didn't do both breakout ports like the Mini)
     
  14. Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008
    I also had the overlay on composite out on my previous Tivos related to the handshake.

    It always showed on the composite out when the tivo's hdmi was connected to a TV that was powered down. But if the Tivo's HDMI cable was connected to an HDMI switch which was switched such as to NOT connect the tivo to ANY other HDMI device then the problem would go away.

    So my solution was to keep it switched that way whenever I powered down the HDMI TV. Since the sole purpose of that HDMI switch was to supply that HDMI TV, there was no problem in keeping it switched away from Tivo when that TV was turned off.
     
  15. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    Well then it should work exactly like your last TiVo then.
     
  16. Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008
    I am only interested in COMPOSITE out simultaneously with HDMI. (Not component) Mine doesn't seem to be working. But I do appreciate the feedback everyone, and especially hearing, Dan, that you have tried it on your pro, which does eliminate a lot of variables.

    Thanks
     
  17. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    I tried mine a while ago, it's possible a recent update broke something. I'll try again later tonight and verify.
     
  18. Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008
    Very kind. Thx
     
  19. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    168
    Apr 17, 2000
    Nevada
    Yep, still works for me.
     
  20. Pete_L_P

    Pete_L_P New Member

    13
    0
    Mar 14, 2008

Share This Page