1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Series1 DirecTiVo Software Update (3.5.0) Migration Thread

Discussion in 'TiVo Upgrade Center' started by tivoupgrade, Apr 26, 2006.

  1. blips

    blips New Member

    Oct 20, 1999
    You should not have to run Tivo Flash again. I would try re-installing the drivers again. What is your network set up? Do you have the Tivo running DHCP or do you have a static IP for your Tivo?
  2. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000
    You definitely won't need to run tivoflash again. However, you WILL need to disable the initrd. Make sure you install the drivers and disable the initrd BEFORE replacing the kernel with CopyKern on the LBA48 boot CD... (if you are using a drive bigger than 137GB...)
  3. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000

    We've verified (finally) that the 3.1.0+ kernel provided on the Free LBA48 CD works fine with the recently released 3.5d version of the software for Series1 DirecTiVo units (Sony, Philips and Hughes models). Furthermore, we've updated InstantCake for these models (basic and TiVoWebPlus versions), as well.

  4. ronsch

    ronsch New Member

    Sep 7, 2001

    mfslive Unix utility or mfstools 2.0
    Silicon Dust CD if you have a cachecard or nic card
    PTVUpgrade 4.04 CD or Todd Miller's 3.5 kernel and tpip utility if you have a large drive
    Jenkins CD just in case

    1. Find a computer with IDE ( I no longer had one). Acquired a Dell GX270 from Goodwill with a 40GB NTFS drive and Windows XP Pro, keyboard, mouse, CD ROM, unformated 40GB drive, flat screen monitor all for $89.95.

    2. Formated the spare drive with a small FAT32 partition with the rest being NTFS.

    3. Backed up my current 3.5c with mfslive 1.1 beta d.

    4. Put the drive back in the TiVo.

    5. Change root to rw.

    6. Edit installSw.itcl to change the reboot to an exit on or about row 156.

    7. Change root to ro.

    8.  cd /tvbin
        installSw.itcl 3.5d-01-1-001
    Got multiple errors about $tcl_library not being defined.
    After multiple search attempts found an archived post from someone trying to modify fonts with a script
    and getting the same error as mine. Embeem had suggested making sure the script was running via tivosh.
    Even though my installSw.itcl's first line is #! /bash/tivosh I tried:

    tivosh installSw.itcl 3.5d-01-1-001
    Watch install proceed smoothly with no apparent errors.

    10. Checked TiVo for functionality and was amused to see System Information showing 3.5d already.

    11. Removed drive and reinstalled in PC as hdb.

    12. Booted up Silicon Dust cd.
           cd /kill_initrd 
           ./kill_initrd disable
           cd /nic_install
           ./nic_install cachecard
    13. Booted up PTVUpgrade 4.04 CD

     mount /dev/hdc  /cdrom
            copykern specifying hdb and 3.1+ kernel 
    This installed smoothly.

    14. Booted up Jenkins CD just in case.

    Found /var intact
    Copied rc.net from hdb4 to hdb7 (fixed IP)
    Copied rc.sysinit.author from hdb4 to hdb7. (startup tivowebplus, endpadplus, telnet, ftp)
    Copied .profile from hdb4 to hdb7.
    Copied .bash_logout from hdb4 to hdb7.
    Copied hackbackup.tar from hdb4 to hdb7.
    Copied hdb4/sbin/tar to /hdb7/sbin/tar (rc.sysinit.author checks to see if /var/hack exists; if not, it attempts a restore)

    15. return drive to TiVo & boot. Everything comes up fine. DTV scan for satellites finished up quickly and completely.
    Locals are back!
    They do need to be readded to "favorite channels".
    System Information shows full 482 hours recording capacity.
    Play several recordings. Everything works.

    16. 24 hours later

    Apply kernel patches originally posted by gohrnz in the other forum:

     mount -o remount,rw /
            cd /tvbin
            mv tivoapp tivoapp.tmp
            cp tivoapp.tmp tivoapp
            chmod 755 tivoapp
            echo -ne "\x48\x00\x00\x38" | dd conv=notrunc of=tivoapp bs=1 seek=5120680
            30 sec skip
            echo -ne "\x40\x86\x00\x40" | dd conv=notrunc of=tivoapp bs=1 seek=4641828
            echo -ne "\x38\x80\x00\x01" | dd conv=notrunc of=tivoapp bs=1 seek=4336744
    mount -o remount,ro /
    17. Pull drive and boot up PC with mfslive 1.1 beta d option 4
    Create backup:

    mkdir /mnt
    mount /dev/hda1 /mnt
    backup -6so /mnt/directivo3.5d.bak /dev/hdb 
    15. Return drive to Tivo.

    16. use bootpage to reset upgradesoftware=false (silly I know but I had to do it) :)
         bootpage -P "root=dev/hda7 upgradesoftware=false"
    End Result: I can now put off the decision about whether to get a THR22 or dump DirecTV and get a Premiere XL4.

Share This Page