1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Series 1 not downloading data

Discussion in 'TiVo Help Center' started by shototsu, Nov 11, 2008.

  1. brimimc

    brimimc New Member

    13
    0
    Aug 6, 2008
    I'm been trying to setup serial IO for my brother for months (I've got it setup for myself) and I thought I had all the kinks worked out, but ran into this same issue where the test call worked but the daily call didn't. Then when we switched back to use the modem and we ran into daily call problems as well.

    After a bunch of packet sniffing, it seems that the service is getting to the point of sending data in raw TCP chunks, but it's taking the series one tivo a long time to send the ACK that it received the individual chunks (don't know if this is normal behavior for the series one or not). The service will send the next segment while waiting for the previous ACK, then when it doesn't get the ACK quickly enough the service is retransmitting the first chunk. It does this send two chunck, times out for the first ACK, retransmit first chunk, get the original chunks ACK sequence then continues.

    I ran into problems because I had set my pppd timeout to be 30 seconds and this process got to the point where it was taking longer than 30 seconds to catch up to the data chunks.

    Unfortunately, at the same time that I tried lengthening the timeout (to 180 seconds) I had just previously been trying it with the the speed bumped down to 57600 (from 115200). With the longer timeout, I'm getting much more data (it's at Ack=38580 after 19 minutes where before it would timeout after Ack=10180 at around 5 minutes).

    Also of note, these segments are small (only 1420 bytes) each and the time between ACKs slows from 6s,12s,24s,48s,96s,120s,120s,120s... It starts at 6 seconds, then doubles until it tops out at 120 seconds between ACKs - very odd.

    I'll let this work for a while longer and send an update if the elongated timeout is a viable work-around for other serial IOers (though this is very painful to have to deal with all the retransmits that must be really slowing things down).
     
  2. dlee0708

    dlee0708 New Member

    115
    0
    Sep 20, 2002
    Lewisville, TX
    I have done a lot of network packet sniffing, but very little (actually none) with Serial PPP stuff, so it maybe just my inexperience with the Serial kind, but it does seem like those ACKS are incredibly slow. Hard to imagine anything working with ACKS that slow.

    But when I setup my mothers Tivo with an external modem some many years ago, I am pretty sure I set the BAUD rate down at 9600 (or maybe lower, can't remember). I don't remember if it didn't work at higher rates or I just got instructions to use the slower rate, but for sure it was 9600 or below.
     
  3. brimimc

    brimimc New Member

    13
    0
    Aug 6, 2008
    I'm just running wireshark against my ethernet interface (en0) filtering it on the tivo IP (chosen from my pppd command) and it shows up just like regular network traffic. It starts by sending some http requests, then ntp (setting the clock), followed by the data download.

    I missed the first few data segments before. The first ACK comes in 0.085s, the next in 3s, then 6, etc. By the time it get to 120 it's at the equivalent of 12bps. Clearly something very wrong.

    Unfortunately the 300s timeout on the ppp connection wasn't enough. At one point it fails when it take 177s to respond with a FIN, ACK. I'm not really sure what it's doing at that point, but it took almost 50 minutes to get to that point and the download operation (getting started to load dial in numbers) is only suppose to take 1-2 minutes.

    Really unfortunately, I was trying to rerun guided setup to hook up a DTV box as a satellite connection so now I'm stuck with a useless tivo until I can complete the guided setup.
     
  4. dlee0708

    dlee0708 New Member

    115
    0
    Sep 20, 2002
    Lewisville, TX
    Whats wrong with 12bps?:)

    I hear you there. After my mom's Tivo stopped being able to connect to Tivo Inc, I came here and saw all the problems people were having I made sure I was in a 3-way call with my mom and Tivo support mainly to make sure they didn't try get her to do Guided setup or otherwise her downgraded Tivo to VCR would become a boat anchor. I was actually somewhat hopeful of Tivo support because they didn't have her go thru a whole host of scripted fixes like I always get with my Verizon DSL.

    Hopefully TivoJerry has the engineering on its way fixing this problem.
     
  5. soundguy

    soundguy New Member

    14
    0
    Oct 18, 1999
    Seattle, WA USA
    my 112 with Turbonet (over FIOS) seems to be connecting all the time but I really haven't paid that much attention to it.

    My 312 is still on the internal modem (Verizon POTS line) and has been having this problem for months, actually long before most of you started seeing it on Dec 2 or thereabouts. I don't keep it connected all the time and run a phone line to it about once a week. Around December, the "Service Unavailable" problem started getting a lot worse (10% success rate) and I discovered that changing dial-in numbers seemed to help, along with always doing the forced call after midnight.

    Today was especially disconcerting because I couldn't even get a test call to go thru for several hours. Seems like Tivo's backend systems are either massively overloaded or someone installed untested or poorly-tested code.
     
  6. 1Scooby

    1Scooby New Member

    15
    0
    Jan 16, 2003
    Marshall, MI
    I too am having the same problem. My tivo has not been able to complete a call since January 15, 2009.
     
  7. jepke20

    jepke20 New Member

    2
    0
    Feb 17, 2008
    My S1 is telephone based.

    It hasn't received Guide data since January 3rd and has since run out of program data. Test dials work 40:60 with 40 being a connection. I can't get my S1 to connect to try another phone number. Right now I took the suggestion of turning off the "Phone In Use" option, it is currently "downloading" data at the moment but we'll see if it completes or not.
     
  8. spaceboytom

    spaceboytom Tivo Since 2001

    29
    0
    Jan 8, 2006
    Houston, TX
    I called Tivo today to report my Sony series 1 wasn't connecting, but it looks like it finally completed a call yesterday (the 20th). I was getting concerned because my lifetime was on the series one and my series 2 and series 3 are on MSD. In case you are unaware, if your lifetime unit does not connect at least once every 90 days, Tivo will drop your MSD rate.

    EDIT: OK this is odd. Tivo says I completed a call yesterday, but my Tivo still says connection failed. So I still can't connect. Test call consistently fails even.
     
  9. klia

    klia Member

    46
    2
    Apr 12, 2005
    My (phone-based) Philips S1 just started doing this yesterday (1/21); I'm getting a "TiVo service unavailable" error message. Restarting and changing dial-in numbers doesn't fix the problem. The last time I tried to switch to a different number, when it was dialing in for the list of numbers, it got stuck there. This is really frustrating.

    Then, suddenly, today, my Humax S2 is unable to dial in, either. What's going on? It seems like it has to be something on TiVo's end if neither of my units is able to connect and download program info!
     
  10. Alcatraz

    Alcatraz Occasionally Helpful

    177
    0
    Nov 22, 2000
    Silly question, but does your phone line work right now at all? What happens if you call the numbers listed on each of your units? Do you get through, is there a busy tone, does it just continue ringing, or does the line pick up with a handshake [modelm] tone?
     
  11. klia

    klia Member

    46
    2
    Apr 12, 2005
    The line picks up and I hear a modem tone.
     
  12. klia

    klia Member

    46
    2
    Apr 12, 2005
    Very weird -- I just forced another daily call, and now miraculously it worked and is currently loading data. I still think it's something weird on TiVo's end, because I haven't done anything in the interim.
     
  13. samro

    samro New Member

    8
    0
    Nov 16, 2008
    For the third consecutive month I find myself out of program guide data. Daily calls and forced daily calls all result once again with Service Interrupted or Call Interrupted errors, sometimes after 15 minutes of Downloading Data. Nice to know TiVo still can't figure out and fix the problem. Or perhaps they truly don't care about S1's . . . .
     
  14. TiVoJerry

    TiVoJerry 00-16 TiVo Employee

    1,511
    0
    Jul 26, 2005
    Alviso, CA
    For anyone with a turbonet card in an S1, engineering wants help getting a network fingerprint.

    Using a Linux router or sniffer, wireshark (windows,linux) or tcpdump (linux), capture whole throughput to test failed calls and send me a PM so I can give you an email address to send the files to.
     
  15. osd

    osd New Member

    2
    0
    Jan 23, 2009
    This morning I had a message on my Phillips Series 1 asking me to have the box make a call since the guide hasn't been updated for 10 days. I was surprised about that.

    I did find early in the week that my phone line was unplugged from the wall, but fixed that and proceeded assuming there was no need to check anything else. It was today's message that alerted me to a problem.

    I proceeded to do a daily call and noticed that everything went smooth, but after many minutes it got interrupted during the data download. I then went to make a test call but that got hung in the Connecting phase. I then proceeded to change the dial up number, which requires a call to Tivo to download the numbers, and that also failed in the Connecting phase.

    At this point I was not ruling out a problem with the modem itself.

    Came back a few hours later, tried again to download the list of phone numbers after changing the area code, but no luck. Made a daily call and after many minutes apparently downloading came back with Service Unavailable or something close to that.

    Then changed the area code again. Proceeded to make the call to download the list of numbers and that worked. So now I knew the modem was OK.

    Then I changed the telephone number. Made the daily call and this time it worked. The download was time consuming but ended normally.

    Could it be that something got fixed this afternoon in the Tivo servers as I was testing my box? I can't tell what got fixed, but all I know is that my Tivo box is in fine health and something outside the box was failing. Glad I didn't proceed to get a new box, as I almost did. Mine is 8 years old and still working.
     
  16. BobCamp1

    BobCamp1 Active Member

    1,347
    7
    May 15, 2002
    For most people it works (or finishes) by the fourth attempt. For some, it takes more attempts. For some, it never works. It's fairly random.
     
  17. mec1991

    mec1991 Cranky old coot

    659
    0
    Nov 5, 2004
    Back home...
    Well, my S1 won't get past the dialing stage now. I forced seventeen calls between last night and this morning before giving up. For all intents and purposes it has become a doorstop.
    :(
     
  18. Racer_C

    Racer_C New Member

    5
    0
    Nov 10, 2008
    When my Tivo (Philips Series 1) calls in, it just rings and rings and rings. When I tried dialing the number it was supposed to be calling Tivo Central answered right away. Now I am trying the Guided Setup, and still just rings, rings, and more rings.

    And by the way, my Tivo now isn't recording any suggestions either.

    Very unhappy... :(
     
  19. dbranco

    dbranco Member

    682
    1
    Nov 20, 2003
    During the "call", the S1 sits at "Connecting..." for 5 or so minutes. Ultimately, when it sits in this state for so long, it fails with "Service Unavailable".

    This morning, this happened with five successive "force calls". The sixth time I forced the call, it downloaded and completed.

    The other day, while it was stuck on "Connectiing..." and I knew it was going to fail, I picked up the phone and heard the TiVo modem trying to ping the service (heard that tell-tell modem "buzz" and bleep). Of course, that one failed with "Call Interrupted".

    I'm with you, Racer. Extremely unhappy with this situation. Have been babysitting this machine since early December. (By the way, the Suggestion problem is a known issue that TiVo seems to be working on, with Beta software. See this thread: http://www.tivocommunity.com/tivo-vb/showthread.php?t=394935 )
     
  20. ciper

    ciper New Member

    2,010
    0
    Nov 4, 2004
    Would it be helpful to get a sniff of a working S1 using an ethernet adapter?
     

Share This Page