1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rolled back to 20.3 thread

Discussion in 'TiVo Roamio DVRs' started by bunjicat, Apr 11, 2014.

  1. Apr 11, 2014 #61 of 187
    bunjicat

    bunjicat New Member

    73
    0
    Jan 14, 2012
    Nope. It was upgraded to Level 2 support.
     
  2. Apr 11, 2014 #62 of 187
    kbmb

    kbmb Active Member

    1,286
    13
    Jun 22, 2004
    NH
    Can also confirm that the rollback should NOT be happening:
    https://twitter.com/tivodesign/status/454725147748884480

    Everyone who was rolled back should email Margret!

    -Kevin
     
  3. Apr 11, 2014 #63 of 187
    alleybj

    alleybj Member

    235
    0
    Dec 6, 2000
    atlanta, ga usa
    Does she have a published email?
     
  4. Apr 11, 2014 #64 of 187
    kbmb

    kbmb Active Member

    1,286
    13
    Jun 22, 2004
    NH
  5. Apr 11, 2014 #65 of 187
    anthonymoody

    anthonymoody New Member

    199
    0
    Apr 29, 2008
    What a clusterF. I disconnected my Ethernet cable just to be sure. I show having contacted the service early this morning with no roll back thank god.
     
  6. Apr 11, 2014 #66 of 187
    MisterTWo

    MisterTWo New Member

    9
    0
    Aug 20, 2012
    Thanks for the heads up, I just used KMTTG to delete the 385 shows in my deleted folder before my Roamio rolled back.
     
  7. Apr 11, 2014 #67 of 187
    JGC650I

    JGC650I New Member

    17
    0
    Sep 1, 2013
    Both my Roamios connected to service early this afternoon per their normal schedule before I saw these posts. Both reverted back to 20.3. Was able to clear deleted before the restart, but couldn't stop the channel list reset. What a drag, that's a lot of channel list updating to redo once this is fixed.
     
  8. Apr 11, 2014 #68 of 187
    DeltaOne

    DeltaOne Mount Airy, MD

    269
    0
    Sep 29, 2013
    I'm home...still running 20.4.1. Next connection to TiVo is scheduled for 9:30 am Saturday morning.
     
  9. Apr 11, 2014 #69 of 187
    NorthAlabama

    NorthAlabama tabasco rules

    5,387
    6
    Apr 19, 2012
    sweet home, al
    please email your tsn's to "margret at tivo dot com" (see posts 60 & 62)
     
  10. Apr 11, 2014 #70 of 187
    JGC650I

    JGC650I New Member

    17
    0
    Sep 1, 2013
    Already had before I posted above.
     
  11. Apr 11, 2014 #71 of 187
    HerronScott

    HerronScott Well-Known Member

    2,777
    26
    Jan 1, 2002
    Staunton, VA
    Is it possible that the TiVo's that reverted actually just flipped back to the pre-upgrade partition? Would this explain deleted shows coming back?

    Scott
     
  12. Apr 11, 2014 #72 of 187
    NorthAlabama

    NorthAlabama tabasco rules

    5,387
    6
    Apr 19, 2012
    sweet home, al
    who knows, i don't want the rollback, and i'm starting to lose faith in tivo's ability to address the current messes.

    i'm pondering whether or not to disable my network connection and deal with the pain involved while they figure out what's going on.
     
  13. Apr 11, 2014 #73 of 187
    aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    Crap!! It looks like my Roamio Pro had a pending restart. So I'm guessing it is the rollback.
     
  14. Apr 11, 2014 #74 of 187
    aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    Yes it was the rollback. I rebooted and now My Shows list is at 99%. I just sent Margret and email.
    My Roamio Basic didn't get the rollback. I do wish it would have been the basic instead.
     
  15. Apr 11, 2014 #75 of 187
    nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    Applies to Roamios only: There no longer is an alternate partition. It's now a partition where the software downloads to, gets verified, prepared, then written to the flash. There is no going back unless the TiVo downloads the prior version again.

    KickStart 52 used to write the current software to the alternate partition, then change the boot sector to make it the active partition. This was officially called an "Emergency Software Reinstall", until the Roamio's design.

    KS52 No longer works, due to the flash always being the primary (destination) software location.

    On Roamios, and Premieres, I've always experienced the deleted items coming back, when I would choose to clear and delete the guide data and program information, so I could download it fresh and unfragmented, without any corruption. It's a great way to fix when garbage collection fails, and the TiVo can't load what the scheduled service connections provide. It also cleans out the history and "won't record" entries, cleaning up quite a bit of things that can get fragmented, corrupted, etc. The downside is it also forgets what has been recorded in the past, so repeat shows can wind up being recorded again. The deleted items going back where they were is only a downside if you have many, and forget to clear them out. I recommend KMTTG for that.

    I don't claim to know everything about what is different with the Roamio. So far, the reports of a download, followed by "pending restart", then the "rollback", supports that somehow that Roamio was able to/directed to download the prior software. Not an entire supporting of what I've said, but a good indication I'm in the ballpark, at least. It sounds like yet another problem on TiVo's side, like sending out New Zealand software to U.S. TiVo HDs. Hopefully, TiVo hasn't just created another situation where the only option is to have them replace the units affected.

    On Roamios, if TiVo fixes things on their end, I would think dropping in a blank drive, just might prompt a Roamio to download the correct software. Then again, I don't recall anybody trying a freshly-imaged drive on those TiVo HDs, to see if they would then download the U.S. version... Correct me if I am wrong on that.
     
  16. Apr 11, 2014 #76 of 187
    aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    Crap!! I have zero shows in the To Do list. I should have over one hundred shows scheduled to record.
     
  17. Apr 11, 2014 #77 of 187
    JSearfoss

    JSearfoss New Member

    27
    0
    Nov 16, 2008
    Wellsboro, PA
    I just had a reboot and roll back. My To Do List was also empty, all channel settings are gone and the hard disk is showing full. Anyone notice that there time in the guide is not correct ? Here it is currently 8:24pm and the guide is showing 12:25am. Nothing that is supposed to be recording is recording. :mad::mad:
     
  18. Apr 11, 2014 #78 of 187
    uw69

    uw69 Member

    403
    0
    Jan 25, 2001
    Washington
    What the heck is going on?
     
  19. Apr 11, 2014 #79 of 187
    NorthAlabama

    NorthAlabama tabasco rules

    5,387
    6
    Apr 19, 2012
    sweet home, al
    i suspect once you delete all the undeleted shows in "my shows" again, then re-run guided setup, and force a couple of connections, it will be back up.
     
  20. Apr 11, 2014 #80 of 187
    aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    Yes my time was off too. I had to initiate another connection. Then the clock had the correct time. Also My To Do List is now showing the scheduled shows. But for 20 or 30 minutes it was empty. I had to manually record the shows I normally watch at 8PM on Friday.


    I had no need to run the guided setup again When the To Do list that was empty. When I checked my Season Passes it showed that it was updating. but it took 20 or 30 minutes for the To Do List to populate. All my settings were still intact from before. It still had my zip code, TV provider etc. But I did have to go into the channel list and setup my received channels and my Favorite channels again. It basically had all of the channels checked after the rollback.
     

Share This Page