1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roamio's tuned to channel 0

Discussion in 'TiVo Roamio DVRs' started by kbmb, Apr 23, 2014.

  1. kbmb

    kbmb Active Member

    1,287
    13
    Jun 22, 2004
    NH
    Weird thing happened on both my Roamios today......I went to turn on the tv and it was a black screen. Pressing info showed the TiVo was tuned to channel 0. Just on that single tuner.

    Both Tivos show they haven't rebooted recently.

    Any ideas?

    No other issues I see. Both are on the latest 20.4.1.

    -Kevin
     
  2. aaronwt

    aaronwt UHD Addict

    19,186
    25
    Jan 31, 2002
    Northern...
    My Pro just rolled back to 20.3.8 again. I couldn't get any channels initially. Unlike before. I had to perform a guided setup again to get the channels to show up.
     
  3. kbmb

    kbmb Active Member

    1,287
    13
    Jun 22, 2004
    NH
    First off......holy crap. You got rolled back again?!? Better start another thread and tweet at Margaret. They owe you big time.

    Both my boxes got 20.4.1 but they weren't ever rolled back.

    All my channels seem fine......but it's just weird to have this happen on two different Tivos both today. Channel 0 doesn't even exist in my channel list...and all the other tuners were fine.

    -kevin
     
  4. ThAbtO

    ThAbtO TiVoholic by the bay

    6,733
    8
    Apr 6, 2000
    SF Bay Area
    About the only thing I can think of is the Zero button was pressed on pickup of remote then it will still change to it after a few seconds.
     
  5. kbmb

    kbmb Active Member

    1,287
    13
    Jun 22, 2004
    NH
    That might be possible on my Basic, since I use the Tivo remote for that.....however, on my Plus I have a Harmony remote, and it won't accept any key presses until the remote goes through starting up all the devices.....so it's possible, but I think unlikely.

    I'm watching it closely to see if it happens again.

    -Kevin
     
  6. Larry M

    Larry M New Member

    29
    0
    Jul 21, 2012
    Central...
    Could it possibly be on tuner 0, not channel 0?
     
  7. BadDuck

    BadDuck New Member

    24
    0
    Aug 22, 2013
    Kbmb, I have had this happen to me daily on my roamio pro since the update. I go to bed watching a normal channel and wake up and it is on channel 0 with a black screen.
     
  8. kbmb

    kbmb Active Member

    1,287
    13
    Jun 22, 2004
    NH
    Good to know! Thanks. Guess I'll tweet to Margret to let her know.

    -Kevin
     
  9. CrispyCritter

    CrispyCritter Purple Ribbon Wearer

    3,647
    1
    Feb 28, 2001
    North...
    This could just be normal, depending on what you've done.

    After a reboot, all tuners are on the same channel, and that could be channel 0 for an update.

    After a Suggestion is recorded, that tuner is returned to one of the channels that was active before the Suggestion was recorded.

    So as long as even 1 out of the 6 tuners is still on channel 0 (from the update reboot), there's a chance that other tuners will be reset to channel 0. This can be tested by going through all your tuners and changing them away from channel 0 at some time that Suggestions are NOT recording, and then see if you still are waking up to channel 0.

    (I suspect that there's some other problem, but you need to rule out the above scenario before you have established it's a bug.)
     
  10. kbmb

    kbmb Active Member

    1,287
    13
    Jun 22, 2004
    NH
    Roamio Basic was up for 4 days at that time I checked. All other tuners were active an on real channels multiples times during those 4 days.

    Roamio Plus was up for 20 days at that time. Again, all tuners were active on actual channels.

    -Kevin
     
  11. tlc

    tlc Member

    710
    0
    May 29, 2002
    Do you use kmttg? It can be configured to change channels to a non-existent channel. This trick sped up the transfer on HDs.
     
  12. mattack

    mattack Active Member

    20,743
    4
    Apr 9, 2001
    sunnyvale
    I've definitely had multiple channels change on my P4 (and I think Roamio, though mostly I stream from my Roamio through my P4 -- yeah I should probably do it the opposite way, but I'm recording most on the Roamio, and trying to prevent the !@$# cable tests that happen at least once a week from ruining my recordings)...

    I turned suggestions back on recently (no particularly good reason why, I never watch suggestions), but they've sometimes had multiple tuners set to CSPAN, when I had only set one on that channel earlier, or multiple on CNNHD..
     
  13. tatergator1

    tatergator1 Active Member

    1,523
    6
    Mar 27, 2008
    Columbus, Ohio
    Yes, I've been casually tracking this same behavior on my Roamio Plus, and have been meaning to create a new thread on the topic of what I would call "Tuner Drift." For me, I most commonly see multiple tuners on the same channel after first turning the TV on in the morning. This morning, 4 tuners were on the same channel. A few weeks ago, I took the time to go into DVR Diagnostics on two separate days and look at the info for all the tuners. The weird part is that I found one instance of the channel that had been there for 10+hours and could be easily linked back to a prime time recording on that channel. However, the other 2-3 tuners that were also on that channel had resolution times that appeared completely random. For example, one tuner changed to the same channel at 03:45:00. Another might have been 04:22:37.

    I've seen the multiple tuner channel be a linear channel as well as and SDV channel. It seems completely random as to which channel multiple tuners will "drift" to, but it happens basically every morning.
     
  14. aaronwt

    aaronwt UHD Addict

    19,186
    25
    Jan 31, 2002
    Northern...
    Does it even matter what channel it's on as long as it's recording everything properly? I haven't noticed the issue on my Roamio pro, but that is using five or six tuners on a daily basis. My Roamio Basic on OTA doesn't record much, but I haven't noticed it with that either. But even if it did, as long as my recordings happen when they are supposed to, I don't care what channel the Roamio is tuned to when it isn't recording.
     
  15. kbmb

    kbmb Active Member

    1,287
    13
    Jun 22, 2004
    NH
    It's more of a question as to why it's happening. No, it doesn't impact anything, other than the first time I turned the TV on and saw a black screen I had a moment of "oh crap....did the Tivo die". And when my other Tivo did the same thing it got me wondering if it's a software bug causing it.

    Call me curious....that's all.....that's why I posted it here on a user forum instead of calling Tivo support.

    -Kevin
     
  16. tatergator1

    tatergator1 Active Member

    1,523
    6
    Mar 27, 2008
    Columbus, Ohio
    No, not really. However, it is an odd behavior that I have a hard time believing is deliberate. As part of this behavior for me, whether directly connected or not, is that fact that on maybe 75% of these instances, the Roamio shows that my Mini has also taken a tuner for no reason (the mini has not been used for at least 10 hours as well), as well as one of the channels showing the "Press Select to retune" message you get when an SDV channel times out. Yet, it's not uncommon for this message to display on the channel that is also on 2-3 other tuners, where all the other instances of that channel are available with their 30-minute buffers.

    Certainly strange behavior, and very likely Tivo software issues. But as you point out, everything records just fine for me, which is why I'm only casually monitoring the issue.
     

Share This Page