1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roamio Plus and Xfinity Router Can't find DHCP Server

Discussion in 'TiVo Roamio DVRs' started by Pete327, Mar 29, 2014.

  1. Pete327

    Pete327 New Member

    9
    0
    Aug 13, 2007
    Washington, MI
    Hi everyone, I hope someone can help.

    I just got my new TiVo Roamio Plus and I can't get it to connect to my home network via wireless. It gives me a N02 error and says it can't find the DHCP server. Here's the setup:
    1. Tivo Roamio Plus
    2. Comcast Xfinity ARRIS TG862 router/cable modem
    3. These are currently located 2 feet apart so I'm sure signal strength isn't an issue (it reads 85-100%)
    4. I have the WPA/WPA2 security on the network, but I have also tried turning security off with no success either.
    5. I have turned off the firewall completely.
    6. I selected get IP address automatically and that I don't need a DHCP client ID. I've tried manually entering an IP address as well, no luck.
    7. I completed Guided Setup using a wired Ethernet connection, which worked fine. Roamio connected to the internet and downloaded updates.
    8. After guided setup completed I went back to the network settings to try again on the Wireless.

    This is not my permanent location so I'd like to get Wifi to work. I know MoCA is an option but right now I'd like to figure out what's wrong.

    Other points of note: My Series 3 and Series 2 connect just find over WiFi to this same router. I have rebooted the router and Roamio multiple times.

    What else can I try?

    Thanks.

    Pete
     
  2. tomhorsley

    tomhorsley Active Member

    1,172
    4
    Jul 22, 2010
    Did you ever enable mac address filtering on the router and then forget about it? Maybe the router is rejecting the mac?
     
  3. tatergator1

    tatergator1 Active Member

    1,523
    6
    Mar 27, 2008
    Columbus, Ohio
    The internal WiFi on the Roamio is notoriously flaky. Based on the number of complaints people have posted, I'm pretty sure there is an inherent hardware/software flaw. If I'm reading your post correctly and the Roamio is 2 feet away from the router , just get an Ethernet cable and forget wireless.
     
  4. Pete327

    Pete327 New Member

    9
    0
    Aug 13, 2007
    Washington, MI
    Tom, thanks for the suggestion. I did check this and nothing is filtered.

    Tater, unfortunately this isn't my permanent location. I could run a really long Ethernet cable through my basement, but I'm not sure I want to go through the effort.

    TiVo must know this is an issue but both service reps I spoke to seemed genuinely lost as to this issue. However, the second one suggested MoCA and is sending me an adapter, so I think he just gave up on trying to fix the wireless. Plus I don't think he any desire to get involved with Comcast. So that may just be the end of the story.
     
  5. CTMCCURDY

    CTMCCURDY New Member

    11
    0
    Aug 30, 2010
    @Pete327

    I just installed my Roamio Pro with similar issues. Tivo tech sent me a long list of ports that need to be open in order for it to phone home. I temporarily added the Roamio to the DMZ with a static IP. That worked great. Now I can't get my Mini to connect. I really don't want to call Comcast.

    Any luck getting yours to work with the TG1682g gateway?

    Thanks
     
  6. PSU_Sudzi

    PSU_Sudzi Member

    532
    3
    Jun 4, 2015
    Philly suburbs
  7. CTMCCURDY

    CTMCCURDY New Member

    11
    0
    Aug 30, 2010
    @PSU_Sudzi

    Thanks for the idea but I went ahead and installed the Moca adapter and it works great.

    Thanks
     

Share This Page