1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roamio Plus and Wireless issues

Discussion in 'TiVo Roamio DVRs' started by Time_Lord, Nov 4, 2013.

  1. Nov 4, 2013 #1 of 11
    Time_Lord

    Time_Lord Member

    213
    0
    Jun 4, 2012
    This is partially a vent message but need some info as well...

    I ran into an issue the other night and figured I'd call TiVO's tech support, but to say they were less than helpful is an understatement, I was told in no simple terms "We don't support network switches" and I'd have to reconfigure my network for them to assist me, they refused to go any further.

    I gave up with their support and found the issue on my own and it turns out to be a bug with the TiVO unit and how it selects WiFi or Wired ethernet (didn't try MoCA). This all stems from when I initially setup the Roamio, I initially connected it
    via WiFi (802.11G), the Roamio successfully found the SSID and I entered my WPA2 key. At that point I let the TiVO go about its merry way with all its updates and connections back to the mothership, all without incident.

    After the initial configuration and downloads were complete I moved the unit to its final location and simply connected the ethernet, I was surprised to see that the unit automatically identified that ethernet was connected and the setup screens shows that the connection type was indeed ethernet and the wireless was no longer being used and showed no configuration for the wireless. Great somebody in development was thinking, if ethernet was in use shutdown wireless.

    Well turns out wireless isn't actually shutdown as I found the TiVO's 2 MAC addresses (one for the TiVO and one for the built in Stream) were bouncing between two ethernet ports on my switch in rapid succession, the port the TiVO was physically connected to and the port the wireless A/P was connected to. What did surprise me is that TiVO uses the same MAC addresses on ethernet as they do on WiFi which didn't help the situation.

    At this point I believe I've stopped the TiVO from using wireless, I ended up disconnecting the ethernet and pointing the TiVO to an invalid SSID/password combination, disabled WiFi and reconnected the Ethernet. Now the performance of the TiVO stream portion appears to roughly match what TiVO claims will be the transfer times (still slow but moving a steady 3 to 4 Mb/s).

    So since TiVO's customer support was less than helpful, I'm guessing they have no interest in logging a bug either since I'm an "unsupported configuration" (my router is separate from my switch) even though I have confirmed the network behavior of the TiVO is just plain wrong.


    My final question is how do I positively confirm the WiFi is shutdown so that it doesn't attempt to connect to the bogus A/P I pointed it to?

    Thanks,
    -TL
     
  2. Nov 4, 2013 #2 of 11
    moyekj

    moyekj Well-Known Member

    11,149
    33
    Jan 23, 2006
    Mission...
    Login to your router and check to see what wireless clients are currently connected. That's how I discovered my Roamio Pro was still trying to use wireless after connecting ethernet and had to take steps to effectively disable wireless using the bogus password method. I just think it's ridiculous there is no "off" setting for wireless somewhere in the menus. If nothing else having it on perpetually for those that have no intent to use it is just wasting power. (I wouldn't be surprised if there is already some backdoor method to turn it on/off via current software, but if there is I don't know about it).
    Quite frankly I'm surprised the Roamio line enabled wireless at all. It's just a huge can of worms TiVo opened up to support, and for years TiVo was very anti-wireless related to MRS/MRV.
     
  3. Nov 4, 2013 #3 of 11
    Time_Lord

    Time_Lord Member

    213
    0
    Jun 4, 2012
    right now I know it isn't associated to either of my A/Ps, but that still doesn't confirm the wireless is shutdown on the TiVO since I do not want to use it at all.
     
  4. Nov 4, 2013 #4 of 11
    moyekj

    moyekj Well-Known Member

    11,149
    33
    Jan 23, 2006
    Mission...
    I'm pretty convinced that wireless is NOT completely shut down, but don't have the equipment to confirm for sure.
     
  5. Nov 4, 2013 #5 of 11
    Time_Lord

    Time_Lord Member

    213
    0
    Jun 4, 2012
    You just caused the lightbulb to go on, I just remembered I do have the equipment to see what WiFi devices are beaconing.


    I've got one of these: http://www.riverbed.com/products-so...products/Wireless-Traffic-Packet-Capture.html

    Tonight I'll see if I can figure out if the TiVO is still searching on WiFi

    -TL
     
  6. Zu Nim

    Zu Nim Registerer Used

    31
    0
    Apr 20, 2012
    I can't for the life of me figure out how to turn WiFi off on a Roamio. I didn't have any luck giving it a bad SSID/key combination because it would kick me out each time saying it couldn't find a proper network. I ended up creating a different SSID on a different router and using that, then deleting that SSID from said router afterwards. I'm sure the Roamio is still plugging away, trying to connect to it. Viewing the network status page will indicate that the wireless is shut off, but it's not.

    This is a remarkably poor design. All I was looking to do was test it or perhaps create a fallback if the wired network got disconnected. Simple in theory, simple in practice, but not for Roamio apparently.
     
  7. yukit

    yukit Member

    206
    0
    Jul 23, 2005
    I am starting to have wireless problems with my Plus after initially working pretty well to transfer from a TivoHD for the 1TB or so.

    Now I am frequently seeing C133 error even if I am not using wireless to transfer programs from other Tivos.

    What I found is that even the hard reset (unplugging the power) does not fix the wireless connection to my router, but switching to another SSID (I have 3 in my house) sometimes makes connect to Tivo work.

    It is a bit of mystery & source of frustration until I can retire my TivoHD with a wired ethernet connection. I may look into Moca to bridge to my home network since that would be the way I want my Mini to work when I get a TV in the bedroom.

    I just got 3.8 update, but taht didn't fix the wireless issue.
     
  8. DeltaOne

    DeltaOne Mount Airy, MD

    269
    0
    Sep 29, 2013
    Get an Ethernet switch and use wired connections for both (assuming both devices are in the same room).
     
  9. Latitude94941

    Latitude94941 New Member

    12
    0
    Dec 15, 2013
    Hi, Time_Lord,

    I'm wondering what the results of this were. I just bought a Tivo Roamio and it sits next to some very sensitive audio equipment, so important that wifi antenna in the Roamio be off. I never activated wifi on this Tivo--I set it up with Ethernet from the start.
     
  10. Time_Lord

    Time_Lord Member

    213
    0
    Jun 4, 2012
    I would suggest you place your audio equipment in a Faraday cage if it is really as sensitive as you make it out to be, as there is probably more RF running around the equipment than you probably realize.

    When I looked for the Roamio's WiFi signal I didn't see it then again it might simply be the limitation of the equipment I was using as my understanding is you cannot positively shutdown the WiFi on the unit.

    Btw you do realize that all the compact fluorescent lights in your house put out a lot of RF noise? so does the cell phone you carry, oh and even though you are using ethernet, there is RF leakage from that too, remember its UTP or Unshielded Twisted Pair, and yes the twist is supposed to act like a shield, but its very far from perfect. You can use shielded twisted pair but most equipment won't ground the shield so it won't do you much good.
     
  11. Latitude94941

    Latitude94941 New Member

    12
    0
    Dec 15, 2013
    Thanks for the info, Time_Lord. Was interested in what you'd found with your test, since I've only gotten conflicting information about whether the Roamio's wifi is active if it was never set up in the first place.

    Regarding, RF noise from fluorescent lighting, I shut them off (which is what I'd like to do with the Roamio's wifi).
     

Share This Page