1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivoX

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Yoav, Dec 10, 2008.

  1. epstewart

    epstewart Member

    648
    0
    Mar 1, 2003
    Rdian06,

    I was using 960x540, which is apparently considered one of the standard resolutions for Apple TV ... but (sadly) Apple TV won't play the .srt subtitles files.

    I used the pyTivo part of pyTivoX to pull the files to my S3, and they played fine!

    It's just the Streambaby method that causes the problem ...

    I tried the various ImTOO HD Video Converter 6 "Zoom" options and found they all produce odd Streambaby behavior when I use ImTOO's H.264 codec at 960x540 and 30fps (which I use so that the subtitles stay in sync). I suspect PAR/DAR has something to do with it, but none of these files (as far as I can tell by inspecting them in QuickTime Player) uses anything but 1:1 PAR. My previous comments about non-1:1 PAR seem to have been off the mark. I could investigate this further, but given that the problem is limited to streaming (rather than pulling) the files to the S3 and doesn't affect my other, newer TiVo units, I'm not sure what could really be gained by doing so.

    Thanks for your insights ...
     
  2. generaltso

    generaltso Member

    964
    0
    Nov 3, 2003
    Vermont
    I'm having this same problem. The OP seems to have fixed it by upgrading to the 1.4 beta, but that didn't fix it for me. I'm running 1.4.1 on OSX 10.6.6. If I transfer a 720p file to my S3 box, it plays at the correct resolution. But when I transfer that same file to my Premiere, it plays at 480p. Any ideas?

    Thanks!
     
  3. generaltso

    generaltso Member

    964
    0
    Nov 3, 2003
    Vermont
    I tried transferring a 720p video to the S3 first, and then transfer it from the S3 to the Premiere instead of going directly from the Mac to the Premiere. It didn't seem to make a difference. It plays at 720p on the S3 and 480p on the Premiere. This is driving me nuts.
     
  4. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
  5. mabrandt

    mabrandt New Member

    1
    0
    Aug 31, 2009
    Sorry. I've deleted it here, but kept it on the pyTivo forum.

    P.S. Because I have fewer than 5 posts, I'm not allowed to include your URL. Interested readers are referred to your original.
     
  6. Mar 7, 2011 #1086 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Hi All. Just installed pyTiVoX and I can't see the files on my TV.

    I opened Music, Photos, Showcase and scroll down to a folder called pyTivoX - Macintosh.local I then press Select and wait for 5/6 minutes and then get a error message saying. HTTP failure. (HTTP connection error: 0x50005).

    I am clicking the green tick..

    There are no files in the Now Play List.

    Under Preferences both Streamboy and pyTivo are enabled.

    I have a good connection with my modem and media box

    Mac 10.6.6
    Wireless to TiVo
     

    Attached Files:

  7. Mar 7, 2011 #1087 of 1437
    Phantom Gremlin

    Phantom Gremlin New Member

    1,555
    0
    Jun 20, 2002
    Tualatin,...
    Here's a shot in the dark. Get rid of special characters in directory names. Why does the user name have an apostrophe in it?
     
  8. Mar 8, 2011 #1088 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Hi and thanks for your impute unfortunately it has changed anything still unable to see the movies, etc

    Thanks ...
     

    Attached Files:

  9. Mar 8, 2011 #1089 of 1437
    richsadams

    richsadams Active Member

    8,893
    2
    Jan 4, 2003
    Okay...another shot in the dark...like the directions say, are you clicking "Apply" (the big green checkmark button) each time you add or update anything? I've found you can actually do all sorts of stuff, but until you click the "Apply" button, nothing takes. You probably are, but it was just a thought.
     
  10. Mar 8, 2011 #1090 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Hi and thanks for your impute.
    Again still doesn't work.

    The message that i'm getting on the screen is:

    CARN'T RUN
    An error occurred while running the application.
    HTTP failure.
    (HTTP connection error: 0x50005)

    - TiVo takes about 8 minuets to give me the above error message.
    - To run it again to see if it has fixed I have to go back to the mac computer and click the green tick again otherwise the link vanishes in the list, Music, Photos, Showcase.

    Cheers
     
  11. Mar 8, 2011 #1091 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Hello again
    I have just notice something that may be causing the problem and was wondering if anyone else can help.
    When I open pyTiVoX and click the blue + button to add the folder containing the movies to view on my TV my PyTivoX screen excepts the folder but when i view the same folder the movies inside the folder aren't highlighted dose that mean that Tivo can't see the movies inside that folder.

    Cheers
     

    Attached Files:

  12. Mar 8, 2011 #1092 of 1437
    Wil

    Wil Senile Member

    4,114
    31
    Sep 26, 2002
    Is "My Share" in the normal Now Playing List? Create a more descriptive name for your video folder than the default "My Share" Does it show up in the Now Playing List?
     
  13. Mar 8, 2011 #1093 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    No it doesn't. Never had anything in Now Play List.

    In Music, Photo's and Showcase I get.

    - pyTivoX - colin-scarfe-computer.local

    Cheers
     
  14. Mar 9, 2011 #1094 of 1437
    Phantom Gremlin

    Phantom Gremlin New Member

    1,555
    0
    Jun 20, 2002
    Tualatin,...
    Okay, since you're still having problems, let me be even more explicit about what I consider to be a "special character".

    Use any of the following 62 characters, and only those characters, in your directory names

    A-Z
    a-z
    0-9

    Notice, in particular, that a "space" or " " character is not on my list, whereas it is in your directory names.

    Yes I know this is very pedantic. But sometimes computers (or, to be more precise, sloppily written computer programs) are very pedantic about such things. IIRC I had a lot of problems with KMTTG until I simplified my directory structure. I wound up creating "links" to work around names with special characters, but I hesitate to mention that because it only opens up the question of what is a link.

    Edit: use the same rules for "Share Name". Get it working without a space in the share name, then experiment to your heart's content in terms of making it more pleasant in appearance.
     
  15. Mar 9, 2011 #1095 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Thanks for you reply

    I have change the name and it still isn't working

    I have upload two screen shots. you can see that from pyTivoX screen that the file rick.avi isn't highlighted.

    Cheers
     

    Attached Files:

  16. Mar 9, 2011 #1096 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Also I can only see my mac from Music,photos & Showcase screen. the file in question comes up as - pyTivoX-Colin-scarfes-Computer.Local
     
  17. Mar 9, 2011 #1097 of 1437
    ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    No It Doesn't only in Music,Photo,Showcase
     
  18. Mar 9, 2011 #1098 of 1437
    Phantom Gremlin

    Phantom Gremlin New Member

    1,555
    0
    Jun 20, 2002
    Tualatin,...
    Okay, maybe you're having some sort of installation or network problems.

    Please tell me the exact URL from where you obtained your version of pyTiVoX. I haven't grabbed a copy in a year or two, but I will get your version, install in a 10.6.6 system, and see what results I get.

    BTW a year or so ago I had a flurry of activity where I did all this sort of thing, i.e. download from Tivo, upload back to TiVo, etc.

    But then little things would go wrong, and it just became too tedious to keep doing it. E.g. my cable provider decided to disallow downloading of all but the network channels, or KMTTG would only download on about every other attempt.

    I can use this as an excuse to reacquaint myself with this software.
     
  19. ba2991

    ba2991 New Member

    50
    0
    Feb 28, 2011
    Hi again I sent it but was sure if it went or not here it is again

    http://code.google.com/p/pytivox/downloads/detail?name=pyTivoX-1.3.dmg
     
  20. Phantom Gremlin

    Phantom Gremlin New Member

    1,555
    0
    Jun 20, 2002
    Tualatin,...
    Hmm. That software is from 2009, it's what I grabbed a while ago. So it doesn't seem to be very actively developed. Still, if it works, .... why not?!

    I will try both the 1.3 version and the beta from September of last year. I'll let you know if and how well they work in a 10.6.6. system.
     

Share This Page