1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivoX

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Yoav, Dec 10, 2008.

  1. Nov 10, 2009 #821 of 1437
    dnorth12

    dnorth12 Member

    264
    1
    Feb 10, 2005
    Kent, WA
    Check your firewall setting. It may have been changed due to the update. Although Rich reports no problems, so may not be it. Just guessing here.
     
  2. Nov 10, 2009 #822 of 1437
    dnorth12

    dnorth12 Member

    264
    1
    Feb 10, 2005
    Kent, WA
    I am in the process of transferring back my recordings using PyTiVoX and the placeholder issue is a non issue.

    The only thing that I am noticing is that some recordings have lost their channel information. Weird, some have it, some don't. Not that big a deal though.
     
  3. Nov 11, 2009 #823 of 1437
    j_wiech

    j_wiech New Member

    1
    0
    Aug 31, 2009
    Has there been any progress on forcing Pytivox ver. 1.3 to force alpha on the files when I view them on my TiVo HD? I am still running Ver. 1.01 on Leopard as the new version 1.3 does not force them into alphabetical order. This feature is the only thing keeping me from upgrading my mac to snow leopard. I have seen posts about inserting the command "force alpha=true" but I have no idea how to do this and what file to do it to. Any suggestions would be greatly appreciated.
     
  4. Nov 13, 2009 #824 of 1437
    naivemelodyth

    naivemelodyth New Member

    1
    0
    Nov 13, 2009
    pytivox isn't working for me and that happened this morning. It was working beautifully last night, then pop. Firewall is not on. I cannot see my folder under "Now Playing."
     
  5. Nov 14, 2009 #825 of 1437
    dig_duggler

    dig_duggler losing enthusiasm

    835
    0
    Sep 18, 2002
    Birmingham, AL
    I have 10.6.2 and everything (pyTivoX, streambaby) are still a okay....
     
  6. Nov 17, 2009 #826 of 1437
    CurtisByers

    CurtisByers New Member

    9
    0
    Aug 11, 2004
    Springfield, MO
    Hey guys. I installed pyTivoX 1.3 on my mac running 10.5.8. I can set up shares and see them on my Tivo HD, but there are never any videos listed in the shares, no matter how many video files I copy into the shared directories. Does anyone know what could be causing this?
     
  7. Nov 21, 2009 #827 of 1437
    tjoldani

    tjoldani New Member

    2
    0
    Nov 21, 2009
    Just thought I would put my name in the "broken images" bucket. I love this program. Any ideas on we would see a new release or beta build?
     
  8. Nov 21, 2009 #828 of 1437
    wmcbrine

    wmcbrine Ziphead

    10,367
    22
    Aug 2, 2003
    Yoav hasn't posted since October 4th, and hasn't logged in since October 15th.
     
  9. Nov 27, 2009 #829 of 1437
    ppartekim

    ppartekim New Member

    70
    0
    Jan 17, 2007
    Middle of...
    Can pytivoX stream videos via links? I tried searching various threads using "link" "alias" and "shortcut" but, did not see this mentioned.

    I tried using a link to stream to by Tivo S3 and while the Tivo saw the file and let me select it. The Tivo displayed a black screen for a minute of two and then came back with a error message.

    I would like to get this to work, as it would save space in organizing my videos. I could for example have the "Nightmare Before Christmas" available via three different directories (Christmas, Halloween, and Musicals) but only have one real copy of the file. I have several films like this and can't afford the disk space to keep separate copies of the files in different directories.
     
  10. Nov 27, 2009 #830 of 1437
    Rdian06

    Rdian06 New Member

    463
    0
    Apr 12, 2008
    Are you creating the "link" with an Alias in Finder or via the ln Terminal command?

    I haven't tried it, but I have a hunch that a a symbolic link created via ln -s from Terminal would likely work.
     
  11. Nov 27, 2009 #831 of 1437
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,133
    302
    Oct 29, 2000
  12. Nov 27, 2009 #832 of 1437
    ppartekim

    ppartekim New Member

    70
    0
    Jan 17, 2007
    Middle of...
    That worked like a champ.. I had tried an "make alias" on my first attempt and it failed. After I made the post I hit the terminal and noticed that the alias did indeed look like another file (not a link). I had created a link with "ln -s" and was waiting for the current movie to end before trying it.

    Also thanks Fofer, I am downloading SymbolicLinker now to give it a whirl.
     
  13. Nov 28, 2009 #833 of 1437
    js29tiv

    js29tiv New Member

    9
    0
    Mar 21, 2009
    The question was posed if anyone else was seeing this same issue. I wanted to confirm that I see the exact same difference between pyTivoX 1.2 and 1.3. (FYI, I'm on OS X 10.5.8, and my Tivo is a Series 2.) I also use iTivo to download with decrypt option only (therefore only .mpg + .txt files, so no .TiVo files, although I'd be happy to download .TiVo files if iTivo provided an option for that), then upload using pyTivoX. With pyTivoX 1.2, it works great (the recorded date/time on the Tivo matches the file modification date/time on my Mac - I used Marconi's Droplet!), whereas pyTivoX 1.3 ends up with the recorded date/time on the Tivo being the date/time that I did the upload from my Mac to the Tivo. FYI, I'm only using the pull method (ie. going onto the Tivo and telling it to transfer files from the Mac.)

    So clearly something changed - has anyone figured out yet whether it is due to something in pyTivoX or in the underlying pytivo revision (or something else)?

    Question for wmcbrine: you mentioned that you thought it was always the transfer date that carries over from the PC/Mac to the Tivo. Yet somehow both Marconi and I see the Mac file modification date carrying over as the "recorded" date on the Tivo (when pyTivoX 1.2 is used). So there must be some way to define the "recorded date/time" on the Tivo for uploaded files to be different than the literal date/time of when I clicked "transfer/pull". In other words, there must be some way to "close the loop" from initial download of a file from the Tivo to re-upload back onto the Tivo to retain the recorded date/time.

    So my question is: do you know of a way (in pytivo) to specify a "recorded" date/time for pulled files? Is there a field we can specify in the .txt file, or can you think of why pyTivoX 1.2 seems to result in the Mac-side file modification date to become the recorded date on the Tivo? If not, are there any log files or other things that Marconi or I could provide for the pyTivoX 1.2 and 1.3 cases to try to debug why 1.2 seems to work better for controlling the recorded date/time?
     
  14. Nov 28, 2009 #834 of 1437
    Rdian06

    Rdian06 New Member

    463
    0
    Apr 12, 2008
    For the record, pyTivoX 1.2 wasn't using the file's modification date and time, it was using the time, startTime, and stopTime metadata value that iTivo adds to the metadata files it generates from the .tivo file. Marconi later realized that he was mistaken and modification date and time being sent to the Tivo was something Tivo Desktop did.

    pyTivoX 1.3 is based on code that tried to fix some duration calculation problems and accidentally ended up ignoring the time, startTime, and stopTime metadata values.

    See http://pytivo.sourceforge.net/forum/post7816.html#7816

    wmcbrine later fixed the issue and added some support for using the file modification time using the file keyword in the time metadata value, but pyTivoX hasn't been updated recently enough to have that new code.

    See http://pytivo.sourceforge.net/forum/time-in-metadata-t1091.html
     
  15. Nov 28, 2009 #835 of 1437
    Wil

    Wil Senile Member

    4,115
    32
    Sep 26, 2002
    Looks at this point there are two ways to go, ongoing:

    1. Look for ways to overlay more recent versions of pyTivo and Streambaby into an existing installation of the very nice pytivoX (latest/maybe last version) interface.

    2. Abandon pytivox and go back to individual installations of current pyTivo and Streambaby.

    Opinions?
     
  16. Nov 28, 2009 #836 of 1437
    Marconi

    Marconi TiVo Junkie

    444
    0
    Sep 8, 2001
    Page, AZ USA
    And with the metadata dates ignored, what dates show in PyTiVo's listing to the TiVo? What dates show in the NPL once recordings are transferred to TiVo?
     
  17. Nov 28, 2009 #837 of 1437
    Rdian06

    Rdian06 New Member

    463
    0
    Apr 12, 2008
    In the absence of metadata time fields (or in this case where the code ignored the fields), pyTivo defaults to using the transfer time to be the record time for a pull. For Push, transfer time is always used because it appears the Tivo's Push mechanism will not accept time data even when we set it in the protocol - there may yet be a way to control it, but no one has found the right field from reverse engineering what Tivo Desktop Plus does.
     
  18. Nov 28, 2009 #838 of 1437
    js29tiv

    js29tiv New Member

    9
    0
    Mar 21, 2009
    Ah, thanks. Those threads clear things up a lot for me - don't know how I missed them during my searches yesterday. I'm looking forward to when pyTivoX is updated to the latest wmcbrine pytivox code! The addition of the File and OAD fields seems like they will enable a "round trip download then upload with show sorting order maintained" solution nicely.
     
  19. Dec 1, 2009 #839 of 1437
    wgoosey

    wgoosey New Member

    20
    0
    Dec 1, 2009
    Hello,

    I'm new here and haven't had the time to wade through the old posts so I apologize if this has been answered.

    I have an old series 2 TIVO laying around that was replaced by a newer series 3. Can this deactivated series 2 be used as a player for media on my server using pyTivoX? It would be a nice use for an old paperweight....

    Thanks
     
  20. Dec 1, 2009 #840 of 1437
    tjoldani

    tjoldani New Member

    2
    0
    Nov 21, 2009
    I am of the inpatient type and went with option 2 over the weekend. I now have wmcbrine's pytivo and Streambaby running individually on my Ubuntu machine. Video/Photos/Music all in working order.

    I'm surprised no one has put the two together into an interface actually.
     

Share This Page