1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. wgw

    wgw New Member

    217
    0
    May 16, 2007
    Yes, Converting to .ts is a way to force pyTivo to transcode any recording, regardless of the bit rate. That was written before I modified pyTivo to transcode any file with a bit rate above max_video_br or max_audio_br. You're correct, pyTivo will now take care of this without the need to convert to .ts.
     
  2. jcthorne

    jcthorne Active Member

    2,726
    3
    Jan 28, 2002
    Houston
    When pytivo is using ffmpeg to re-encode .mkv files for my HD tivo box, occaisionally a file will cause ffmpeg to lock up. When it does so, it trips the entire computer and reboots Windows XP. Took me a while to find the problem and its not pytivo as I can duplicate the problem with ffmpeg as a command line program. Not all files, just some, but it is very repeatable and happens at the same point in the file each time.

    I just loaded the new Feb 5 windows executeable from build 11870 and it seems to do the same.

    Has anyone else seen this behaviour? Is there some other tool or workaround for these files? Seems a problem with ffmpeg as it should error and quit, not lock up the OS
     
  3. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    That is extremely abnormal.

    Can you point me to one of the bad files?
     
  4. greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    May want to verify your memory is not faulty. Glitchy ram will do weird things at odd times.

    http://www.memtest86.com/
     
  5. fred2

    fred2 New Member

    509
    0
    Jan 20, 2006
    I was using a folder-problematic version for quite a while.

    I installed a newer version about two weeks ago. It appeared to work. But it was NOT installed as a service so I ran the service cmd line. It installed but

    I get:

    "The pyTivo service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service."

    WinXP SP2.

    I then replaced this newer version with my older (non-folders) by copying everything back into the pyTivo folder and it worked.

    Just tried reversing that process - copying everything from the new install back again and again get that quoted text above.

    So pytivo is NOT present when I go down to my tivo.

    Any help appreciated.
     
  6. jcthorne

    jcthorne Active Member

    2,726
    3
    Jan 28, 2002
    Houston
    You were right. My overclocked but stable machine was not as stable as I thought it was. Brought it down from 3.4Ghz to 3.0 and the problems went away... Gee:cool:
     
  7. greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    :up:
     
  8. ITGuy72

    ITGuy72 New Member

    65
    0
    Aug 10, 2005
    Meta generator just stopped returning any results about a week ago. Anyone else having trouble with this?
     
  9. PaulS

    PaulS Member

    674
    1
    Sep 16, 2002
    Southern NH
    MetaGenerator issues queries to a couple of websites to retrieve data concerning TV shows and movies. Both of them went off-line last month, for unrelated reasons. The TV show site should be back up, and word has it that the movie site will be back up shortly. MasterCephus is on top of it, so don't worry.
     
  10. MasterCephus

    MasterCephus New Member

    309
    0
    Jan 2, 2005
    Hueytown,...
    Yeah, trying to be :)

    As far as I know, tvdb data (TV shows) should be working. They are changing their interfaces starting March 1st (I think). When they do that, MG will stop working.

    I am in the testing phase of implementing the new interfaces for tvdb. It works for the most part...some minor bugs. I hope to release a new version (1.4.0.0) by the end of the day which should keep the TV shows working.

    The movies are a different story. As far as I know, zag2me has moved the data to a new host, and the site is working. However, he is having some issues with data retrieval. As soon as he gets those issues worked out, MG movie part should just start working for all versions.

    Sorry about all of this, but I think we'll be back on track shortly.
     
  11. MasterCephus

    MasterCephus New Member

    309
    0
    Jan 2, 2005
    Hueytown,...
    New version of the metagenerator!

    1.4.0.0
    fixed bug(s)
    -fixed searching for tv show and movie at the same time

    enhancement(s)
    -transitioned to new tvdb.com interfaces
    -SeriesID obtained from tvdb.com data and not from local db

    see my signature to download
     
  12. mrbubbles

    mrbubbles New Member

    51
    0
    Apr 12, 2003
    I have the same problem as you thczv, not as shredhead. I am using the latest snapshot on Windows XP. I am going to try on my fedora core 6 machine to compare. Did you ever get it figured out?
     
  13. thczv

    thczv New Member

    47
    0
    Dec 20, 2001
    Sacramento, CA
    I never did figure it out. For now I am using the Tivo Desktop server for playlists, while also running pyTivo for video. I would love to get pyTivo working for everything.
     
  14. zirzlo

    zirzlo New Member

    9
    0
    Jul 4, 2004
    Hello all,

    So, I just started using pyTivo this past week. I love it! Thank you!!!

    But (come on, you knew there was one coming), I'm having or rather had issues getting it to recognize my music store and thought I'd post my observations here for anyone that might run into the same thing (at least I'm trying to be helpful) :)

    All of my music is stored on an Infrant NAS device under \\ratnas\media\music

    I have the latest pyTivo from wgw installed (the most recent one I found was the one from about 80 minutes ago, the Master one with the description of 'notify when debug enabled')

    Now, video works fine. My issue was with music. I have pyTivo installed as a service (WinXP SP2). In my pyTivo.conf file, I initially setup the music parms as:

    [My Music]
    type=music
    path=\\ratnas\media\music

    Then, I restarted the service. So far, so good. But when I navigated to My Music on my TiVo, it would give me an error of:

    'An unexpected error occurred while accessing the server. (Error#3-5-6)'

    So, I figured maybe pyTivo didn't understand UNC pathnames, so I mapped a drive, M, to this share, changed pyTivo.conf to point to M:, restarted the service and tried to access my music on the TiVo and got the same error.

    Then, I thought, OK, the PyTivo service can't access the NAS because it is launching with System credentials, so I changed the service to startup using my own credentials, which are the same on the NAS, and restarted the service again. But again, from the TiVo, I got the same error. At this point, the conf file was still pointing to the mapped drive, M.

    So, since it was running as a service, I couldn't really tell what was going on when the TiVo spit out this error. So, I stopped the service and launched pyTivo from the command line so I could see the console. I then went back into the TiVo and tried to access the music, expecting to get the same error since I hadn't changed anything at this point other than how I was running pyTivo. Lo and behold, it displayed all my music just fine. At this point, I had to just sit there for a minute and scratch my head.

    OK, done scratching! I killed pyTivo on the command line. I went back into the conf file and changed the music share info back to the original settings of:

    [My Music]
    type=music
    path=\\ratnas\media\music

    Then I went back and restarted the service, which is now running under my creds. Back to the TiVo and....Voila! Everything works just great now. Well, except for the fact that I can't play any of my FLAC files (I guess ffmpeg doesn't do FLAC).

    So, what did I learn?

    -pyTivo works with UNC, but NOT mapped drives (when run as a service)
    -If pyTivo is running as a service, in order for it to work with UNC locations, you need to change the service to use credentials that have access to that location.
    -If pyTivo is started from the command line and you are logged on as a user that has access to the UNC location or mapped drive, everything works.

    Hope this helps someone else!

    P.S. - are there any plans to support FLAC or is that a function of ffmpeg and therefore not under the control of pyTivo?
     
  15. gonzotek

    gonzotek tivo_xml developer

    2,404
    3
    Sep 24, 2004
    Outside...
    Those are some helpful notes on the windows service/networked drives troubles that people commonly come up against.

    I don't have any FLAC files in my library, but here's the output of my self-compiled ffmpeg:
    Code:
    cassidy@tungsten:~/Desktop$ ffmpeg -i newkid.flac -acodec libmp3lame newkid.mp3
    FFmpeg version SVN-r11546, Copyright (c) 2000-2008 Fabrice Bellard, et al.
      configuration: --enable-gpl --enable-pp --enable-pthreads --enable-libvorbis --enable-liba52 --enable-libgsm --enable-libdc1394 --disable-debug --enable-shared --enable-libxvid --enable-libfaac --enable-libmp3lame --enable-libx264 --enable-libfaad --enable-x11grab --enable-swscaler --prefix=/usr/local
      libavutil version: 49.6.0
      libavcodec version: 51.49.0
      libavformat version: 52.4.0
      libavdevice version: 52.0.0
      built on Jan 17 2008 19:03:24, gcc: 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
    Input #0, flac, from 'newkid.flac':
      Duration: N/A, bitrate: N/A
        Stream #0.0: Audio: flac, 44100 Hz, stereo
    Output #0, mp3, to 'newkid.mp3':
        Stream #0.0: Audio: libmp3lame, 44100 Hz, stereo, 64 kb/s
    Stream mapping:
      Stream #0.0 -> #0.0
    Press [q] to stop encoding
    size=     153kB time=19.6 bitrate=  64.0kbits/s    
    video:0kB audio:153kB global headers:0kB muxing overhead 0.019779%
    cassidy@tungsten:~/Desktop$ 
    
    (I got the test file from here: http://ff123.net/samples.html )
    The mp3 played fine on my pc. I can't test the TiVo at the moment, sorry. You could try running ffmpeg by hand on one of your files, to see if it can both correctly decode flac, then re-encode it to mp3. If so, this could be a pyTiVo issue. If not, you may need to find a different ffmpeg binary, or compile your own. I'm not sure if the developers are building one for the windows build of pyTiVo or not.
     
  16. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    The TiVo bug which causes high bandwidth programs to suffer errors is giving me a headache, and I was hoping to get pyTiVo to alleviate it somewhat for the time being. I am able to get pyTiVo not to transcode at all, which results on great looking videos, but high bandwidth content suffers major video and audio skips when played back on the TiVo. Of course I can enable transcoding, but then ffmpeg also transcodes the audio, which I don't want, and transcodes the video to 4Mbps, which alleviates the skipping, but produces quite a few artifacts and causes me to wind up with simple stereo audio rather than AC3. I've tried various options, but nothing I've tried will get ffmpeg to transcode at , say 8 or 10Mbps rather than just 4, and it always comes out with transcoded audio. Is there a way to get ffmpeg to transcode to 8 or 10Mbps and not transcode the audio?
     
  17. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    You should know that this error occurs spontaneously at times with the music plugin (only when running on Windows -- I've never seen it happen in Linux). A similar error can occur with the photo plugin.

    Just add '.flac' to the list of supported extensions near the top of music.py ("TRANSCODE"). The current list is not comprehensive... I asked for help on that, but no one responded. Anyway, I'll add .flac for the future.
     
  18. PaulS

    PaulS Member

    674
    1
    Sep 16, 2002
    Southern NH
    You should be able to specify an video bitrate ("video_br") in your pytivo.conf file. Try assigning it to 8192k or 10240k and see if that clears up your artifacting.
     
  19. CuriousMark

    CuriousMark Forum Denizen

    2,606
    0
    Jan 13, 2005
    SoCal
    I am seeing this on my kurobox running debian but not from windows xp. It is random in that it will happen after a random number of page downs. At first I thought it might be content related, but then I saw that pages which erred one time displayed fine the next. I am thinking it might be resource problems on the Kuro, it is pretty wimpy. I hope to put some time into looking at it this weekend.
     
  20. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    I've gotten the 3-5-6 error using your music plugin on Linux ... it was when I had those directory names with special characters.
     

Share This Page