1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. KRKeegan

    KRKeegan Im lost and confused

    Jul 20, 2004
    Yes but it is rarely used and it appears users prefer to use the forum.
  2. vnavone

    vnavone New Member

    Feb 3, 2003
    I've cross-posted this message at the new pyTivo forum...

    Hi All, I'm following the wiki installation guide for MacOS X (I'm running 10.4.10). I've installed Xcode Tools (2.5), MacPorts (latest), and Python (2.5.1), and now I'm trying to do the remaining installs and get PyTivo running. So far I seem to be unable to install the faac with ffmpeg. I get this:

    Victors-G5:~ victor$ sudo port install ffmpeg +lame +libogg +vorbis +theora +faac +faad +xvid +x264 +a52 +dts
    ---> Configuring faac
    Error: Target org.macports.configure returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_faac/work/faac && aclocal -I . && autoheader && glibtoolize --automake" returned error 1
    Command output: /usr/bin/glibtoolize: line 1: cd: /usr/share/libtool: No such file or directory
    glibtoolize: cannot list files in `/usr/share/libtool'

    Error: The following dependencies failed to build: faac faad2 autoconf help2man p5-locale-gettext perl5.8 libtool m4 automake libogg libtheora libvorbis pkgconfig x264
    Error: Status 1 encountered during processing.

    I've looked in my /usr/share directory and sure enough, no "libtool" folder. Was this supposed to be installed by Xcode, MacPorts or something else? There was a sentence in the OSX install instructions that I didn't understand:

    "Make sure that your path includes the XCode tools."

    I don't know how to do this; could this be part of the problem?

    I was able to compile the other elements individually (lame, vorbis, xvid, etc.) so I thought I'd try running pyTivo without the faac. That doesn't work either:

    Victors-G5:/Applications/pyTivo victor$ python pyTivo.py
    Traceback (most recent call last):
    File "pyTivo.py", line 11, in <module>
    httpd.add_container(section, settings)
    File "/Applications/pyTivo/httpserver.py", line 21, in add_container
    settings['content_type'] = GetPlugin(settings['type']).CONTENT_TYPE
    File "/Applications/pyTivo/plugin.py", line 13, in GetPlugin
    module = __import__(module_name, globals(), locals(), name)
    ImportError: No module named photo.photo

    After searching this thread for similar problems I ruled out some possible causes. I have correctly copied and renamed my config file, so that's not the issue. I also inserted .profile and .bash_profile in my home directory (they were not there originally) and put in the following info:

    export PATH=/opt/local/bin:/opt/local/sbin:$PATH
    export DISPLAY=:0.0
    export EDITOR=/usr/bin/pico

    The profiles are otherwise empty. Do I need more? Any help appreciated.
  3. philhu

    philhu User Since Day ONE!

    Apr 11, 2001
    That was it! All fixed.
  4. jsbrss

    jsbrss New Member

    Mar 15, 2007
    Xcode installs its own directory structure in the 'Developer' folder in the root directory. So you should see "/Developer/usr/share/libtool" on your system.

    I did the install on my mac using the same instructions you are, but I can't remember exactly what they mean by "Make sure that your path includes the XCode tools" either. Maybe you cd to that directory before you run the sudo commands?
  5. vnavone

    vnavone New Member

    Feb 3, 2003
    Thanks for trying to help. I found the "libtool" in my /Developer/usr/bin, then I tried running my commands from within /Developer but I still get the same error:

    Command output: /usr/bin/glibtoolize: line 1: cd: /usr/share/libtool: No such file or directory
    glibtoolize: cannot list files in `/usr/share/libtool'

    So I tried copying libtool to my usr/share, but I still get the same error.
  6. John Slider

    John Slider New Member

    Apr 16, 2006
    I'm having noticeable overscan problems. I right clicked on my video and selected properties, and the details and it says the width is 720 so I edited the pyTivo config file to match that, but there is still a good amount trimmed. How can I fix?
  7. StanSimmons

    StanSimmons Senior Moment Member

    Jun 10, 2000
    I've got a couple of hundred shows I'm importing to a S2 v9.1 TiVo and pyTivo seems to be the way to go except for one little issue...

    I can't seem to get pyTivo to see any of my metadata. I have a bunch of shows named someshowname.mpg with matching someshowname.mpg.txt metadata files.

    I've confirmed that a normal showname.tivo file will transfer and the metadata inside that file will transfer as well. If I extract the showname.mpg and showname.mpg.txt metadata file, then I do not get the metadata info.

    What should I look at first to troubleshoot this?

    Never mind.... It helps if you are working on the current version. :eek:
  8. wgw

    wgw New Member

    May 16, 2007
    I've issued an update moving the calls to get source bitrate into the video info cache. Tivo NPL display should no longer be slowed significantly by these extra calls.

  9. StanSimmons

    StanSimmons Senior Moment Member

    Jun 10, 2000
    One thing I've noticed is that the pyTivo NPL has the current date showing for each recording, not the recorded date that is listed in the metadata.

    Once the recording is moved onto the tivo, then the correct date shows up.
  10. scrappydog65

    scrappydog65 Long Time TiVo User

    Dec 29, 2003
    I've noticed the same thing and wish there was a way to either show the date in the metadata file OR the physical files date.

  11. netphoenix

    netphoenix Netphoenix

    Apr 30, 2006
    As I continue to search for clues in this behemoth of a thread...

    I've been alll fat, dumb & happy until a few days ago I decided to update my code.... <g> That's when my listing problems began with folders containing mixed Tivo & mp4 files. If I remove the tivo recordings from the folder, the mp4 shows display just great.

    If I have a single .tivo file in a directory full of .mp4's I'm ok. If I add a 2nd .tivo file, that's when it starts hosing up. This first file (.tivo recording) that should display will disappear and instead, seems to act like a hyperlink to the bottom of the .mp4's (alphabetically listed). If I put more than a screen full of .TIVO files in the directory, it'll display the first screen repeatedly as I attempt to scroll down. Way weird...

    I did a complete pytivo removal and a new install of the latest (what the heck while I'm at it) which was a 12-31 master file.

    I'm bare bones now, with a single folder configured and an S2 tivo:


    ffmpeg=c:\Program Files\pyTivo\plugins\video\ffmpeg_mp2.exe

    Folder example:

    Bones - Death in the Saddle.TiVo
    Bones - The Soccer Mom in the MiniVan.TiVo
    bones 0101 - Pilot.mp4
    bones 0102 - The man in the SUV.mp4
    bones 0103 - A Boy in the Tree.mp4
    bones 0104 - The Man in the Bear.mp4
    bones 0242 - Spaceman in a Crater.mp4
    bones 0243 - Glowing Bones in the Old Stone House.mp4

    and the debug show's an intersting error:
    Anchor not found: e:\MP4\TV\Bonese:\MP4\TV\Bones - The Soccer Mom in the MiniVan.TiVo

    C:\Program Files\pyTivo\Cheetah\Compiler.py:1508: UserWarning:
    You don't have the C version of NameMapper installed! I'm disabling Cheetah's useStackFrames option as it is painfully slow with the Python version of NameMapper. You should get a copy of Cheetah with the compiled C version of NameMapper.
    "\nYou don't have the C version of NameMapper installed! " - - [06/Jan/2008 14:37:14] "GET /TiVoConnect?Command=QueryContainer&Container=&#37;2F HTTP/1.0" 200 - - - [06/Jan/2008 14:37:30] "GET /TiVoConnect?Command=QueryContainer&Container=Bones&Recurse=Yes&SortOrder=Title&ItemCount=8&Filter=x-tivo-container%2Ftivo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F* HTTP/1.1" 200 - - - [06/Jan/2008 14:37:36] "GET /TiVoConnect?Command=QueryContainer&Container=Bones&Recurse=Yes&SortOrder=Title&ItemCount=8&AnchorItem=%2FBones%2Fbones%25200106%2520-%2520The%2520Man%2520in%2520the%2520Wall.mp4&AnchorOffset=-1&Filter=x-tivo-container%2Ftivo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F* HTTP/1.1" 200 - - - [06/Jan/2008 14:38:08] "GET /TiVoConnect?Command=QueryContainer&Container=Bones&Recurse=Yes&SortOrder=Title&ItemCount=8&AnchorItem=%2FBones%2Fbones%25200107%2520-%2520A%2520Man%2520on%2520Death%2520Row.mp4&AnchorOffset=-8&Filter=x-tivo-container%2Ftivo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F* HTTP/1.1" 200 -
    Anchor not found: e:\MP4\TV\Bonese:\MP4\TV\Bones - The Soccer Mom in the MiniVan.TiVo - - [06/Jan/2008 14:38:12] "GET /TiVoConnect?Command=QueryContainer&Container=Bones&Recurse=Yes&SortOrder=Title&ItemCount=8&AnchorItem=%2FBones%2FBones%2520-%2520The%2520Soccer%2520Mom%2520in%2520the%2520MiniVan.TiVo&AnchorOffset=-2&Filter=x-tivo-container%2Ftivo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F* HTTP/1.1" 200 -
  12. wmcbrine

    wmcbrine Ziphead

    Aug 2, 2003
    netphoenix, I think I see the problem. Look here.
  13. netphoenix

    netphoenix Netphoenix

    Apr 30, 2006
    That was it!!! I really appreciate you pointing this out. PyTivo is so cool. Right now I have digitized about 150 movies and the same number of TV shows. Just consider the calories I've saved since I no longer have to dig up the DVD and actually put it in my DVD player to watch it :rolleyes:

    I informed the boss I would need to add another Tb to my farm this year... ;)

  14. slestak

    slestak New Member

    Apr 4, 2007
    Anyone interested in getting a support channel on freenode going for pytivo?

    I looked around and didn't see one. I'll research it if there is an interest.
  15. starmanj

    starmanj New Member

    Aug 18, 2007
    Any chance of adding MRV protocol to PyTivo so us zippered dtivo users can enjoy this tool?
  16. dlfl

    dlfl Cranky old novice

    Jul 6, 2006
    Nice offer, but:
    A dedicated pyTivo forum with a support topic was just created. What would a "support channel" buy us beyond that?
  17. gonzotek

    gonzotek tivo_xml developer

    Sep 24, 2004
    Real time chat over standard IRC protocol. To me, the best projects allow for mailing lists, forums, chat , and independent developers' blogs, but they archive everything online, where it can be found later.
  18. slestak

    slestak New Member

    Apr 4, 2007
    Ive registered over there. I agree with the fellow who said we dont have to have just one. irc is nice when you want to float an idea or want to see if anyone is in for an immediate question. Thre is also a social aspect to irc you do not get as much with forums.

    I know the idiosyncrasies and sense of humor of friends in other freenode communities where we have common interests. Its also a good "staging area" to help grow the pytivo community.

    Just a thought.
  19. Narf54321

    Narf54321 New Member

    Mar 29, 2005
    Getting PyTivo working with DTV units would be pretty tricky, since it's all built around the Tivo-To-ComeBack feature which DirecTivos lack.

    I'd suggest checking out tivoserver or MovieLoader for similar functionality. You've obviously already "hacked" the box, so those are new options for you.
  20. MasterCephus

    MasterCephus New Member

    Jan 2, 2005
    Ok I changed the link in my sig to a better download location...

    Now you should be able to download it.

Share This Page