1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    523
    46
    Jul 9, 2001
    Central Jersey
    Why do you think that it would, or would not, be?

    ALL of the 'tools' that perform the *SAME* tasks with a TiVo must access the *SAME* functions on a TiVo, so unless the author of a certain 'tool' has somehow inserted 'delays' in the fetch routine, each 'tool' should perform downloads basically the same.
     
  2. Mikeguy

    Mikeguy Well-Known Member

    4,125
    568
    Jul 28, 2005
    New pyTivo Desktop has a queue screen showing the remaining jobs, as well as the status (amount transferred (percentage and size) and transfer speed) of the current job. Nice--also for checking if a job has frozen.

    Easier to use pyTivo
     
  3. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    @jgrub and any other Mac users. I've just posted my first release of pyTivo Desktop for Mac...

    pyTivo Desktop

    please try it out if you can and let me know if you have any trouble with it.
     
    Wil and Mikeguy like this.
  4. Spenner

    Spenner Member

    89
    2
    Mar 28, 2006
    If you refresh the pyTivo page where you checked the shows to transfer, under the show it will show the transfer speed, amount transferred, "Transfer Complete", or "Queued". ie:
    NBA Playoff: Game 3: Warriors at Trail Blazers
    Transfering - 69.52 Mb/s
    1.380 GB Stop Transfer
     
  5. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    My version uses a differt UI. When you click the download button on a recording it's added to the transfer queue which is indicated by a button with a number in the upper right of the UI. Clicking that button displays the queue which includes an auto updating progress bar along with byte count and transfer speed.

    Looks like this....
    [​IMG]
     
  6. wmcbrine

    wmcbrine Ziphead

    10,450
    60
    Aug 2, 2003
    Untrue -- it doesn't care what the MAK is at that stage. (It doesn't come up until you try to get a list of recordings from the TiVo, or of course, download one.) Note that you can even set MAKs on a per-TiVo basis in pyTivo.conf.
     
  7. May 1, 2017 #5867 of 5893
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    You're right. It does require some MAK or it doesn't even look for TiVos though. I assumed it needed a correct MAK, but as long as there is something it'll work. (Also requires an output directory)
     
  8. May 1, 2017 #5868 of 5893
    cherry ghost

    cherry ghost Well-Known Member

    5,484
    38
    Sep 13, 2005
    Chicago
    Did you ever figure this out?

    I got it to work on my new Bolt by setting zeroconf to "on," but it seems odd that all my non-Bolts are fine with it set to "auto" or "off."
     
  9. May 1, 2017 #5869 of 5893
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    FYI I updated the zeroconf code in the newest release. I'm not 100% sure it'll help your issue, but it might.
     
  10. May 1, 2017 #5870 of 5893
    cherry ghost

    cherry ghost Well-Known Member

    5,484
    38
    Sep 13, 2005
    Chicago
    Thanks, but I'm not using that version.



    It turns out that it's not working as it should. I can now see my Bolt on my browser but can't see any shares on my Bolt.
     
  11. May 2, 2017 #5871 of 5893
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    You should give it a try
     
  12. May 2, 2017 #5872 of 5893
    cherry ghost

    cherry ghost Well-Known Member

    5,484
    38
    Sep 13, 2005
    Chicago
    Ok, finally got it working properly by changing the beacon setting
     
  13. May 2, 2017 #5873 of 5893
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    What did you change it too? Did you set it to blank, which turns beacon off, or set it to a specif IP range?
     
  14. May 2, 2017 #5874 of 5893
    cherry ghost

    cherry ghost Well-Known Member

    5,484
    38
    Sep 13, 2005
    Chicago
    It was blank. I put in the IP of the Bolt.
     
  15. May 2, 2017 #5875 of 5893
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    If it was actually in the file but blank...

    beacon=

    then that means beacon was off. If you simply delete the line, rather then put an IP in there, then it will turn back on and broadcast to your entire subnet.
     
  16. May 2, 2017 #5876 of 5893
    dorpen

    dorpen New Member

    8
    0
    Nov 12, 2016
    In the past week my Tivos (Premiere and Roamio) have stopped seeing my computer. Up to this point I started pyTivo and they would both show my computer allowing me to transfer files from my computer to each Tivo. Then both Tivos stopped showing my computer as a choice in the My Shows section, stopping me from transferring videos to the Tivos. The pyTivo on my computer can still see and transfer the files on each Tivo back to my computer. What step am I missing in having the Tivos read my computer as a choice and allow files to be transferred computer to Tivo? I have tried the latest versions 1.5.12 and 1.5.15 and still get the same result.

    Below is the info data I get from pyTivo (same for all pyTivo versions):
    Code:
    INFO:pyTivo:Last modified: Sat Aug 27 15:02:20 2016
    INFO:pyTivo:python: 2.7.12
    INFO:pyTivo:System: Windows-10-10.0.14393
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo.beacon:Living Room
    INFO:pyTivo.beacon:Bedroom
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: Movies to Tivo
    INFO:pyTivo:pyTivo is ready.
    
    Any suggestions as to what I can do to get my Tivos again seeing my computer and offering it as a choice in Tivo's My Shows section as it has been doing for years?

    Darrel
     
  17. May 2, 2017 #5877 of 5893
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    39,252
    838
    Apr 17, 2000
    Nevada
    There could be a conflict. Exit the tray app. Double check the task manager and make sure all versions of pyTivo.exe are stopped. If not kill them manually. Now restart pyTivo and give it a few minutes. If the shares still don't show up on your TiVo then check the options. Make sure zeroconf is either on/auto and that beacon is blank.
     
  18. May 2, 2017 #5878 of 5893
    cherry ghost

    cherry ghost Well-Known Member

    5,484
    38
    Sep 13, 2005
    Chicago

    It was not in the file at all
     
  19. May 5, 2017 #5879 of 5893
    ericdkirk

    ericdkirk New Member

    13
    1
    Oct 9, 2014
    Dan is there any chance of you supporting plugins?
     
  20. May 5, 2017 #5880 of 5893
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    523
    46
    Jul 9, 2001
    Central Jersey
    Wrong thread! :oops:

    This is pyTiVo by @wmcbrine
     

Share This Page