1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. May 18, 2007 #501 of 5755
    cuzzinjim

    cuzzinjim New Member

    15
    0
    Sep 18, 2004
    NYC!!
    Just want to say thanks for all the hard work you guys have done on this program. It is a feature set that I found indispensable as soon as I tried it - and I cheered when you solved the 8.3 bug - I was lost without PyTivo.

    Thank you!!
     
  2. May 20, 2007 #502 of 5755
    mkleiman

    mkleiman New Member

    10
    0
    Mar 8, 2007
    What is the last stable version that supports multiple pytivo servers on the same network?
     
  3. May 20, 2007 #503 of 5755
    TreborPugly

    TreborPugly Unreal!

    4,542
    0
    May 2, 2002
    Eastern TN

    I would imagine anything on the trunk. The stuff for dealing with version 8.3, which added the problem with multiple pytivo servers, is a branch.
     
  4. May 23, 2007 #504 of 5755
    Sicklybutsexy

    Sicklybutsexy New Member

    179
    0
    May 5, 2007
    This might be unneccessary, but do you know if it is possible to have both TDN and pyTivo on the same computer. I tried it and had troubles converting AVI files.
     
  5. May 23, 2007 #505 of 5755
    windracer

    windracer joined the 10k club

    11,600
    4
    Jan 3, 2003
    St. Pete, FL
    I've never tried, but you might need to change some ports. I believe they both use 9032/9033.
     
  6. May 23, 2007 #506 of 5755
    buffalova

    buffalova New Member

    30
    0
    Jul 7, 2006
    First I would like to say what a great program. I have installed the 8.3 with subfolder 200 version and it works great on 2 tivos and does a fantastic job of converting wmv and other files as well as browsing subfolders. I added 5 shares with no problem except for one share. When I browse the folder I can an "error occurred" and it doesn't display anything. The share in question has many folders in it and probably 100 gb of files.

    My question is am I asking too much by such a large folder or is it possibly one particular file within that folder that is causing the error or are there just too many folders in that folder.

    It's really no big deal anyway I am more than pleased with the results I have. I was just wondering if there was something to look for. Many thanks to the developer(s).
     
  7. May 23, 2007 #507 of 5755
    mkleiman

    mkleiman New Member

    10
    0
    Mar 8, 2007
    You are correct. My problem with multiple pytivo servers was a result of the undocumented guid feature. Once I sent the guid's manually in the .conf files, everything worked as expected.

    Any reason this hasn't been added to the documentation/wiki?
     
  8. May 26, 2007 #508 of 5755
    etsolow

    etsolow Don't Try

    1,560
    0
    Feb 8, 2001
    Wisconsin
    No comment here, but a question:

    What ports need to be open between the Tivos and the pyTivo machine? I opened the port that's in pyTivo.conf (TCP/9032) as well as UDP/3560 that I found with Netstat, but I'm not seeing anything on the Tivos. This setup worked fine before I separated my wireless network from my "main" network with an IPCop firewall.
     
  9. May 26, 2007 #509 of 5755
    greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    It is TCP/9032 and TCP/9033 for Tivo.Net. With those two open pyTivo also works on my system...
     
  10. May 26, 2007 #510 of 5755
    etsolow

    etsolow Don't Try

    1,560
    0
    Feb 8, 2001
    Wisconsin
    Hmm. I have both of those open now and still nothing. I just realized that I've got two subnets with the new system, that must be the problem. I might need to re-architect a little!
     
  11. May 27, 2007 #511 of 5755
    TreborPugly

    TreborPugly Unreal!

    4,542
    0
    May 2, 2002
    Eastern TN
    Cool, I think I found an undiscovered but with the 8.3 folders fix!

    1. Go into Folder "A" - see the proper list
    2. Go back out to the top of your share, or back to the Now Playing list, whatever,
    3. Go into Folder "B" - see the proper list for folder "B". Scroll through files with arrows, no problem.
    4. Use your "skip to tick" button, which normally will jump you to the end of the list, right? It jumps, but now you are seeing the contents of Folder "A"!

    If you go back out and into Folder "B", or Folder "C", it will show stuff right, but whenever you use the skip to tick to jump to the end, it will go back to Folder "A".

    (Oh, well, after trying to leave folder "C", I had my Tivo Crash, so, maybe not...)
     
  12. May 29, 2007 #512 of 5755
    sraveh

    sraveh New Member

    1
    0
    Feb 9, 2005
    Hi,

    I've been using pyTivo for a couple of month now and I love it.
    I used Galleon before and I think pyTivo is doing great job.
    One thing that I miss or do not know how to configure is mp3 playlist. I tried pointing pyTivo to a directory that contains my playlist but it complains that it empty.
    Does pyTivo support playlist?


    Thanks,
    Simon
     
  13. May 29, 2007 #513 of 5755
    brunson

    brunson New Member

    14
    0
    Apr 26, 2005
    Has anyone reported this to TiVo? It seems like they could fix it in a future release.
     
  14. May 29, 2007 #514 of 5755
    KRKeegan

    KRKeegan Im lost and confused

    215
    0
    Jul 20, 2004
    Los Angeles, CA
    Yeah I did, I even got a response back that they were forwarding it to the correct department and requesting my contact information.

    That was however, almost a month ago and I have not heard anything back from them at all. But I hope it gets fixed.

    Kevin
     
  15. May 30, 2007 #515 of 5755
    cr33p

    cr33p New Member

    644
    0
    Jan 2, 2005
    Ann Arbor MI
    First of all I have been using pytivo ever since I stumbled on it when it first dropped might I just add its the whip, much thanks :) Anywho on to my question, does pytivo support any info details like xml data? When I choose a vid out of my NPL it just tells me the name of the file but does not tell me the duration or any other data. Is there a way to have this info imputted with pytivo ?

    Thanks

    Chris
     
  16. May 30, 2007 #516 of 5755
    KRKeegan

    KRKeegan Im lost and confused

    215
    0
    Jul 20, 2004
    Los Angeles, CA
    No nothing yet I am afraid, that is a project of mine that has been stumbling around in my head for a while. I have 2 issues to solve:
    1. How to store the data, (Database, or individual files, or some embedded tag like ID3)
    2. How to input the data, (probably need some html interface to add titles and the like)

    It is on the list of things to do, but I am afraid it is a big step, so it might take me a while to get around to it. :p

    Kevin
     
  17. May 30, 2007 #517 of 5755
    gonzotek

    gonzotek tivo_xml developer

    2,407
    4
    Sep 24, 2004
    Outside...
    My vote would be for #1, using an ajax-ified html form to pre-fill in as many fields as possible(for instance different episodes of the same series will contain many similar meta fields the same way different tracks of an album will). Using a DB also gives the opportunity to query it independently of pyTiVo functions, to (for example) create an output file in another format for another device(ipod or whatever), with metadata transported over. If there's a standard for tagging mpeg2 video (I'm not aware of any, will id3v2 or ape tags work???), tagging the files would be useful for some things, but I think a db would provide faster results, since once the files are added(or updated) they wouldn't need to be read from disk (unless updated again).
     
  18. May 30, 2007 #518 of 5755
    KRKeegan

    KRKeegan Im lost and confused

    215
    0
    Jul 20, 2004
    Los Angeles, CA
    That would be very cool, someone may have to help me with ajax, I have never worked with it.
    My only problem with a db is that moving or renaming files will of course cause an issue.
    There is, but it is not available in all of the video formats that ffMpeg supports, thus it is not a good idea.
     
  19. Jun 1, 2007 #519 of 5755
    buffalova

    buffalova New Member

    30
    0
    Jul 7, 2006
    Hello all. I have read this entire post and believe my problem has been discussed but am not sure how to proceed.

    On my TSN240 tivo when I transfer a video with a ratio greater than 4:3 specifically 1.37 or 704x512 I receive a conversion that has black bar on both sides where as 704x528 works.
    If I set the tivo to display 4:3 instead of 16:9 it produces a correct video but is now enclosed in a frame of black bars so to speak.

    I even tried the suggested mpeg4 modifier to make it a true 4:3 ratio. I tried it for pixel AR as well as display AR but that didn't see to help either.

    I was going to try changing this statement to false but it doesn't even appear in my pytivo.conf file

    #If you want to use 16:9 or 4:3 on this tivo
    #aspect169=true


    If I use Gui4fmpeg and convert manually to the tivo desktop folder it works fine which to me seems like an edit is possible I just don't know what to edit.

    Is there a simple edit I can do or is it that some files with this machine will not convert correctly?

    What is odd it that it doesn't do this on my TSN540 tivo. Many thanks

    I have WinXP
     
  20. Jun 2, 2007 #520 of 5755
    dlfl

    dlfl Cranky old novice

    7,052
    26
    Jul 6, 2006
    Dayton OH
    Have you tried the *** Wiki ***? Particularly the 'Notes" in the configuration section and the discussion of aspect ratio.

    Just out of curiosity, what is the source of the videos, and what type are they?
    pyTivo cannot find out the PAR (or DAR) from ffmpeg. Thus it must assume square pixels, i.e., that the desired DAR is that represented by the input file dimensions.
    Read the Wiki notes on the configuration page describing the format of the pyTivo.conf file. Many parameters, including aspect169, will get default values if they don't appear in the file. Default for aspect169 is false. If you want a different value just add the line in the proper section.

    To get better help here, post your pyTivo.conf file, at least the parts before the sections defining shares.
    In general there are some files (specifically those with non-square pixels) that will not be handled properly by pyTivo (because it has no knowledge of PAR or DAR).
    There are differences in the Tivo models in this regard. The width and height settings in your .conf file can make a difference here.
     

Share This Page