1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    Why are you still trying to run it from Program Files?
     
  2. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    This is how I enter it.

    1 Open command with admin privileges
    2 Open ie
    3 enter localhost:9032
    4 click my videos.
    That as far I has I can get.
     
  3. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    What I am asking is why have you not installed pyTivo in its own directory. Start fresh.

    Stop pyTivo.

    Create C:\pyTivo

    Copy pyTivo.conf from C:\Program Files\pyTivo to C:\pyTivo

    Copy everything from pyTivo-master to C:\pyTivo

    Start the pyTivo,py that is in C:\pyTivo not the one that is in C:\Program Files\pyTivo.
     
  4. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    I tried that yesterday with the same results. I'll it again later the computer I use for pytivo is in use is in use
     
  5. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    I have a question that I might be misunderstanding.You said to stop pytivo. How do it check that? I always was rebooting the computer think that pytivo does not start when it is rebooted.
     
  6. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    The ones you start can be stopped by doing a Ctrl-c (hold down the "Ctrl" key and hit the "c" key) while in the command window in which it is running.

    To see if it is running as a service, do a Ctrl-Alt-Del, select Task Manager, then select the "Services" tab select any service named "pyTivo" or "python", right mouse and select "Stop". I was going to suggest you do this anyway. Post here if you find any so named.
     
  7. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    Ok this is what did just now . Check to see if pytvo or python is r.unning they are not
    Open a command with admin rights.
    Entered cd C:\pyTivo ehter then pytivo.py
    Now I get this.
    C:\pytivo>pytivo.py
    Traceback (most recent call last):
    File "C:\pytivo\pyTivo.py", line 15, in <module>
    import httpserver
    File "C:\pytivo\httpserver.py", line 16, in <module>
    from Cheetah.Template import Template
    File "C:\pytivo\Cheetah\Template.py", line 59, in <module>
    from Cheetah.Compiler import Compiler, DEFAULT_COMPILER_SETTINGS
    File "C:\pytivo\Cheetah\Compiler.py", line 35, in <module>
    from Cheetah.Utils.Indenter import indentize # an undocumented preprocessor
    ImportError: No module named Utils.Indenter

    C:\pytivo>.

    I think it is about time we quit on this ideal.
    as least I did find out to copy and paste the command lines instead of using a print screen app.
     
  8. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    This is one reason I wanted you to use this rather that the one in Program Files. There is something seriously wrong with your installation. When you unzipped the file you downloaded, did you tell it to retain the directory structure?

    That's up to you but bear in mind that it may not be easy to get back to where you were.
     
  9. 951SoCal

    951SoCal New Member

    1
    0
    Jun 12, 2014
    Anyone else notice the MIND server is not working right now?

    Code:
    
    INFO:pyTivo:Last modified: Fri Jun 06 13:08:06 2014
    INFO:pyTivo:Python: 2.7.7
    INFO:pyTivo:System: Windows-7-6.1.7601-SP1
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo.beacon:Roamio
    INFO:pyTivo.beacon:TivoHD
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: MyMovies
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo.video.video:[12/Jun/2014 20:13:29] Queued "C:\Users\Ryan\Downloads\A
    ir crash\Air Crash Investigations - Season 1\Air Crash Investigations - 1x02 - R
    acing The Storm.avi" for Push to Roamio
    INFO:pyTivo:127.0.0.1 [12/Jun/2014 20:13:29] "POST /TiVoConnect HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [12/Jun/2014 20:13:34] "GET /TiVoConnect?Command=QueryCont
    ainer&Container=MyMovies/Air%20crash/Air%20Crash%20Investigations%20-%20Season%2
    01&Format=text/html HTTP/1.1" 200 -
    
    Just sits there.... tried 5 times now. Was working earlier today.
     
  10. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    Guess i believe we got to work. I re downloaded the master file to one of my hard drives instead of network drive. The network drive was only showing 15 files but my pc drive showed 21 files. I copied the new tivo master to pytivo folder. I open the command up and it looked ok. I open the web page up and clicked my videos. It went to the my videos page. I haven't tried to upload but Ii will in a few minutes. Thanks for the help
     
  11. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    Glad to hear it.
     
  12. aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    I just did a quick install of PyTiVo and ffmpeg since I have been having issues recently with my Tivo Server from TiVo Desktop stopping. I don't know if it's becuase of the large amount of shows or what. I've also setup KMTTG.

    But anyway. I have it setup and am able to transfer content back to my TiVos without issue.

    But when I view the list of shows from the PC on the TiVo, it doesn't show up in groups. Is there some setting in PyTivo I need to enable to allow me to see the groups? I can turn groups on/off on the TiVo and it makes no difference.
     
  13. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    The HDUI and the SDUI have separate grouping controls (and pyTivo shares are forced to SDUI mode). Press "2" while viewing the pyTivo share.
     
  14. aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    Thanks. I tried it but that didn't do anything. It had the same effect as me changing the groups on/off on the options page. Only pressing "2" is a shortcut instead of going to that page. I know when I had the TiVo Server running groups would show up.

    I only set this up to emulate what TiVo Desktop does. So KMTTG will transfer shows to the PC automatically and then I setup PyTiVo and ffmpeg so I could view the list of shows and transfer them back when needed. But without grouping the list is very large since I have around 650 shows in there right now.
     
  15. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    So to be clear, you're seeing the line "Groups sorted by date" (or "Groups sorted by name") at the bottom of the screen, and still not seeing groups in the list? And, you do have subdirectories (folders) within the pyTivo share?

    Or... is this a flat directory full of .TiVo files, and you're relying on the internal metadata to group? Is that a thing TiVo Desktop does? pyTivo doesn't do that. It just reflects the operating system's directory structure.
     
  16. aaronwt

    aaronwt UHD Addict

    19,173
    21
    Jan 31, 2002
    Northern...
    Yes just a folder full of shows, no sub-folders. TiVo Desktop would automatically put things in folders when you viewed them from a TiVo. But the folders didn't actually reside on the PC.

    So it sounds like I need to manually put the shows in folders on the PC to see them in folders from the TiVo? Or is there a way to automate putting the shows in folders?
     
  17. mickrussom

    mickrussom Member

    36
    0
    Dec 21, 2007
    I keep getting 404s for videos Im attempting to push to Tivo Series3

    INFO:pyTivo GET /TiVoConnect?Command=QueryItem&Url (url to video) 404

    Example

    INFO:pyTivo:192.168.0.203 [28/Jun/2014 07:55:11] "GET /TiVoConnect?Command=QueryItem&Url=http%3A%2F%2Fa%2Fb%3FContainer%3D%2FNowPlaying%26id%3D%2FMyMovies%2FWhisper%252
    0Heart.mp4 HTTP/1.1" 404 -

    This is driving me nuts, I just updated to latest.

    This used to work, I had to update for some other reason, but now basic things dont work. I even regenerated all the the pyc.

    INFO:pyTivo:Last modified: Thu Jun 19 09:35:44 2014
    INFO:pyTivo:python: 2.7.3
    INFO:pyTivo:System: Windows-post2008Server-6.2.9200
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: MyMovies
    INFO:pyTivo:pyTivo is ready.
    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:03:30] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:03:30] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:03:33] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:03:35] "GET /TiVoConnect?Command=QueryFormats&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -

    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:04:00] "GET /TiVoConnect?Command=TVBusQuery&Container=MyMovies&File=%2FWhisperHeart.mp4 HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:04:01] "GET /TiVoConnect?Command=QueryFormats&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
    INFO:pyTivo:192.168.0.203 [28/Jun/2014 08:04:01] "GET /TiVoConnect?Command=QueryItem&Url=http%3A%2F%2Fa%2Fb%3FContainer%3D%2FNowPlaying%26id%3D%2FMyMovies%2FWhisperHear
    t.mp4 HTTP/1.1" 404 -
     
  18. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    Um... QueryItem has always returned 404, because pyTivo doesn't implement it. (I did eventually add it for Photos and Music, but not Video.) Apart from the 404 in the log, its absence has no detectable effect. It's even less meaningful for push than for pulls, because on push requests, the TiVo doesn't even make TiVoConnect queries.

    Are you having an actual problem pushing or pulling?
     
  19. mickrussom

    mickrussom Member

    36
    0
    Dec 21, 2007
    Pull (from video share on my compute to the Tivo) problem - This used to work , but now when I ask for the video to pushed it wont get into the ToDo list.

    The only reason I looked at these 404s is that for some reason it went from working with a large directory full of files (30-40 videos), one day it did not want to take files off of this share (C:\Users\username\videos), so I tried a number of things and the best hack so far is to put one file in the video share dir at a time and then it seemed to work. I tried shortening the path, changing the names of the files to shorter names, etc. Cant figure it out.

    It seems its choking on specific movies without ever getting to ffmpeg. These at the moment seem to be MP4. But this same movie was transferred before.

    I converted it to MKV (from MP4) and its still the same. Seems im only able to transfer AVI?
     
  20. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    I'm a bit confused. How are you initiating the transfer? By selecting the share in "My Shows" on the TiVo (which would be a pull) or by selecting it for push in pyTivo or vidmger?

    Is it possible that one file is causing the problem? Have you tried splitting the videos into two different shares and seeing if the problem only occurs with one the other?
     

Share This Page