1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pyTivo - Transcoding server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by armooo, Nov 25, 2006.

  1. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    Yes. But, the only relevant thing it tells me is that the transfer stopped after 12 KB. I'm guessing that FFmpeg aborted the transcode. It should be clearer in console mode.
     
  2. Hercules67

    Hercules67 TiVo addict

    354
    0
    Dec 8, 2007
    I get the same thing in Console Mode, so I am not sure what I should be looking for.
     
  3. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    There should be FFmpeg output before the "Done" line, for one thing.
     
  4. gonzotek

    gonzotek tivo_xml developer

    2,404
    3
    Sep 24, 2004
    Outside...
    William, I just pulled down your updates from last night. Really like the changes! :)
     
  5. mlippert

    mlippert New Member

    59
    0
    Apr 2, 2010
    Massachusetts
    Me too! thanks.:up:
     
  6. bareyb

    bareyb Under Maintenance TCF Club

    25,945
    8
    Dec 1, 2000
    Silicon Valley
    Can you summarize the changes? Wondering if I should update again...
     
  7. gonzotek

    gonzotek tivo_xml developer

    2,404
    3
    Sep 24, 2004
    Outside...
    Listed here under May 23rd and 24th.
    https://github.com/wmcbrine/pytivo/commits/master

    Basically css/html improvements for settings and the push and ToGo pages. Looks nicer (imho), and the navigation between the root page and plugins is improved.
     
  8. bareyb

    bareyb Under Maintenance TCF Club

    25,945
    8
    Dec 1, 2000
    Silicon Valley
    Sounds like a worthwhile update. Thanks...
    UPDATE: Oooh... I like the link to the Web Config page! That's nice. I've been wanting that for awhile. :)
     
  9. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    I would think fewer hairs would make it easier to put your finger on it. Which strand are you trying to finger?
     
  10. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    Eh? That's always been there. I just renamed it.

    The new things are links back to the top level from everywhere, links back to higher levels from lower levels, and a unified logical framework for these.

    Basically stuff that should've been done long ago, but I never got around to it.
     
  11. jhilla

    jhilla Guest

    114
    0
    May 13, 2011
    I pulled the update, love the enhancement and the hyperlinks to the menus. :) Plus with TD Free going to the graveyard, more will come out and play with either Pytivo or KMTTG.
     
  12. Hercules67

    Hercules67 TiVo addict

    354
    0
    Dec 8, 2007
    I wonder with all the PyTivo experts around, why nobody has been able to help me on this....

    Where should I turn for help?

    NOW, I have a new problem caused by ffmpeg:
    1) It started with some files I changed to AVI (xvid format) will not transfer;
    AND NOW,
    2) Nothing will transfer.

    How do I capture what shows in the console to show you what I am seeing? As usual, the log.txt shows nothing. DEBUG=True.

    So, I am lost.

    Help is appreciated, even though I've gotten none. Still, it's a free program, so I can't complain. :cool::confused::(:eek:
     
  13. bschuler2007

    bschuler2007 Frustrated owner

    325
    0
    Feb 25, 2007
    Thanks for the update wmcbrine. Having to hit BACK, BACK, BACK, etc.. bothered me so much that I spent over an hour one weekend recently trying to find out where I would put in the link back to the root. I never did find it.
     
  14. innocentfreak

    innocentfreak Active Member

    8,950
    3
    Aug 25, 2001
    Florida
    I am trying to help a friend setup PyTiVo and he is having an issue. I have been trying to figure it out while he is at work without much luck.

    He did the install off the guide and the only change he made is PyTiVo runs on port 9033. He already had 9032 as something else. PyTiVo finds his TiVos and announces the shares. He can see the shares on the TiVo and the contents of the folders.

    What he can't do is see anything but settings in the web interface. He read his settings off to me and they are identical to mine except for share names and paths for the directories. He is running win 7 and installed it in C:\PyTiVo. He added the firewall exceptions. We just can't get the shares to show in the web interface. Any ideas?
     
  15. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Does he have his TiVo user ID, password and MAK defined in the pyTivo configuration?

    The best thing would be to post his pyTivo.conf file, after redacting all sensitive data.
     
  16. innocentfreak

    innocentfreak Active Member

    8,950
    3
    Aug 25, 2001
    Florida
    Yeah. His pulls seem to work fine also. He just can't see shares from the web interface. I remember having this problem also years ago, but don't remember the fix. I will have to see if I can still remote in. Otherwise I will have to wait until he gets home.

    EDIT: Thanks it looks like it was related. Somehow his web interface configuration wasn't matching his pyTivo.conf file. He had the username, MAK, and password in the global server settings, but it only showed the email address in the PyTivo.conf. It is weird since he saved, restarted, quit and relaunched multiple times. It always showed in the web config, but it most not have written it to the conf file somehow.
     
  17. dpierce

    dpierce New Member

    4
    0
    Aug 7, 2009
    I can never seem to get music to play or show up any ideas
     
  18. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Do you have a "music" share defined?
     
  19. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    Look under "Music and Photos" instead of the "My Shows" list?
     
  20. Hercules67

    Hercules67 TiVo addict

    354
    0
    Dec 8, 2007
    So, this is the type of error I am seeing now in the console window (yes, I figured out how to capture this information).

    Can anyone help me with this, OR should I just give-up?

    (See attached "error_log" text file).
     

    Attached Files:

Share This Page