1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pytivo thius page can't be displayed problem

Discussion in 'TiVo Home Media Features & TiVoToGo' started by caddyroger, Jan 13, 2013.

  1. lrhorer

    lrhorer Active Member

    6,924
    1
    Aug 31, 2003
    San...
    That doesn't tell us anything. (What does "different" mean?) There should be a line that says

    TCP <IP address>:9032 <Hostname>:0 LISTENING

    If not, pyTivo is not listening on port 9032.
     
  2. lrhorer

    lrhorer Active Member

    6,924
    1
    Aug 31, 2003
    San...
    Please try that sentence again. What is the IP of the machine running pyTivo? What machine is being used to contact pyTivo?

    I repeat: This has nothing to do with any TiVo. It does not matter what the IP of any TiVo on your system is, or even if there is a TiVo attached to your system at all, or not.
     
  3. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Sorry i have to leave like this but a friend needs my help
     
  4. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Sorry it should have have been I do not know if it attempting to reach the local pytivo server?
    The ip address of this computer is 192.168.1.6. And I am using the same computer to contact tivo.
     
  5. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    The version of pyTiVo you're trying to use is very out of date, and your pytivo.conf appears to have several errors(no section name for the video share, incorrect paths to tivodecode and tdcat, and the beacon line may or may not be helping).

    I suggest removing the out of date version of pytivo completely, then restart by following the directions at http://pytivo.sourceforge.net/wiki/index.php/Windows_Install. If you're not sure what a particular step is asking you to do, stop and ask for help here and we'll try to get you sorted. I've been working on improving the install directions, so it will be helpful to me to work through the rough spots you encounter.

    Don't feel bad about asking a lot of questions.
    Please, do provide as much and as specific information as possible, such as steps taken, full directory names, any error messages encountered, addresses, etc. :)

    While I'm not aware of any known Win8 issues, I don't have access to a Windows 8 box; if there are issues specific to that OS, hopefully we can find someone else who is knowledgeable about it.
     
  6. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    I been using this conf file and pytivo program for about 2 years now. I have replaced the motherboard and Os a couple of times. I have not any problems with installing pytivo and getting to run ok until this new motherboard.
    The files tivodccode and tdcat is located in the bin folder which my conf points to.
    I am not a very technical person with this type of stuff. Th url you listed I been there. I do not under stand it,it would have to in books for dummies form
    If some one could write that i would try it.
    If you think I upset with you I am not. I Just not smart enough to do this type of things
     
  7. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    Well, it's hard to say what is wrong. The installer was built years before Win8 was around. I have no idea if it works correctly or not. If you want to continue troubleshooting what you've got now(it's fine with me): We need to know how you're starting pyTivo. Are you double-clicking pytivo.py, or running it as a service, or???

    If you'd rather install a much more current version that has had many fixes and improvements(also ok :) ): What's the first thing that's hanging you up on the wiki? I'm willing to work through each step with you, so I can use the experience to improve the wiki and make it more friendly to less technical folk.
     
  8. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    I tried the new pytivo. When I click on pytovo.pl It shows a black cmd box and then disappears. It might be the conf file. Where can i get some sample conf files.
     
  9. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    Here is more or less what a pyTivo.conf should look like if you've set it up using the directions from the wiki:
    Code:
    [Server]
    tivo_password = acbdefg
    tivo_username = wxyz123
    tivo_mak = 0123456789
    port = 9032
    togo_path = E:\FROM THE TIVO
    ffmpeg = C:\pyTivo\bin\ffmpeg.exe
    tivodecode = C:\pyTivo\bin\tivodecode.exe
    
    [MyMovies]
    type = video
    path = F:\FOR THE TIVO
    
    Let's see if that gets pyTiVo started. If not, try running it from the command line: Press [Windows Key]-R to open the run window, then type cmd.

    Type
    cd c:\pyTivo
    then type
    pyTivo.py

    Either way, copy and paste the results here (right-click and Select All, then press Enter to copy).
     
  10. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Some how I am not able to save every thing because to many images. I get it to later If you read before I get it done.
     
  11. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    This is the only way I could get the information you wanted.
     

    Attached Files:

  12. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    If you're seeing the blinking cursor after the line with 'pyTivo is ready', then it's running. Maybe the problem is Windows 8 specific.

    Are you using IE10?
    Here's something I googled up:
    http://nik.rolls.cc/2012/08/01/localhost-development-with-ie10-metro/

    /edit:
    Also, it seems like you cut and pasted from several different windows, so I'm not exactly sure what's happening. How are you starting pytivo? How did you get the text that ends with "pyTiVo is ready" to appear?

    After that text, you have a command typo. If you are already on the command line(how you got there, I'm not sure), you don't need to start it with 'cmd'. You'd just type:
    cd c:\pyTivo
    then press [Enter] then type
    pyTivo.py
    You need to already be in the pytivo directory to start it by just typing it's name. But that should all be unnecessary IF pytivo is already running. What happens if you click http://localhost:9032/ or http://127.0.0.1:9032/ when it says pytivo is ready?
     
  13. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Yes it is IE10. I read the link you posted and entered local host 9032 but it did not help. I even switched the default to firefox with no help.
    When I opened up cmd box and typed in cd c:\pytivo I get this windows which reads can not find cd make sure you have the correct spelling. If I enter cmd cd:\pytivo then It will go to a black screen with c:\windows\system32
    I can not type any thing in the box after the blinking cursor.
     

    Attached Files:

    • cd.jpg
      cd.jpg
      File size:
      11.8 KB
      Views:
      6
  14. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    Can you verify that you have the firewall disabled (just for troubleshooting purposes, it should be re-enabled it once we've found the problem)?
    http://windows.microsoft.com/en-US/windows-8/windows-firewall-from-start-to-finish#section_2
    If you have another firewall, what is it(name and version)? Also what antivirus(name and version)?

    And, please, how are you starting pytivo? Do you double click on something or what? It's important to be as clear as possible.

    To all: Does anyone else checking out this thread have pytivo working under Windows 8 already?
     
  15. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    It's:
    cmd
    press [enter],
    then
    cd c:\pytivo

    not cmd cd c:\pytivo.
     
  16. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Ether I dumb or typed it wrong but he here it is

    Microsoft Windows [Version 6.2.9200]
    (c) 2012 Microsoft Corporation. All rights reserved.

    C:\Users\CADDY>cd c:\pytivo

    The top 2I could not show unless I did a screen shot but it the same the one posted in attachment
    INFO:pyTivo:python: 2.6.6
    INFO:pyTivo:System: Windows-post2008Server-6.2.9200
    INFO:pyTivo.beacon:Announcing shares...
    INFO:pyTivo.beacon:Registering: My Videos
    INFO:pyTivo.beacon:Scanning for TiVos...
    INFO:pyTivo.beacon:CADDY TIVO
    INFO:pyTivo:pyTivo is ready.

    I still can not enter any thing at the cursor
    I have the fire wall and anti- virus turn off. I use only microsoft

    Ok now I tried entering http//localhost:9032 on the IE address box
    It took me to the web configuration. Togo showed my programs but my videos did not. I remembered their no programs in that folder. I copy a program to it and now i can not get back to the web config page
     
  17. gonzotek

    gonzotek tivo_xml developer

    2,421
    9
    Sep 24, 2004
    Outside...
    Progress!

    Always keep the window with 'pytivo is ready' open, that's important, for now at least. You're not supposed to type into it. It's the running program and will be displaying output as you use it.

    To get back to web config, bookmark http://localhost:9032 and always use that as the jumping off point for pytivo web stuff.
     
  18. caddyroger

    caddyroger New Member

    1,730
    1
    Mar 14, 2005
    Some where...
    Yes I found out about keeping the tivo.py box open. I will bookmark it
    Thanks you very much helping this old dog out:D
     

Share This Page