1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PyTiVo machine icon is now "!"!

Discussion in 'TiVo Premiere DVRs' started by crxssi, Oct 30, 2012.

  1. reneg

    reneg Member

    699
    0
    Jun 19, 2002
    I have one system with a lot of shares defined. None of the shares are empty nor point to nonexistent directories. Only the last share displays the normal icon.

    I have another instance of pyTivo on another system with a single share, and it displays normally.

    One thing I have noticed is that when stopping and starting pyTivo, if I immediately try and display the contents of the shares from the Tivo after restart, the shares are empty. After a few seconds, the contents of the shares show up if I navigate out and back into the share. I have lots of videos so it takes a while to populate.

    I don't know if it's related to the "!" or not, but thought I'd mention it.
     
  2. waterchange

    waterchange Member

    149
    0
    Jun 29, 2010
    My ! has changed to a computer icon. Not sure what changed. I did restart pytivo but didn't make a point of noting whether or not the icon changed before that restart.
     
  3. crxssi

    crxssi Veteran TiVo User

    2,791
    0
    Apr 5, 2010
    My "share" is not empty, just a directory that has videos and a whole lot of other nested sub-directories, all of which also have videos. Yet mine is "!" always.
     
  4. moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
    Perhaps try adding a new video share in pyTivo.conf with few or no items to see if that has any influence on the icon?
     
  5. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    OK, I found two other situations in which I get the "!" display:

    1. If Zeroconf is disabled; i.e., I'm relying on the old-style beacons. This would also apply if your Zeroconf packets weren't getting through, for whatever reason (a lot of people seem to have trouble with this).

    2. If the platform name doesn't start with "pc". (This was never in any committed version, AFAICT, but I played with it for a few minutes back in February while trying to "correct" the then-new display for music and photo shares (those now use "pyTivo" as the platform name).)
     
  6. Jonathan_S

    Jonathan_S Active Member

    15,063
    10
    Oct 23, 2001
    Northern...
    For what its worth I'm seeing it as a ! in the HD menus, but a computer in the SD ones :confused:

    Whatever, it still works great, just looks a little odd.
     
  7. cherry ghost

    cherry ghost Active Member

    5,276
    5
    Sep 13, 2005
    Chicago
    setting my zeroconf to "True" fixed this for me

    Thanks
     
  8. Gavroche

    Gavroche New Member

    398
    0
    May 26, 2007
    State of...
    I have zeroconf set to true and my names begin with "pc" but I still get the darned exclamation mark instead of the computer icon on Tivo Premiere.

    Any further suggestions?
     
  9. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    You're not supposed to change the names to start with "pc", although it's harmless if you do; that was referring to a field that's set by pyTivo internally. I shouldn't have brought it up, really. You don't need to explicitly set the "zeroconf" option to "true", either, since that's the default; the point was that you'll see this behavior if you set it to false, or if for any other reason the TiVo isn't getting the zeroconf packets. The main reason zeroconf packets don't get through seems to be routers failing to forward multicast packets.
     
  10. crxssi

    crxssi Veteran TiVo User

    2,791
    0
    Apr 5, 2010
    All I know is that nothing on my machines or network changed. After the update on the TiVo, I get the "!"'s. Same PyTiVo (yours) running on same Linux system with same distro, same Linksys WRT54GL running Toastman Tomato Linux. Prior to the TiVo update there was never a "!"
     
  11. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    Yes, there's a change in the TiVo's behavior. But that doesn't mean you don't have a network problem.
     
  12. djwilso

    djwilso Member

    588
    0
    Dec 23, 2006
    Phoenix, AZ
    Do you know of any way to easily check to see if our router is not forwarding multicast packets? When I say "easily", I mean with some kind of existing (hopefully free) software?

    Thanks.
     
  13. crxssi

    crxssi Veteran TiVo User

    2,791
    0
    Apr 5, 2010
    All I have to say about that is... !
     
  14. slowbiscuit

    slowbiscuit FUBAR

    3,501
    18
    Sep 19, 2006
    In the ATL
    Same here, running Toastman Tomato on a Netgear WNR3500L. I even tried enabling 'efficient multicast routing' in the Routing page with no effect. Not a big deal since PyTivo works fine, but odd that the Elite doesn't get the packets and shows the exclamation mark with greyed-out name.
     

Share This Page