1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PY Tivo help

Discussion in 'TiVo Underground' started by rick123, Oct 4, 2012.

  1. rick123

    rick123 Member

    258
    1
    Dec 8, 2004
    Had to reinstall Windows and trying to re-set up pytivo.

    It has been a long time since last install and I forgot the struggle it was (for me anyway).

    I have the pytivo server running (in the command line box, I start it when needed and don't run it as a service).

    I am also able to see the pytivo control "page" at localhost 9032, which has the Web configuration, to go, and Video Shares/My videos selections.

    I have put a video into my videos folder, and pytivo sees it. pytivo also sees both of my tivo boxes on my network.

    My problem is that pytivo will not send the video file to my tivo box. when I press the "send to tivo" button, I get the following error text:

    No option 'tivo_username' in section: 'Server'

    Traceback (most recent call last):
    File "C:\Program Files\pyTivo\plugins\video\video.py", line 341, in Push
    m = mind.getMind()
    File "C:\Program Files\pyTivo\mind.py", line 285, in getMind
    username = config.getTivoUsername()
    File "C:\Program Files\pyTivo\config.py", line 62, in getTivoUsername
    return config.get('Server', 'tivo_username')
    File "C:\Python26\lib\ConfigParser.py", line 541, in get
    raise NoOptionError(option, section)
    NoOptionError: No option 'tivo_username' in section: 'Server'

    I'm thinking I have failed to configure something properly. When I read the read me notes I come across mention of the creation of a file called pytivo.conf. This file is not in my installation folder, although there is a pytivo.conf.dist file. So I created this file by making a copy and then renaming the pytivo.conf.dist. I moved this file into the program files and thought I had done something right because a "my movies" was now listed on the configuration page, but then clicking on my movies or my videos got a failed to connect screen.

    Anyway, that's where I stand. I would appreciate anyones help with this that has a better understanding of setting up pyTivo than myself.

    Thanks
     
  2. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    In order to "Push" videos to a TiVo, you must add your tivo.com user and password to the global settings.

    Bring up the pytivo web inteface (localhost:9032), click on "Web Confguration" , select "Global Server Settings" and set "tivo_username" and "tivo_password". Save changes.

    You should also create a valid Share. "Add Section", give it whatever name you want pyTivo see is as (it will show up in the NPL of your Tivos with this name) and save changes. Select this new section, specify "video" as type and enter the full path in the "path" field. Save changes and "Restart pyTivo".
     
  3. rick123

    rick123 Member

    258
    1
    Dec 8, 2004
    thank you for your help

    Under global settings, there is port, guid, ffmpeg, beacon, debug,par, ffmpeg-pram, ffmpeg-tmpl, and ffmpeg-wait. Then ther is a user defined settings, which lists a temp path on the c drive.

    I don't see a section to set tivo user name and password?
     
  4. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    I suggest you start over. The first thing you should do is download and install the latest version of pyTivo.
     
  5. rick123

    rick123 Member

    258
    1
    Dec 8, 2004
    I've got it going, thanks. Yes I had started with an outdated version. Unfortunately the wiki site is certainly not written as a guide for dummies, I really struggled with this. Maybe if I can figure out exactly what I did I will write a simplified guide.
     

Share This Page