1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Push problem

Discussion in 'TiVo Home Media Features & TiVoToGo' started by lpwcomp, Feb 8, 2013.

  1. Feb 8, 2013 #1 of 32
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    I am suddenly unable to push anything. All attempts get the following:

    Code:
    INFO:pyTivo.video.video:[08/Feb/2013 18:22:02] Queued "C:\Downloads\TV\Criminal
    Minds\Criminal Minds.S08E14.All That Remains.mp4" for Push to 1300000801E990C
    INFO:pyTivo:127.0.0.1 [08/Feb/2013 18:22:02] "POST /TiVoConnect HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [08/Feb/2013 18:22:02] "GET /favicon.ico HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [08/Feb/2013 18:22:07] "GET /TiVoConnect?Command=QueryCont
    ainer&Container=Downloads/TV/Criminal%20Minds&Format=text/html HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [08/Feb/2013 18:22:07] "GET /main.css HTTP/1.1" 200 -
    INFO:pyTivo:127.0.0.1 [08/Feb/2013 18:22:07] "GET /favicon.ico HTTP/1.1" 200 -
    ERROR:pyTivo.video.video:<error><code>badCookie</code><debug>1</debug><text>Sess
    ion cannot be authenticated; try login again</text></error>
    Note that I tried this on multiple files and multiple TiVos (both local and remote), including a file that was successfully pushed to a remote TiVo last night.
     
  2. Feb 8, 2013 #2 of 32
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Looks like authentication problem.
    With a web browser are you able to login to tivo.com using username & password supplied in your pyTivo.conf?
     
  3. Feb 8, 2013 #3 of 32
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Yes, and this was two different user ids. The remote TiVo is on a different account.
     
  4. Feb 9, 2013 #4 of 32
    aunterste

    aunterste New Member

    3
    0
    Aug 10, 2009
    Since two days - login into tivo.com works fine and I've also verified that the time on the box running pytivo is accurate (mind.tivo.com didn't like that - must be some TLS thing or so).

    Other's having that problem ? There was a time when mind.tivo.com was totally over capacity and lots of people had the problem, but it passed after a day or two.

    Thanks, Andreas
     
  5. Feb 9, 2013 #5 of 32
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Just tried it today and I'm getting the same authentication problem. Additionally, attempting to push using streambaby instead of pyTivo also fails. I don't have TiVo Desktop installed to see if auto transfers is still working there. If someone has TiVo Desktop perhaps they may want to give it a try to see if it's a server issue or if TiVo finally decided to block 3rd party access to mind.tivo.com for pushes.
     
  6. Feb 9, 2013 #6 of 32
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    I have TD installed but it is 2.3 (last version that works on Win2K) and doesn't support pushes.

    If someone does test in on TD and if fails, please also open a thread on the tivo.com forums.
     
  7. Feb 9, 2013 #7 of 32
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    At least the good thing is that wmcbrine recent pyTivo fork (and recent ffmpeg binary) now supports mp4 pulls with ts=on setting, so push is not required to get native H.264 videos on your TiVo series 4 unit.
     
  8. Feb 9, 2013 #8 of 32
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Well, I can't run the latest ffmpeg, but I don't use pushes much for the local TiVos anyway since I prefer full metadata info on the TiVo. It's the push to the remote TiVo that bothers me. I'd hate to go back to using Nike net for that.:eek:
     
  9. Feb 9, 2013 #9 of 32
    cherry ghost

    cherry ghost Active Member

    5,279
    6
    Sep 13, 2005
    Chicago
    TD pushes are not working for me

    Error is


    "Unable to access the account information for the selected DVRs. Pleas try again later"
     
  10. aunterste

    aunterste New Member

    3
    0
    Aug 10, 2009
    I went ahead and tried that - as much as I hate that package. The push through Tivo Desktop still works ....

    So it may indeed be tivo blocking third party apps...
     
  11. lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Dueling posts!
     
  12. sirfergy

    sirfergy New Member

    288
    0
    May 18, 2002
    Same here. I wonder if they changed something on their side, or if it's down?
     
  13. kaspersen

    kaspersen New Member

    1
    0
    Jan 24, 2011
    I'm also having this problem with TD. I can see on my PC that Tivo Server is stopped and can not get it to run. Just got off of the phone with Tivo Support. Was told that a lot of people are having this issue and their top tech group is working on the problem
     
  14. Spenner

    Spenner Member

    88
    1
    Mar 28, 2006
    Same problem for me today, no pushes from pytivo to THD. I get the "badCookie" / "Session cannot be authenticated; try login again" message in my pytivo.log file. Someone post if it clears up for them.
     
  15. jgaver

    jgaver New Member

    31
    0
    Dec 30, 2003
    Salt Lake City
    I have been unable to push since around Thursday. was messing with kmttg and thought something got messed up so I did a fresh install and still have the authentication issues. TD works both directions and I can pull with pyTIVO but cannot push.
     
  16. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    'Same problem here:

    Code:
    DEBUG:pyTivo.mind:__login
    {'cams_security_domain': 'tivocom', 'cams_login_config': 'http', 'cams_cb_password': 'XXXXXXXXXX', 'cams_original_url': '/mind/mind7?type=infoGet', 'cams_cb_username': 'yyyyyyy@zzzzzzz'}
    DEBUG:pyTivo.mind:pcBodySearch
    {}
    
    <error><code>badCookie</code><debug>1</debug><text>Session cannot be authenticated; try login again</text></error>g
    INFO:pyTivo:192.168.1.105 [10/Feb/2013 23:32:02] "GET /TiVoConnect?Command=QueryContainer&Container=%2F&DoGenres=1 HTTP/1.0" 200 -
    DEBUG:pyTivo.mind:pcBodyStore
    {'replaceExisting': 'true', 'name': 'pyTivo'}
    
    <error><code>badCookie</code><debug>1</debug><text>Session cannot be authenticated; try login again</text></error>g
    DEBUG:pyTivo.mind:bodyOfferModify&bodyId=tsn:7460001xxxxxxxx
    {'description': '', 'pcBodyId': None, 'publishDate': '2013-02-11 05:3202', 'partnerId': 'tivo:pt.3187', 'duration': 8042, 'size': 6626362301, 'title': 'The Chronicles of Riddick (Recorded Fri Feb 01, 2013, MAXHD)', 'url': 'http://192.168.1.50:9032/RAID%20Server/The%20Chronicles%20of%20Riddick%20%28Recorded%20Fri%20Feb%2001%2C%202013%2C%20MAXHD%29.mp4?Format=video/mp4', 'bodyId': 'tsn:74600019093843A', 'source': 'The Chronicles of Riddick (Recorded Fri Feb 01, 2013, MAXHD)', 'state': 'complete', 'encodingType': 'avcL41MP4'}
    
    <error><code>badCookie</code><debug>1</debug><text>Session cannot be authenticated; try login again</text></error>g
    ERROR:pyTivo.video.video:<error><code>badCookie</code><debug>1</debug><text>Session cannot be authenticated; try login again</text></error>
    
     
  17. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    Irrelevant for those of us who have Series III machines and / or don't have their files in TS format. I can pull h.264 videos from the server with no problems at all without either, but it blows that vidmgr is down. I needed to transfer a Star Trek episode this evening, and it took me nearly two minutes to get to it in the NPL.
     
  18. wmcbrine

    wmcbrine Ziphead

    10,368
    22
    Aug 2, 2003
    There's no need for the files to be in TS format. pyTivo will remux to TS from any h264-containing format (MP4, MKV, FLV, whatever else there might be).
     
  19. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    Well, that's true for the Premiere, of course. It still takes ages to get to the video unless its name starts with a number, A - C or V - Z.
     
  20. jgaver

    jgaver New Member

    31
    0
    Dec 30, 2003
    Salt Lake City
    Anyone have any thoughts to try? login to tivo.com works fine, quad checked un,pw and MAK. it was working then just quit. just keeps giving me the badcookie - session cannot be authenticated; try login again
     

Share This Page