1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PTV300 User from Australia

Discussion in 'TiVo NZ/Australia' started by hazrd, Mar 17, 2012.

  1. hazrd

    hazrd New Member

    Mar 17, 2012
    Hi all,
    Just picked up a Phillips PTV300 from eBay. was pretty wrapped. Only thing im confused about is... I am trying to connect the aerial to the box which is a coaxial plug, but the box doesnt have the plug for it?? It only has a heap of AV input/outputs and two "cable" like connections labelled RF in and RF out

    I took photos of the back of the unit and the coax plug, but am unable to post them (need 5 posts first ;) )

    Am i missing a part for it or something? Searched high and low for a manual for this unit but all end up going into dead links. Even tried the TiVo "generic" setup trouble shooting page and no luck :(

    Any help would be appreciated!!

  2. zowwie85

    zowwie85 New Member

    Jul 24, 2010
    Phoenix, AZ
    Wow, you bought a project :) Just a few hurdles to overcome... won't run on 240V power, has an American analog NTSC tuner, no ready-made source of guide data...


    Good luck!
  3. classicsat

    classicsat Astute User

    Feb 18, 2004
    Ontario Canada.
    AFAIK, they work on 240V fine.

    The only hardware problem is the tuner, as software modifications to run a PAL tuner and PAL video. With services all digital, it makes no sense change the tuner, just connect a box to the A/V input d make software changes. You would be on your own for guide data, since I believe the system in place for that went away when the proper Australian TiVo was launched.
  4. petestrash

    petestrash New Member

    Mar 7, 2004
    Your post on the OzTiVo forums has also been answered a few days ago.

    You need to buy a compatible set top box to handle the tv signals, and install the current version of the OzTiVo software so it will work in Australia.

    From the photo's you posted it looks like your TiVo had a network card installed at some point. can you open the TiVo and see if it is still there?

    But really you should start at http://www.oztivo.net/twiki/bin/view/Install/PrepareTiVoDisk, then http://www.oztivo.net/twiki/bin/view/Install/GuidedSetup16, and would also be worth looking at http://www.oztivo.net/twiki/bin/view/FAQ/BeginnersFAQ.


Share This Page