1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with Direct Show Dump

Discussion in 'TiVo Home Media Features & TiVoToGo' started by bellbm, Jan 23, 2014.

  1. bellbm

    bellbm New Member

    76
    0
    Dec 16, 2003
    Chicago
    Hi-
    I have used DSD for quite some time to convert tivo files to mpeg 2. Since I got the roamio, the converted files will play ok on my computer, but I can't open them in my video editing software, or transfer them back to my Roamio.
    Anyone else having this issue, or have an idea of what might be causing this, or how to fix it?
    Thanks
     
  2. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    I'm guessing that you're extracting the files as transport streams -- TiVo Desktop's "fast mode" -- and your particular video editor doesn't support that; and you're attempting to send them back via TiVo Desktop. TD will only send back transport streams that are still in the form of .TiVo files, AFAIK, and not the decrypted versions. (pyTivo would allow you to send them back, though.)

    You might try renaming the affected files from ".mpg" to ".ts" to see if that changes your video editor's behavior. (What is it, BTW?) If not, you could manually remux the files to .mpg, via FFmpeg, for example:

    ffmpeg -i filename.ts -vcodec copy -acodec copy filename.mpg

    For future transfers, if you uncheck that box in TD, they should work as before.
     
  3. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,440
    160
    Apr 17, 2000
    Nevada
    Shameless plug....

    VideoReDo can open .tivo files directly, edit them, and save them back to a format compatible with TiVo Desktop regardless of the format. You should give it a try.
     
  4. bellbm

    bellbm New Member

    76
    0
    Dec 16, 2003
    Chicago
    I'm using Pinnacle Studio to edit. I'll take a look at that option in Tivo Desktop (I wasn't even aware it was there). I don't think I've made any changes to the settings since I switched from my Tivo HD to my Roamio. The only thing I did do was stop the automatic conversions for my iphone, since I can now download those through the ap.
     
  5. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    Yeah, it's the default setting, I think. You wouldn't have seen the effect before, because it only works on Series 4 or 5.
     
  6. bellbm

    bellbm New Member

    76
    0
    Dec 16, 2003
    Chicago
    That did the trick!

    Thanks for the fix! Would have probably never figured that out myself!
     
  7. ChinaBull

    ChinaBull New Member

    17
    0
    Aug 11, 2008
    Thanks for the helpful post! I ran into the same problem in which Vegas Studio refused to recognize the video stream. I retried the transfer without "Fast Mode", but it still didn't work.

    ffmpeg fixed it right up for me.
     

Share This Page