1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems recording buffer. Is this a behavior change or a bug?

Discussion in 'TiVo Coffee House - TiVo Discussion' started by anakha000, Oct 21, 2012.

  1. anakha000

    anakha000 New Member

    Jun 17, 2012
    I've encountered what I consider to be a big problem lately. I've tried searching the forums to see if there is any info, but I see conflicting information about whether other people are having the same problem or not.

    The problem succinctly: I'm in the middle of watching a show in the buffer that has finished (in live TV time) and I press Record. Prior to 1-2 months ago, I would get the next show (next in the buffer, current by live TV time) with at least part of the finished show appended at the beginning dependent upon buffer capacity. Now, when I press record it dumps the buffer from before the start of the next show (current in live TV) and I lose what I was watching because ONLY the next show gets recorded.

    With more details:
    Previously (maybe more than 1-2 months ago), if I was watching something in the buffer that had ended (in live TV), I could press record and get everything in the buffer. In fact, regardless of whether I was watching the live show or the finished show before, I used to get everything in the buffer. I know that some people (myself included) didn't like the fact that the Tivo would record extra before the live show, but that was better than what my box has started doing lately. Now, no matter what I do, I can't record anything from the buffer that has ended. If I'm watching channel 99, show A, but I'm not caught up and show B starts, there is no way for me to get show A even though it's in the buffer. When I press record, show A gets dumped (regardless of where I am in the buffer) and only show B gets recorded. I can also only go back in the buffer as far as the start of show B.

    I've tried pressing Rec when I'm on the prior show, and I've tried pressing Info and then Select to record/explore the prior show and neither work. Funny thing is that when I press Info it shows the correct prior show program info, but then when I select record/explore show the popup dialog is asking about the next (live TV) show.

    Is anybody else experiencing this INCREDIBLY frustrating behavior? Anybody know how to work around it?

    Technical info:
    Model: Premiere HD
    Platform: Series4
    Flash: 20-2-1-mr/2012.06.04-1505
    HD Menu SW: b-iris-2-1-mr/2012.05.23-1542

    Please forgive me if this has been discussed somewhere already, but I found conflicting information in recent threads:
  2. steve614

    steve614 what ru lookin at?

    May 1, 2006
    Dallas, TX
    It's very possible that something changed in the software.
    The Premiere is being actively updated (unlike the earlier models).
    Maybe TiVo finally listened to all the complaints about the extra material being saved?
  3. rahnbo

    rahnbo Active Member

    Sep 12, 2010
    I've never known it to work a different way since S2. If I wanted to watch a show in the buffer but another show has started then I must watch the buffered part before it runs out. However, I do seem to recall being able to set up a manual recording with the start time set 1/2 hour before real time and being able to record the buffer. Not sure if that still works but might try later just to see.
  4. anakha000

    anakha000 New Member

    Jun 17, 2012
    I'm guessing what you said is the case, that they listened to the complaints about the extra material being recorded. To fix that at the expense of not being able to record anything you're watching unless it happens to be in the current time slot is crazy IMO. Does anybody have a premiere that can confirm they are having the same problem?

    That's a good idea and I'm going to try it as soon as I get a chance. Seems to be a painful way to accomplish something simple though! I know that as of a few months ago on the same premiere I could just press Rec when watching a show in the buffer and it would get recorded. The title and description in my recordings would be of the later program and the recording wouldn't stop until the later program ended, but at least I would get the buffer as well.
  5. rahnbo

    rahnbo Active Member

    Sep 12, 2010
    I just tried it with manual recording and it did work. So long as you never change channels or hit the record button it should work. Once you do either of those two things the buffer is lost. If your buffer is on channel X and the next show is on channel Y it wouldn't work, both most be on the same channel considering how many tuners you have available and are not recording. So what I did to test is let Family Guy start buffering at 2am. Black Thunder followed at 2:30. Went straight in to the create a manual recording at 2:31 and set the recording to record from 2am to 3am. It recorded the entire buffer of Family Guy as well as the new show in one recording labeled "Family Guy." There was a notice on the screen that the recording was already in progress. I acknowledged that and it works!
  6. SixString

    SixString New Member

    Jan 7, 2003
    I just posted a similar problem yesterday in the HD forum!

    For me, at least, it's not that simple. Sometimes I get the behavior you describe (recording starts at beginning of Show B, losing tail of Show A); sometimes I get the entire 30 minutes, including the tail of Show A; and other times (rarely) I get far more than the 30 minute buffer. Yesterday, I got not only the tail of Show A, but the entire program before it! One hour and nineteen minutes prior to where I hit Record, which was half-way into the 30 minute buffer!

    I've never been able to figure it out. Some say the Tivo has a buffer of a particular size in GB, rather than minutes. But that doesn't explain why sometimes it clips out the previous show and other times it doesn't.

    I'll try the manual record method. Thanks.
  7. eplanes

    eplanes New Member

    Dec 6, 2012
    I get the same behavior on Series 4 20.2.2....
    To me it seems like a bug, because I remember they touted that functionality as a feature in the past and I loved it.
    I also get a wierdness FastForward on a live feed, when you get to real time if you press pause to let it build up like I do, it will continue to play even though the markers show paused.
  8. celtic pride

    celtic pride Member

    Nov 8, 2005
    I 've been having trouble with fastforward as well ,2 arrows is way to fast!! i can only do 1 arrow at a time or always overshoot and for a while on fast forward i would hear the volume on fast forward with the sound sounding like the chipmunks. very frustrating now when i fast forward .

Share This Page