1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Premiere XL Search Results off by one hour

Discussion in 'TiVo Premiere DVRs' started by eddieb187, Jun 6, 2011.

  1. Jun 6, 2011 #1 of 33
    eddieb187

    eddieb187 New Member

    79
    0
    Jan 16, 2009
    Hudson...
    All my search results are off by exactly one hour. I noticed this last night when searching to record a movie on HBO. For example:
    I just did a search for The Daily Show. I type in Daily and the first result is The Daily Show and it shows: Mon 6/6 10:00pm??? The Daily Show is on at 11PM.
    Every search result I get is behind by one hour.
    The time on my Guide and Info screen are correct though. As is the time in my System Information screen. Maybe the search did not change for Daylight Savings?
    Anyone else notice this issue?
     
  2. Jun 7, 2011 #2 of 33
    rahnbo

    rahnbo Active Member

    1,090
    1
    Sep 12, 2010
    Florida
    Odd. Could the 10pm showing be a repeat? Do you live in one of those places where you're near the time line or that the time line circles around? I was watching that show "How the states got their shapes" the other day and in some places time can be a real PITA. Most importantly, are your shows getting recorded properly? I think their is a tick somewhere in Tivo setup where it asks you if your locale observes daylight savings time.
     
  3. Jun 7, 2011 #3 of 33
    eddieb187

    eddieb187 New Member

    79
    0
    Jan 16, 2009
    Hudson...
    No.
    All search results are exactly one hour behind.
     
  4. Jun 7, 2011 #4 of 33
    L David Matheny

    L David Matheny Active Member

    1,588
    1
    Jan 29, 2011
    SE Ohio
    Experts: Is there something in his TiVo account that tells the TiVo box what time zone he is in?
     
  5. Jun 7, 2011 #5 of 33
    atmuscarella

    atmuscarella Active Member

    5,717
    16
    Oct 11, 2005
    Rochester NY
    Should be his zip code.
     
  6. Jun 7, 2011 #6 of 33
    johnnygyno

    johnnygyno New Member

    7
    0
    Sep 6, 2004
    Any chance the zip code was typed incorrectly?
     
  7. Jun 7, 2011 #7 of 33
    eddieb187

    eddieb187 New Member

    79
    0
    Jan 16, 2009
    Hudson...
    Definitely not the Zip Code. I just setup a new XL.
    I have two Premieres XLs and one TiVo HD.
    Both XLs have this glitch but the TiVo HD does not.
    This leads me the think it has to do with the latest 14.8 update.
    Only the search results when you search from TiVo Central.
    I just called TiVo Support and reported it.
    The tech agreed it was probably the latest update.
    I was just curious if anyone else has noticed this.
    Apparently not.
     
  8. Jun 7, 2011 #8 of 33
    rahnbo

    rahnbo Active Member

    1,090
    1
    Sep 12, 2010
    Florida
    Go it. But are the shows being recorded properly despite the search results being an hour off?
     
  9. Jun 7, 2011 #9 of 33
    eddieb187

    eddieb187 New Member

    79
    0
    Jan 16, 2009
    Hudson...
    Yes I tested that tonight.
    I scheduled Knight and Day which the search results had at 8pm.
    I did record Knight and Day which was actually on at 9pm.
     
  10. rahnbo

    rahnbo Active Member

    1,090
    1
    Sep 12, 2010
    Florida
    OK, good you're getting the right recording at least. I documented a very similar bug and reported to Tivo many months ago which is why I'm asking you leading questions. The YouTube link is here for my documented bug:

    http://youtu.be/a6hKv7EvsSE

    I reported this along with the video to YouTube. They never fixed it. They just gave me some line about we'll fix it someday. I can still reproduce it sometimes. I suggest you document and report it as well. My theory is that there is some customer facing code in the HDUI either adding +1 or subtracting a -1 somewhere it shouldn't be as displayed to the end user. Fortunately the main scheduler is dealing with this and getting the correct recordings. The problem I see is when I try to schedule another program that appears to conflict with with the program that is +1 or -1 hour off. If the new program is correct lets say 8pm and the wrong + or - an hour then it it going to cause problems saying there will be no tuner available or overwrite another program. Sometimes it says it will overwrite itself which is always a good chuckle. I usually give up and go to the SDUI where the bug doesn't seem to exist or do it all via Tivo.com.

    PS, how is Knight in Day if you watched it yet (without spoilers, of course)? I have it recorded but haven't got around to it yet.

    BTW, in that video it was actually a 12 hour difference where it seems AM and PM got fungled by Tivo.
     
  11. L David Matheny

    L David Matheny Active Member

    1,588
    1
    Jan 29, 2011
    SE Ohio
    I've noticed that in System Information my Premiere says "Daylight Saving: Inactive", yet we are surely using Daylight Saving Time now. What is that data value used for? What does yours say?
     
  12. eddieb187

    eddieb187 New Member

    79
    0
    Jan 16, 2009
    Hudson...
    I watched your video. Pretty strange. But at least the software is intelligent enough to get the event recorded anyway.
    I did watch Knight and Day. Pretty good. Lots of action.
     
  13. eddieb187

    eddieb187 New Member

    79
    0
    Jan 16, 2009
    Hudson...
    I just looked and my Premiere says "Daylight Saving: Inactive" as well.
    Maybe that's the problem?
    Are your search results the correct time for you time zone?
     
  14. L David Matheny

    L David Matheny Active Member

    1,588
    1
    Jan 29, 2011
    SE Ohio
    Well, I'll be .... I hadn't done much searching while in the HDUI, and I thought my times were OK, but they're not. I just did "Find TV, movies & videos" / Search, and the times are indeed one hour ahead of the actual time (i.e., News at Noon shows 11:00 am). I don't think they're off in the SDUI, but I think I'll wait to switch back until after a couple of recordings finish.

    EDIT: OK, I'm now back on the SDUI (OTA only, 14.8.U2 software), and times are correct using Find Shows / Search by Title. System Information still says "Daylight Saving: Inactive".
     
  15. Wangstang

    Wangstang New Member

    1
    0
    Jul 2, 2011
    Triangle...
    So I have a standard Premiere with lifetime service and had been viewing in the SD UI and switched over to the HD UI last week. I immeadiatly noticed the scheduling was all off by an hour in the HD UI and was thinking that Tivo would fix it with an update but that hasn't happend.

    The daylight savings time option is marked as inactive on my box too.

    I also have a tivo series 2 with lifetime service and it does not have this issue.

    Any way to elevate this issue with in Tivo's customer support or was a solution found?

    Thanks
    Wes
     
  16. rahnbo

    rahnbo Active Member

    1,090
    1
    Sep 12, 2010
    Florida
    That would be nice. You could call and try but they have a habit of getting you off the phone in the nicest possible way. I ran in to this again last night and took another video. It was 3am and I wanted to record a show that search said came on at 3:10am. When I tried to record it it was "conflicting" with other shows but when I looked at the grid and zap2it it actually wasn't on until 4:10am (+1 hour). I ended up getting the show but man what a pain and waste of 10 minutes. Tivo Premiere has so many bugs I forgot about this one and even the video I took months ago. I even took another video proving the point until I went to upload it. I then realized I already have been through this issue, documented it, commented on it, etc.
     
  17. TerpBE

    TerpBE Go Terps!

    682
    0
    Jan 23, 2003
    Philly 'burbs
    I'm having the same problem. Mine is also showing Daylight Saving: Inactive.

    I only noticed it began about a week ago, but it's possible it has been going on longer.

    [​IMG]
     
  18. rahnbo

    rahnbo Active Member

    1,090
    1
    Sep 12, 2010
    Florida
    There are only 2 reliable ways I know to do this. One is to avoid any HDUI components when scheduling a program and #2 is to schedule it from Tivo.com or m.tivo.com from your mobile device. This is a day one HDUI only problem I believe that Tivo has yet to address along with many other issues.
     
  19. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    The only place I've seen this problem is when I select a show from "My shows", the recording information on the right side is off by an hour. Both guides are correct and the info display when playing the program is correct. Everything is correct in the SD menus.

    I haven't had a scheduling or recording problem. I was under the impression that TiVo was supposed to keep all of its info in UTC and only converted to local time for display purposes. If this problem is causing scheduling problems, this is a sign of really sloppy programming and testing.
     
  20. rahnbo

    rahnbo Active Member

    1,090
    1
    Sep 12, 2010
    Florida
    I also see this issue where it gets AM and PM backwards documented in the video below which I recorded in October last year and is still a problem. It may not cause you to miss a program but it can lead to some serious "say what?" situations when you're trying to record something.

    http://youtu.be/a6hKv7EvsSE
     

Share This Page