1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Premiere+Old TV+Pytivo -- cannot stream since 16th

Discussion in 'TiVo Premiere DVRs' started by moose53, Feb 19, 2013.

  1. moose53

    moose53 New Member

    120
    0
    Aug 30, 2011
    I have a very-very old single-def TV and a Tivo Premier. All of this stuff worked beautifully together until the 16th.

    I cannot stream any PlayOn show to my television. All shows go into the "To Do" list but never move to "My Shows". I've restarted Tivo; unplugged/restarted Tivo; reinstalled PlayOn and PlayLater. No joy.

    PlayOn support told me to disable my anti-virus. No joy.

    I've seen other postings about Tivo Desktop and kmttg and Tivo To Go not working ... something to do with a date and an expired cookie. I don't have any of those. But, it is interesting that their problems all started after 16th, just like mine.

    I've tried installing Tivo Desktop. Don't like it. And it seems to block my PlayOn from showing up on my television.

    I would have never bought lifetime subscription to PlayOn if I had known I was going to have to depend on antiquated crap software that never gets updated. A lot of the PlayOn scripts are not working; but, that's a whole nother itch fest.

    Right now, I just want to get PlayOn streaming again. I've tried the things mentioned for the other problems ... change the computer date, modify the Tivo desktop cookie. No joy.

    PlayOn support is no help at all. But, then, they've never been.

    Right now I've got software I can't use. And downloaded TV shows on my computer that I can't access.

    Anyone have any ideas why PlayOn and pyTivo (I use pytivo-jkasyan-fork) are no longer working??

    Thanks.

    Barb
     
  2. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
  3. moose53

    moose53 New Member

    120
    0
    Aug 30, 2011
    Thank you.

    I did exactly what dlfl suggested:

    Everything works beautifully now. I'd increase your allowance, if I was in charge of it [​IMG]
     
  4. RJV

    RJV New Member

    8
    0
    Sep 4, 2003
    Also did exactly what dlfl suggested and successfully recovered Playon functionality.

    Note: While the problem existed, no transfers to the Tivo were successful after a failure to transfer using the Playon interface occurred. A Tivo Reboot would recover functionality, but only until the next failure using Playon.

    A big thanks to dlfl.
     
  5. poppagene

    poppagene User

    790
    0
    Dec 29, 2001
    I tried the above dlfl fix with no joy. I've also tried installing a fake cookie, changing the date on the pc, uninstalling playon and reinstalling an earlier version.

    Any other suggestions?
     
  6. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    The fixes for the cookie problem (aka error 400 in the ToGo plugin) aren't relevant to the PlayOn problem. Also, "installing a fake cookie" has no meaning in a pyTivo context, so what are you talking about? :confused:
     
  7. poppagene

    poppagene User

    790
    0
    Dec 29, 2001
    As you are very well aware (I've read enough of your recent posts to confirm this) there seem to be a bunch of related or unrelated problems with file transfers involving tivos and (you may not be aware) there have also been a lot of rude and indignant replies complaining that there are gazillions of posts on these problems and the issues have been solved. Rather than offer advice or ask useful questions, they often provide a link to a post that may or may not help.

    Some have solved transfer issues by setting the pc click back. Some have solved issues by seeting a fake cookie. Some have used task manager to get the mediamall pid in order to modify the playon.py file.

    I can transfer files from premiere to premiere fine. I can transfer files to and from tivo desktop fine. I can't transfer files from playon to tivo at the current time.
     
  8. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    That doesn't answer my question. Are you talking about "installing a fake cookie" in TiVo Desktop? Or what? Please understand, there is no interaction at all between TiVo Desktop and pyTivo.

    Again, the problem of being unable to transfer files from the TiVo to the PC (which is due to the TiVo sending out pre-expired cookies) is absolutely unrelated to the problem of being unable to use the PlayOn plugin in pyTivo. They're not "related or unrelated", they're unrelated, period.
     
  9. poppagene

    poppagene User

    790
    0
    Dec 29, 2001
    Cannot stream or transfer files with playon and pytivo. I hope that eventually someone smarter than me will get it all working again

    pytivo by itself works fine for tranferring file s to tivo.
    playon web videos list is viewable from tivo, but any attempt to watch goes directly to "To Do"
    playon web content viewable just fine with sony bluray, xbox 360, pbo, and samsung led tv.

    Both Playon and pytivo are working as originally intended, just not with each other (which means for me that I can;t watch playon web content on tivo which is my primary use for both playon and pytivo)

    Update: Back in business.
    I reinstalled python 2.73 and pytivo using the latest from wmcbrine.

    I went through the "pyTivo for jython/windows installer thread" at the pytivo discussion forum
    I installed django (don't know if it was needed) and dowloaded and installed dlfl's zip file http://pytivo.sourceforge.net/forum/download.php?id=568 and set the replace port to 62478.
    After rebooting everything, I'm transfering playon webcontent to my tivo.
    Thanks to all especially those that write the code that makes my tivo experience richer.
     
  10. moose53

    moose53 New Member

    120
    0
    Aug 30, 2011
    Here we go again: they updated the Playon software early this morning.

    Again, it's not working.

    I changed:

    From: Line 48 in playon.py was: path = path.replace(':54479',':62478') [which worked from February to yesterday]

    To: Line 48 in playon.py was:
    path = path.replace(':54479',':52478')

    Can't get it to work. I get one of the two following results:

    (1) I cannot stream any PlayOn show to my television. All shows go into the "To Do" list but never move to "My Shows".

    or

    (2) I get an error: Not transferred because of an error. 1. ...copy protected. 2. ...format not supported by the Tivo service. 3. ... file has been moved or deleted from Internet TV - Playon.

    None of what happens in the second instance seems to make any sense at all. I've tried multiple shows ... shows from Hulu, from my computer's hard drive, and shows from One Channel. No joy from any of it.

    I did at one point this afternoon get an error from Flashplayer, so, I uninstalled and reinstalled both of those (FireFox and IE).

    If Playon is going to change the port that they use, why can't they tell us in the release notes. AARRGGHH!!

    I've spent hours working on this. Uninstalling. Reinstalling. Seriously getting ready to throw the whole thing in the pond and start reading books again. Not worth all this aggravation.

    Anybody got any ideas?? It would be helpful if something in readable language went into the logs so that you could run down exactly what the problem is...

    Thanks.
     

Share This Page