1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Premiere and expander issue found and then solved

Discussion in 'TiVo Premiere DVRs' started by dtyree, Aug 19, 2012.

  1. dtyree

    dtyree New Member

    Dec 24, 2010
    I had researched about a year ago about adding the WD expander drive and noticed related comments saying that esata cable in the box was not suitable for some reason.
    I went ahead and bought the drive and a spare esata back about a year ago. I hooked up the expander with the spare cable and everything went fine. I threw the unused esata cable from WD in my junk computer parts box. I used it a few times hooking up other external drives to my laptop and is always worked. Kinda odd, i mean it's just a cable. But i went with the comments and experences of the assorted forums and spent the few bucks just be safe and never plugged the WD into my Tivo.

    Fast forward to about week ago, my dad was looking at getting the WD expander for his Premiere and I mentioned to him about the cable situation.
    He went ahead and ordered the expander but didn't get another esata cable. i said ok fine lets try the new esata cable from WD.

    No luck with getting dads Tivo to see the expander with the cable in the box.

    So i grab the old WD esata cable from my junk box and it works first time with no problem.


    When i get a chance i'll hook an external drive to my laptop with the new WD esata cable and see what happens.

    last i heard, there is only one kind of esata cable.

    But i guess it boils down luck on getting a cable from WD that will work with a Tivo.

Share This Page