1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC sleep mode and Tivo server

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Anonymike, Jun 25, 2013.

  1. Anonymike

    Anonymike New Member

    7
    0
    Apr 22, 2013
    I have a Desktop PC that has archived shows with a wired connection to my Tivo Premiere XL. I have the PC set to go into sleep mode after a while (saving the Earth -you're welcome) which should be fine. I wiggle a wireless mouse near my TV in the other room, and the PC wakes up.
    I'm using Tivo desktop and for some reason, the woken computer doesn't show up on the Tivo "Now PLaying" screen unless I manually go to my PC and click "pause server", and then re-start it. Then it shows up instantly. But I'm curious if there's any way to not have to restart the Tivo server after sleep mode on the PC for it to show up in my Now Playing list.

    Thoughts? Comments? Insults?
    BTW - I've tried alternatives, and Tivo Desktop is the best software for me - so kmttg is not a solution.
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay

    6,739
    9
    Apr 6, 2000
    SF Bay Area
    KMTTG is not a Tivo server. An alternative to Tivo Desktop is PyTivo. you can just have the PC turn off the monitor (or blacken the screen) when its idle and not use sleep mode.

    Another idea is to setup a Network Access Storage (NAS) on your network with PyTivo installed. This maybe a better 24/7 solution to get access to your videos albeit more expensive.
     
  3. ggieseke

    ggieseke Active Member

    4,031
    12
    May 30, 2008
    If you have Windows 7 you can do some pretty tricky things with Task Scheduler by creating a task that's triggered by specific events. Look through your event logs for the specific source and event ID that happens when your PC wakes up, then create a task that would run a batch file.

    The batch file could have the following two lines:

    "C:\Program Files (x86)\TiVo\Desktop\TiVoServer.exe" /stop

    "C:\Program Files (x86)\TiVo\Desktop\TiVoServer.exe" /service /registry /auto:TivoServer

    You may need to adjust the actual path for your system. Leaving TiVoServer alone and just restarting Bonjour or TiVoBeacon might work too.
     
  4. msmart

    msmart New Member

    228
    0
    Jan 2, 2007
    Are your TiVo files on an external drive that may not "wake up" as fast causing the TiVoServer to think it's still offline?

    I agree with ThAbtO, just turn off the monitor rather than use sleep mode, it's what I do.
     
  5. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    It is a generally bad practice to ever sleep a server.

    Not so much. Depending on the program requirements, a dedicated server can use as little as 10W, especially for something like pyTivo serving native files.

    Bad move.

    Simple solution: Use neither sleep mode nor TiVo Desktop.

    Well, OK, if you insist...
    You're ugly, and your mama dresses you funny. ;)

    I find that impossible to believe. TDT is such a lousy, badly broken program, I cannot imagine it being best under any circumstances. Not to put too fine a point on it, but you just yourself told us all it isn't meeting your needs.

    'Not surprising, since kmttg does not handle the functionality you seek, at all. Kmttg is a TTG utility. You are talking about GoBack functionality, which is not what kmttg does.
     
  6. wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    Lately I run pyTivo on an old SSD netbook, with two large external USB drives for storage. The drives sleep most of the time, while the server stays up.

    The TiVos are very finicky about recognizing servers on the network. There's probably no chance to do it the way you want, sorry. Although perhaps you could try using the "Manually add a server" function on the TiVos, and giving up auto-recognition?
     

Share This Page