1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Roamio Plus won't stream OOH

Discussion in 'TiVo Roamio DVRs' started by David Platt, Jan 5, 2014.

  1. David Platt

    David Platt !Texas TCF Club

    Dec 13, 2001
    I've been troubleshooting a problem with TiVo tech support concerning a brand new Roamio Plus and OOH streaming. I have an iPhone on iOS7 with the latest version of the TiVo app installed. I have a new Roamio Plus updated to the latest software. In-home streaming and downloading works flawlessly, but neither OOH streaming or downloading will work when connected to a stable wifi connection. When I select a show to stream, I get the standard "setting up your streaming session" message, then a vague error message telling me there is a problem with my streaming device. Downloading does not appear to be working either; any attempted OOH download hangs at 0%.

    Phone support at TiVo has been next to useless. Any suggestions?

    Relevant info:

    ISP: Frontier FiOS 25Mbps down/25Mbps up

    Router: Apple Airport Extreme

    Roamio Plus SW version: 20.3.8

    TiVo App version: 3.2.2, OOH streaming enabled via Streaming setup
  2. caughey

    caughey Member

    May 26, 2007
  3. mjcxp

    mjcxp New Member

    Nov 22, 2013
    I get this error a ton too. I am only connected via WiFi so I figure it is due to that. In home streaming works flawlessly.
  4. dbattaglia001

    dbattaglia001 New Member

    Feb 9, 2003
    Are there restrictions on the wifi you connect to OOH? 95% of time I get an error when trying to connect through my work wifi, but works flawlessly at every other out of home wi fi connection.
  5. spinjockey

    spinjockey New Member

    Nov 23, 2007
    I set up my Romio Plus on Saturday and got that error when trying OOH for the first time later on Saturday. (In home streaming was working.)

    Sunday I forced a service call, rebooted the Tivo, and ran setup again.

    Now I'm no longer getting the same error, now it's "there was a problem connecting to your streaming device".

    Haven't tried service desk, figured I find something on the board.

    FYI streaming/downloading works fine on local network (neither via remote wifi nor VPN).

    Note that my work blocks some connections to my home system. (I've had to use port 80 for ssh as port 22 is blocked.)
  6. snoopdogg1

    snoopdogg1 New Member

    Sep 24, 2008
    Same problem. I figured it was because I am on Time Warner, and they lock down their recordings. I can't even download most shows on my HOME network from my Roamio Pro to my iPad. OOH, I can't get anything.
  7. soobaerodude

    soobaerodude New Member

    Nov 8, 2013
    I have a Roamio Basic with a separate Stream device. My Roamio and Stream are connected to the same Wireless N router that acts as a wireless bridge to the main wirless router and cable modem upstairs. Like others, I can stream to my iPhone on my home network, but not when I'm OOH on wi-fi.

    I thought my problems had to do with the wireless bridging, but it doesn't seem like anyone can get OOH streaming to work.
  8. DeltaOne

    DeltaOne Mount Airy, MD

    Sep 29, 2013
    I've done OOH streaming a few times. Just tried it now here at work and it worked fine. So it does work for some of us.
  9. sldozier

    sldozier New Member

    Aug 7, 2005
    I tested OOH streaming yesterday and it works fine. I have seen on occasion where it pops up an error when attempting to OOH stream as well though, so I'm not sure it's an exact science or completely without issues. Of course, I don't know the nuts and bolts of how OOH is accomplished, so I don't have any definitive clues on why it gave me errors on a few attempts, but has worked successfully on other attempts.
  10. spinjockey

    spinjockey New Member

    Nov 23, 2007
    The short story is that it appears that the Tivo needs UPNP enabled on the router but not to map/forward ports! I suspect that Tivo is only using UPNP to get the WAN IP.

    By default I've disabled UPNP on my router due to security concerns (I don't like applications punching holes in my firewall w/o my knowledge). From the http://www.tivocommunity.com/tivo-vb/showthread.php?p=9866909 discussion I saw some post about port mapping so I figured I'd try to figure out which ports were mapped and statically map them.

    After enabling UPNP port mapping (called "Connection control server" on my draytek router) I noticed that the Tivo wasn't opening ports on the router. Sure enough streaming still worked after turning off the that option but leaving UPNP enabled and I was unable to map ports via UPNP. (After a bunch of googling I believe it's similar to "config upnp config option enable_natpmp" in openwrt.)

    Furthermore turning OFF UPNP prevented the iPad from connecting to the stream OOH. After turning UPNP back on and restarting the iPad Tivo app it worked again.

    I played around in the sysinfo page (http://<tivo stream address>:49152/sysinfo/) and if the "Proxy Enabled" is unchecked then streaming doesn't work (the default is checked). Note my page looks different than the one posted on the OOH Streaming Countdown thread. I believe it was changed in the Tivo update.

    Also I'm on a corporate network that blocks a bunch of outbound ports to my house (e.g. ssh over port 22 doesn't work so I had to remap it to 443) so I suspect this setup will be pretty robust for most ISPs.

    Also note that my iPhone doesn't stream yet (OOH download worked) though I suspect it's because I only ran the setup once on it... (I'll try that early next week).
  11. soobaerodude

    soobaerodude New Member

    Nov 8, 2013
    Thank you! I enabled UPnP on my router and was able to stream OOH on my iPhone. I wonder why this isn't mentioned in the Tivo Stream OOH support page?
  12. patrickthickey

    patrickthickey New Member

    Sep 4, 2002
    UPDATE: this link includes a white paper on the vulnerability of the UPnP protocol used (?) by Tivo to enable Out of Home Streaming. Apparently, quite a few folks use this, and "Universal Plug and Play" may be at risk.


    A couple of thoughts...

    1. - this does not PLAY well with the notion of streaming out of home.
    2. - the silence from Tivo is deafening. I suspect this feature, cool as it may be, might need to include a release waiver sparing Tivo from any liability pertaining to the significant security implications. Just saying...

    Some firewalls do not allow UPnP to be "enabled". Mapping ports?... any ports opened represent a "potential" issue.

    I can find no documentation from Tivo pertaining to this because if they reveal the ports they are using, OOH streaming becomes a backdoor to be hacked. I believe UDP 1900 is the only "standard" port associated with it? Hopefully someone in Tivo Engineering can chime in....this issue will bite Tivo in the rear until it is fully documented and made clear.

    I am not saying it matters - that of someone gaining access to your Roamio - and what are the odds and why would a consumer DVR be a target? BUT...I'd like to hear how Tivo plans to address this.

    If you happen to use a business grade firewall, you need to ascertain the ports Tivo uses and map them. If you have a commodity firewall which allows the service to be enabled/disabled - you should be perfectly fine. Enable it. Why not? But it is not "secure", according to how I am reading things. Neither is a home security video camera but many people use them without issue. Happy to hear other's thoughts.

    It SHOULD be in the Tivo FAQ - I sent my feedback to them. The FAQ is simplistic. Networking is not that.

    I'm not criticizing specific firewalls - some are built for home/commodity use and others are for business, that's all. Business typically has more skin in the game insofar as security and poking holes (dynamic or static).

    Thanks to those of you who specifically identified this Open Source protocol being used by Tivo.

Share This Page