1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jan 25, 2010 #1801 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    There were some fixes to ffmpeg ipod encoding profiles in version 7g. Install version 7g and make sure to use the "encode" folder that comes with that version.
     
  2. Jan 25, 2010 #1802 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    Every version has had that capability for some time. I've only been doing it for about 18 months, but I know folks have been using auto transfers for much longer.
     
  3. Jan 26, 2010 #1803 of 10413
    miguelakiira

    miguelakiira New Member

    37
    0
    Jan 26, 2010
    HI thanks for making this useful program!
    The issue I have is in windows 7 64 bit. I am using kmttg p7g.
    I run kmttg as a service. I set the service with a user/login. I started the service. Kmttg will read the dvr playlist once and start downloading, but it never refreshes the list. I set kmttg check tivos interval to 15 (minutes). Also, Kmttg will sometimes download a series of files as 1k files. Any ideas? TIA
     
  4. Jan 26, 2010 #1804 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Check or post relevant portions of your auto.log file which has details about what is happening in service mode.
    For the 1k files that is likely problem with TiVo web server refusing to allow downloads for a period of time. The auto log file should have corresponding error messages for failed downloads but you can also open the files with a text editor to see the error message contained therein. Rebooting your TiVo usually fixes the bad state the web server can get in at times.
     
  5. Jan 27, 2010 #1805 of 10413
    sender_name

    sender_name I remember XM 202!

    227
    0
    Feb 11, 2005
    Northboro Ma
    which should take less time to encode to handbrake television (hb_television)
    a .tivo file or a .tivo file saved as a mpg via VideoReDo...
    i cut the commercials from my .tivo with VideoReDo and then i reencode to the hb_television...which should work faster?
     
  6. Jan 27, 2010 #1806 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    I don't really understand the question. I don't think handbrake accepts TiVo files as input so you have to feed it mpeg. Your flow of TiVo->VRD commercial trimming->mpeg->handbrake looks like the optimal to me.
     
  7. Jan 27, 2010 #1807 of 10413
    sender_name

    sender_name I remember XM 202!

    227
    0
    Feb 11, 2005
    Northboro Ma
    Oh ok...It just seemed like for some reason a conversion of my show took forever yesterday...like 4 hrs to covert a 43 min mpg2 to hb_television...I wonder if i did something that was overkill in the kmttg settings...I'm going to time the next one. I have a Vista ultimate, quad core q9550 and 4 gb of ram...so it's not a resource issue..thanks
     
  8. Jan 27, 2010 #1808 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    h.264 encoding tends to be very slow and handbrake in general is slow compared to ffmpeg.
    Make sure that under kmttg configuration->General you set encoding cpu cores > 1 to take advantage of multi-core CPU.
     
  9. Jan 27, 2010 #1809 of 10413
    abnersnell

    abnersnell New Member

    18
    0
    Mar 3, 2002
    595 is available! I am ready to test! ;-)
     
  10. Jan 27, 2010 #1810 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Everything is working beautifully in development code. Aside from VRD encoding support there are a bunch of other good changes related to VRD tasks and also some long overdue kmttg GUI enhancements (stretchable panes). So this next release coming out soon is shaping up to be a good one.
     
  11. Jan 27, 2010 #1811 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    Ever since seeing this, I've been testing the new Mac tools that I packaged for you. I haven't been seeing any issues with the Mac version of aac. Can you be a bit more specific about the issues with the aac on the Windows side?

    Also... If that is still available, I could throw together a Windows VM for comparison.
     
  12. Jan 27, 2010 #1812 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    I have been using handbrake because I get a good quality encode that works on both AppletTv and my iPod. Is their a reccomended profile for ffmpeg that will work on both devices?
     
  13. Jan 27, 2010 #1813 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Which handbrake profile are you using? The ffmpeg ff_ipod_high_res and/or ff_ipod_low_res will probably work fine for both, obviously the high_res giving better quality. Just make sure you are using 0p7g release and the "encode" folder that comes with that release since there were fixes to those profiles.
     
  14. Jan 27, 2010 #1814 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    It is likely source mpeg file specific and it's not the easiest thing to pick out without earphones. I put encoded recordings on my portable player when going to the gym. I noticed twice that when playing back the recordings that were generated using the new ffmpeg annoying pops in the audio every few seconds. Seeing as I had switched out to new ffmpeg I reverted back to older one using libfaac and generated mp4 from same source and played it on my portable player and that one came out fine. That was the case for 2 other source recordings as well from same channel (same news program).
    I can see if I can generate a short source clip that you can encode from and an accompanying mp4 encoding with the audio glitches, but I'm fairly convinced it's a bug in the source, so doesn't matter what platform you use. (As I mentioned I tried several of newer ffmpeg builds that spanned the last 6 months and all had the same problem).
     
  15. Jan 27, 2010 #1815 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI

    I am currently using a handbrake "universal" profile. You don't supply this one but I munged it together from the handbrake ui. It works pretty well but the encode is really slow. Wondering, if ffmpeg might be faster.
     
  16. Jan 28, 2010 #1816 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    There is little doubt the ones I mentioned will be faster. If you have multi-core CPU make sure to turn set the kmttg setting appropriately to use them as that will help.
     
  17. Jan 29, 2010 #1817 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    v0p7h version is now released. Please see release notes for details:
    http://code.google.com/p/kmttg/wiki/release_notes

    NOTE: This release was updated to use newer ffmpeg build which also required changes to encoding profiles. So install kmttg to a fresh location to make sure you get the up to date versions of 3rd party tools and "encode" folder. For auto transfers setup you can copy your auto.ini file from previous installation folder over to new folder so you don't have to redo auto transfers.
     
  18. Jan 29, 2010 #1818 of 10413
    abnersnell

    abnersnell New Member

    18
    0
    Mar 3, 2002
    Awesome! I got everything situated with this release but it complains when attempting to grab VideoRedo encoding profiles. Do I need to rename the VideoRedo exe in TVSuite4? I am running 595. I think the exe's are different names from VideRedoPlus vs VideoRedoSuite.

    Refreshing encoding profiles
    C:\Users\Abner\AppData\Local\Temp\VRD8171412680062598749.vbs(2, 1) WScript.CreateObject: Could not locate automation class named "VideoReDo.VideoReDoSilent".
    Encountered problems obtaining encoding profiles from VideoRedo

    Thanks for the hard work and dedication to this project. My children are growing up in a house without commercials and the WAF is very very high! ;-)

    DOH! Should have read the Wiki first! Works perfectly after running VideoRedo as Administrator in Windows 7.
     
  19. Jan 29, 2010 #1819 of 10413
    miguelakiira

    miguelakiira New Member

    37
    0
    Jan 26, 2010
    Moyekj,
    Thanks for your reply. KMTTG is reliably refreshing the playlist. I have been reading the auto.log quite a bit, it is indispensable! Here is the message I get when a transfer fails:

    2010_01_29_15:06:19 >> DOWNLOADING K:\Video Workbench\MSNBC News Live (MSNBC_23 01_29_2010).TiVo ...
    2010_01_29_15:06:19 C:\Users\Akiira\Desktop\kmttg\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Akiira\AppData\Local\Temp\cookie6646847331887724329.tmp --url ___://192.168.137.56:80/download/MSNBC%20News%20Live.TiVo?Container=%2FNowPlaying&id=189440 --output "K:\Video Workbench\MSNBC News Live (MSNBC_23 01_29_2010).TiVo"
    2010_01_29_15:06:27 NOTE: K:\Video Workbench\MSNBC News Live (MSNBC_23 01_29_2010).TiVo: size=0.00 MB elapsed=00:00:08 (0.00 Mbps)
    2010_01_29_15:06:27 ERROR: <h2>Server Busy</h2>
    2010_01_29_15:06:27 ERROR: Download failed to file: K:\Video Workbench\MSNBC News Live (MSNBC_23 01_29_2010).TiVo
    2010_01_29_15:06:27 ERROR: Exit code: 0
    2010_01_29_15:06:27 ERROR: % Total % Received % Xferd Average Speed Time Time Time Current
    2010_01_29_15:06:27 ERROR: Dload Upload Total Spent Left Speed
    2010_01_29_15:06:27 ERROR: 0 31 0 31 0 0 283 0 --:--:-- --:--:-- --:--:-- 283
    2010_01_29_15:06:27 ERROR: 0 31 0 31 0 0 283 0 --:--:-- --:--:-- --:--:-- 0
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 251 0 --:--:-- --:--:-- --:--:-- 251
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 251 0 --:--:-- --:--:-- --:--:-- 0
    2010_01_29_15:06:27 ERROR: Warning: Transient problem: HTTP error Will retry in 1 seconds. 3 retries
    2010_01_29_15:06:27 ERROR: Warning: left.
    2010_01_29_15:06:27 ERROR: Throwing away 51 bytes
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 817 0 --:--:-- --:--:-- --:--:-- 817
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 817 0 --:--:-- --:--:-- --:--:-- 0
    2010_01_29_15:06:27 ERROR: Warning: Transient problem: HTTP error Will retry in 2 seconds. 2 retries
    2010_01_29_15:06:27 ERROR: Warning: left.
    2010_01_29_15:06:27 ERROR: Throwing away 51 bytes
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 363 0 --:--:-- --:--:-- --:--:-- 363
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 363 0 --:--:-- --:--:-- --:--:-- 0
    2010_01_29_15:06:27 ERROR: Warning: Transient problem: HTTP error Will retry in 4 seconds. 1 retries
    2010_01_29_15:06:27 ERROR: Warning: left.
    2010_01_29_15:06:27 ERROR: Throwing away 51 bytes
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 272 0 --:--:-- --:--:-- --:--:-- 272
    2010_01_29_15:06:27 ERROR: 0 51 0 51 0 0 272 0 --:--:-- --:--:-- --:--:-- 0


    It sounds, like you say, that the server is blocked. Is this the web server online, or the ftp server in the actual Tivo? Is there anyway to prevent these drop outs from occuring?
    The odd thing is that I have multiple Tivos, and they fail transfering at the same time. I guess this would confirm that it is an issue with the online web server, although I don't understand why restarting the Tivos would correct the problem. Is there automated scripting that can be done to reset the server if it fails? Thanks for your help!
     
  20. Jan 29, 2010 #1820 of 10413
    miguelakiira

    miguelakiira New Member

    37
    0
    Jan 26, 2010
    ps I took "http" out of the above auto.log
     

Share This Page